Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 728990

Summary: net-dns/opendnssec-1.4.14 - version bump
Product: Gentoo Linux Reporter: Dennis Schridde <devurandom>
Component: Current packagesAssignee: Marc Schiffbauer <mschiff>
Status: CONFIRMED ---    
Severity: normal CC: jstein
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=632570
Whiteboard:
Package list:
Runtime testing required: ---

Description Dennis Schridde 2020-06-21 10:53:10 UTC
According to https://www.opendnssec.org/download/ version 1.4.14 was released on 2017-04-28.  It is the current LTS release.

Please note that even this version will go EOL in about 1 month: https://www.opendnssec.org/2019/10/opendnssec-1-4-end-of-life-upgrading-and-testing-versions/  But maybe this version bump is easier to achieve than bug #632570, which would buy us some time getting version 2.1 to work in Gentoo.

Reproducible: Always
Comment 1 Dennis Schridde 2020-06-21 10:54:34 UTC
(In reply to Dennis Schridde from comment #0)
> Please note that even this version will go EOL in about 1 month:

correction: 3 months
Comment 2 Dennis Schridde 2020-06-22 11:06:38 UTC
This was explicitly to request a bump in the 1.4 release line, which is an LTS branch and thus the only version available in Gentoo that is still being maintained upstream (1.3 and 2.0 are non-LTS branches and thus superseded by 1.4 and 2.1).  The version bump to 2.1.6 is already being tracked in bug #632570.

The assumption was that a bump in a patch-level version (1.4.x) can be done quicker and with less risk than a bump in the minor version (2.x), since the latter would bring new features that have to be tested.  If this assumption is wrong and the bump to 2.1 is only a few days or weeks away, please close this bug as a duplicate of bug #632570.
Comment 3 Marc Schiffbauer gentoo-dev 2020-06-22 11:19:25 UTC
confirmed