Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 72774

Summary: keramik crashed using "-fstack-protector-all"
Product: Gentoo Linux Reporter: meyerm
Component: [OLD] KDEAssignee: PPC Porters <ppc>
Severity: minor CC: kde, niv
Priority: High    
Version: unspecified   
Hardware: PPC   
OS: Linux   
Package list:
Runtime testing required: ---

Description meyerm 2004-11-28 16:05:39 UTC
I've just compiled a new KDE on PPC using "-fstack-protector-all". Now I can't work with KDE. KDM draws its screen but crashed right after starting. KControl can't be started - konqueror works as longs as I don't type anything into the adress toolbar.

In Konqueror it complains about a stach smashing attack in 

  virtual bool KermaikStyle::eventFiller(QObject*, QEvent*)()

. KControl already crashes while initializing with

virtual void KeramikStyle::drawPrimitive(QStyle::PrimitiveElement, QPainter*, const QRect&, const QColorGroup&, uint, const QStyleOption&) const()

. Do you want further informations?

What part should I recompile perhaps without stack-protector? Only QT or also kdebase?


(Severity Minimal since it should work without stack-protector)

Reproducible: Always
Steps to Reproduce:

peggy ~ # emerge info 
Portage 2.0.51-r3 (default-ppc-2004.3, gcc-3.4.3, glibc-, 
2.6.9-pegasos-r2-pegasos ppc) 
System uname: 2.6.9-pegasos-r2-pegasos ppc 7447/7457, altivec supported 
Gentoo Base System version 1.6.6 
Autoconf: sys-devel/autoconf-2.59-r5 
Automake: sys-devel/automake-1.8.5-r1 
Binutils: sys-devel/binutils- 
Headers:  sys-kernel/linux26-headers- 
Libtools: sys-devel/libtool-1.5.2-r7 
CFLAGS="-O2 -mtune=G4 -maltivec -mabi=altivec -fno-strict-aliasing 
-fstack-protector-all -ftracer -pipe" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-O2 -mtune=G4 -maltivec -mabi=altivec -fno-strict-aliasing 
-fstack-protector-all -ftracer -pipe" 
FEATURES="autoaddcvs buildpkg ccache distlocks" 
USE="X acl adns alsa altivec apache2 bash-completion berkdb cdr chroot crypt 
cups divx4linux dvb dvd dvdr encode esd evo exif f77fam flac fortran ftp gdbm 
gif gnome gphoto2 gpm gstreamer gtk gtk2 hardened imagemagick imap imlib 
innodb ipv6 jabber jack java jpeg kde ldap libwww maildir memlimit mng mozilla 
mysql nas ncurses nls nptl offensive oggvorbis openal opengl oscar oss pam 
pcre pda perl php pic pie png posix ppc ppds prelude python qt readline recode 
samba scanner sdl shared sharedmem snmp sockets socks5 sqlite ssl svg sysvipc 
tcpd tetex theora tiff truetype usb vhosts xine xinerama xosd xprint xv xvid 
video_cards_radeon linguas_de"
Comment 1 meyerm 2004-11-29 12:01:24 UTC
I recompiled qt without any stack-protector and with stack-protector and stack-protector-all. The same with kdelibs. Takes a while with my poor PPC... 

After testing out every combination I can say the following: QT is not affected at all and works in all three variants. But kdelibs needs to be compiled WITHOUT stack-protector-all and stack-protector or it will fail (at least here on my PPC).

BTW: The same still applies for arts, but I gave up sending in bug reports for this ;-)
Comment 2 Gregorio Guidi (RETIRED) gentoo-dev 2005-01-10 08:02:54 UTC

ppc herd: can you reproduce it?
Comment 3 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2005-01-15 19:13:23 UTC
I can confirm this bug. This is what I get out of gdb (compiled without debug symbols):

#1  0x0e04eff0 in __stack_smash_handler () from /lib/tls/
#2  0x0df665fc in KeramikStyle::drawPrimitive () from /usr/kde/3.3/lib/kde3/plugins/styles/
#3  0x0df665fc in KeramikStyle::drawPrimitive () from /usr/kde/3.3/lib/kde3/plugins/styles/
#4  0x0df665fc in KeramikStyle::drawPrimitive () from /usr/kde/3.3/lib/kde3/plugins/styles/
Comment 4 Lars Weiler (RETIRED) gentoo-dev 2005-05-07 17:09:17 UTC
From the bugreport I can't see which version of kdebase you tried to compile.  But from the date I guess it was kde-3.3.x.  Did you tried with kde-3.4 yet?
Comment 5 Nicolas Vilz 2005-05-08 18:12:59 UTC
strange... i unmerged kdelibs 3.3.2-r7 and started kdevelop, tried to use some keramik-stuff... it works... crashes seem to be vanished with kdelibs-3.4.0 now...
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2005-05-08 23:05:39 UTC
If it is so, then let's close this bug.
Comment 7 Joe Jezak (RETIRED) gentoo-dev 2005-05-25 23:02:47 UTC