Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 725520

Summary: gnome-base/gnome-shell: test failures (missing testdeps)
Product: Gentoo Linux Reporter: Sam James <sam>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: UNCONFIRMED ---    
Severity: normal Keywords: TESTFAILURE
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: testlog.txt

Description Sam James archtester gentoo-dev Security 2020-05-26 19:58:09 UTC
Created attachment 641954 [details]
testlog.txt

>>> Test phase: gnome-base/gnome-shell-3.34.5
 * Scanning for an open DISPLAY to start Xvfb ...
 * Starting Xvfb on $DISPLAY=1 ...
meson test -C /var/tmp/portage/gnome-base/gnome-shell-3.34.5/work/gnome-shell-3.34.5-build --num-processes 4
ninja: Entering directory `/var/tmp/portage/gnome-base/gnome-shell-3.34.5/work/gnome-shell-3.34.5-build'
ninja: no work to do.
1/6 CSS styling support                     FAIL     2.24 s (killed by signal 11 SIGSEGV)
2/6 insertSorted                            FAIL     3.11 s (exit status 1)
3/6 jsParse                                 OK       1.55 s
4/6 markup                                  FAIL     3.11 s (exit status 1)
5/6 params                                  OK       0.88 s
6/6 url                                     FAIL     2.23 s (exit status 1)

Ok:                    2
Expected Fail:         0
Fail:                  4
Unexpected Pass:       0
Skipped:               0
Timeout:               0

Full log written to /var/tmp/portage/gnome-base/gnome-shell-3.34.5/work/gnome-shell-3.34.5-build/meson-logs/testlog.txt
Comment 1 Sam James archtester gentoo-dev Security 2020-05-26 19:59:03 UTC
Seemed to be fixed by installing gdm[introspection]. Can't recall if the first test was fixed by it, but I think so.