Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 722948

Summary: dev-libs/foma calls ar directly
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Joonas Niilola <juippis>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2020-05-14 08:35:04 UTC
This is an auto-filled bug because dev-libs/foma calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-14 08:35:11 UTC
Created attachment 638816 [details]
build.log

build log and emerge --info
Comment 2 Joonas Niilola gentoo-dev 2020-06-07 08:06:48 UTC
FYI looks like upstream is about to make a new release, so I'll wait for that also in order not to break stable ebuild.
Comment 3 Larry the Git Cow gentoo-dev 2022-08-10 07:41:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3a7a950375b06bd34c861de68c1d67612741c912

commit 3a7a950375b06bd34c861de68c1d67612741c912
Author:     Joonas Niilola <juippis@gentoo.org>
AuthorDate: 2022-08-10 07:40:15 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2022-08-10 07:40:15 +0000

    dev-libs/foma: add 0.10.0_p20220612
    
    Closes: https://bugs.gentoo.org/722948
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 dev-libs/foma/Manifest                     |  1 +
 dev-libs/foma/foma-0.10.0_p20220612.ebuild | 29 +++++++++++++++++++++++++++++
 2 files changed, 30 insertions(+)