Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 722336

Summary: app-misc/dvorak7min fails to compile
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED DUPLICATE    
Severity: normal CC: sam
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=742080
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2020-05-11 07:12:04 UTC
This is an auto-filled bug because app-misc/dvorak7min fails to compile.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-11 07:12:12 UTC
Created attachment 637866 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-09-13 07:45:12 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a70ccb1e002ff4becc0ba79cd3390d73a73d1027

commit a70ccb1e002ff4becc0ba79cd3390d73a73d1027
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-09-13 07:42:32 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-09-13 07:45:06 +0000

    app-misc/dvorak7min: bump to EAPI 7, fix build
    
    * Port to EAPI 7
    * Adopt Debian's patches for some little bug fixes (inc. glibc-2.32)
    * Fix linking with ncurses by using pkgconfig
    
    Closes: https://bugs.gentoo.org/742080
    Closes: https://bugs.gentoo.org/722336
    Closes: https://bugs.gentoo.org/715848
    Closes: https://bugs.gentoo.org/689986
    Closes: https://bugs.gentoo.org/698082
    Closes: https://bugs.gentoo.org/702372
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: Sam James <sam@gentoo.org>

 ...min-1.6.1.ebuild => dvorak7min-1.6.1-r1.ebuild} |  17 +-
 .../files/dvorak7min-1.6.1-debian-changes.patch    | 194 +++++++++++++++++++++
 .../files/dvorak7min-1.6.1-makefile-flags.patch    |  26 +++
 .../dvorak7min-1.6.1-ncurses-pkg-config.patch      |  24 +++
 4 files changed, 255 insertions(+), 6 deletions(-)
Comment 3 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-09-13 07:47:01 UTC

*** This bug has been marked as a duplicate of bug 689986 ***