Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 719172

Summary: dev-libs/openssl-compat-1.0.2u-r2 does not respect LDFLAGS
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Gentoo's Team for Core System packages <base-system>
Status: CONFIRMED ---    
Severity: normal CC: esigra
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 331933    
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2020-04-24 06:25:38 UTC
This is an auto-filled bug because dev-libs/openssl-compat does not respect LDFLAGS.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0".
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-24 06:25:48 UTC
Created attachment 634310 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-09-22 06:48:34 UTC
tinderbox has reproduced this issue with version 1.0.2u-r2 - Updating summary.