Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 719054

Summary: media-video/ffmpeg calls ranlib directly
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: media-video herd <media-video>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: build.log.bz2

Description Agostino Sarubbo gentoo-dev 2020-04-23 14:07:27 UTC
This is an auto-filled bug because media-video/ffmpeg calls ranlib directly.
The issue was originally discovered on x86, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
This issue has been reproduced by setting the RANLIB variable and by removing the /usr/bin/ranlib binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-23 14:07:35 UTC
Created attachment 634192 [details]
build.log.bz2

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-11 15:30:54 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=147420c29c551d482ed150b467fb8ef8bdd33f0e

commit 147420c29c551d482ed150b467fb8ef8bdd33f0e
Author:     Alexis Ballier <aballier@gentoo.org>
AuthorDate: 2020-06-11 15:27:33 +0000
Commit:     Alexis Ballier <aballier@gentoo.org>
CommitDate: 2020-06-11 15:30:38 +0000

    media-video/ffmpeg: pass ranlib to configure too
    
    Closes: https://bugs.gentoo.org/719054
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Alexis Ballier <aballier@gentoo.org>

 media-video/ffmpeg/ffmpeg-9999.ebuild | 1 +
 1 file changed, 1 insertion(+)