Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 71222

Summary: dev-util/intltool missing dep on dev-perl/XML-Parser
Product: Gentoo Linux Reporter: nate grady <nate>
Component: [OLD] LibraryAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description nate grady 2004-11-14 17:02:56 UTC
When I try to emerge dev-util/intltool-0.31.2, it fails during config with:
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

Emergeing dev-perl/XML-Parser prior to intltool fixes the problem.

Reproducible: Always
Steps to Reproduce:
1.emerge =dev-util/intltool-0.31.2
2.
3.

Actual Results:  
ngrady root # emerge =dev-util/intltool-0.31.2 
Calculating dependencies ...done! 
>>> emerge (1 of 1) dev-util/intltool-0.31.2 to / 
>>> md5 src_uri ;-) intltool-0.31.2.tar.bz2 
>>> Unpacking source... 
>>> Unpacking intltool-0.31.2.tar.bz2 to /var/tmp/portage/intltool-0.31.2/work 
>>> Source unpacked. 
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man 
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc 
--localstatedir=/var/lib 
configure: WARNING: If you wanted to set the --build type, don't use --host. 
    If a cross compiler is detected then cross compile mode will be used. 
checking for a BSD-compatible install... /bin/install -c 
checking whether build environment is sane... yes 
checking for gawk... gawk 
checking whether make sets $(MAKE)... yes 
checking for i686-pc-linux-gnu-strip... no 
checking for strip... strip 
checking for perl... /usr/bin/perl 
checking for XML::Parser... configure: error: XML::Parser perl module is 
required for intltool 
 
!!! ERROR: dev-util/intltool-0.31.2 failed. 
!!! Function econf, Line 449, Exitcode 1 
!!! econf failed 
!!! If you need support, post the topmost build error, NOT this status 
message. 
 

Expected Results:  
Software installing. 

Note that I am running inside of a 32-bit chroot from an AMD64 system. In this 
case, I don't see how that could be a difference.  
 
ngrady root # emerge info 
Portage 2.0.51-r3 (default-x86-2004.2, gcc-3.3.4, glibc-2.3.4.20040808-r1, 
2.6.9-gentoo-r1 x86_64) 
================================================================= 
System uname: 2.6.9-gentoo-r1 x86_64 AMD Athlon(tm) 64 Processor 3500+ 
Gentoo Base System version 1.4.16 
Autoconf: sys-devel/autoconf-2.59-r5 
Automake: sys-devel/automake-1.8.5-r1 
Binutils: sys-devel/binutils-2.14.90.0.8-r1 
Headers:  sys-kernel/linux-headers-2.4.21-r1 
Libtools: sys-devel/libtool-1.5.2-r5 
ACCEPT_KEYWORDS="x86" 
AUTOCLEAN="yes" 
CFLAGS="-O2 -march=athlon-xp -msse2 -msse -pipe" 
CHOST="i686-pc-linux-gnu" 
COMPILER="" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-O2 -march=athlon-xp -msse2 -msse -pipe" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoaddcvs ccache distlocks sandbox" 
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com/ 
http://ftp-mirror.internap.com/pub/gentoo/ http://gentoo.binarycompass.org" 
MAKEOPTS="-j2" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="" 
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage" 
USE="3dnow 3dnowex X apm arts avi bcmath berkdb bitmap-fonts blender-game cdb 
cdf codecs crypt cscope cups dnd encode esd f77 faac faad fam ffmpeg flac 
font-server foomaticdb fortran gdbm gif gimp gimpprint gmp gmtsuppl gnome 
gnuplot graphviz gs gtk gtk2 hdf hdf5 iconv imap imlib imlib2 java jce jikes 
jp2 jpeg jpeg2k kde lcms libg++ libwww live lzo lzw lzw-tiff mad maildir 
mikmod mime mmx mmx2 mng motif mozilla moznocompose moznoirc moznomail mozp3p 
mozsvg mpeg mpeg4 mplayer native ncurses network nls noplugin ntlm offensive 
oggvorbis openal opengl oss pam pdf pdfkit pdflib perl png ppds python 
qemu-fast qt quicktime readline real recode rtc sdl slang smime spell ssl svg 
tcpd tetex theora truetype truetype-fonts x86 xanim xine xml2 xmms xv zlib"
Comment 1 Jonathan Adamczewski 2004-11-14 21:10:36 UTC
Can confirm this bug (running on a native x86 system), and that emerging XML-Parser results in succesful merging of intltool.
Comment 2 Joe McCann (RETIRED) gentoo-dev 2004-11-14 23:24:38 UTC
The dep is clearly there, please check or search before filing a bug. 

*** This bug has been marked as a duplicate of 41124 ***