Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 711444

Summary: media-sound/audacity-2.4.2-r1: waveforms view refresh problem with wxGTK-3.0.4
Product: Gentoo Linux Reporter: Nikita Zlobin <cook60020tmp>
Component: Current packagesAssignee: Professional Audio Applications Maintainers <proaudio>
Status: CONFIRMED ---    
Severity: normal CC: alexander, email, fordfrog, jstein, richard
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 736192    
Bug Blocks:    

Description Nikita Zlobin 2020-03-03 17:42:22 UTC
In audacity-2.3.3 entire waveforms view (with all tracks) doesn't redraw until window resize. Although there are very rare cases when it updates without resize, it's so rare, that I still could not catch any pattern.
Downgrade to 2.3.2 solves the problem.
Comment 1 Nikita Zlobin 2020-03-03 17:47:13 UTC
Oh, one note: I have gcc-7.4.0, can't find time to move to later/recent.
Comment 2 Alexander Tsoy 2020-03-14 07:04:13 UTC
Could you try to switch to WX_GTK_VER="3.0" ?
Comment 3 Nikita Zlobin 2020-03-15 22:18:18 UTC
It doesn't seem to make difference. I noticed, that audacity-2.3.3 indeed looks like gtk3 app, than gtk2 (determined by menu style, which has rounded corners for gtk3).

First time, after upgrade from 2.3.2 back to 2.3.3, there where some difference, but now I don't see it. Bug presents both with WX_GTK_VER="3.0" and without.
Comment 4 Nikita Zlobin 2020-03-15 22:22:38 UTC
Oh, and there are two types of Debug messages:
Debug: ScreenToClient cannot work when toplevel window is not shown
Debug: ClientToScreen cannot work when toplevel window is not shown
Comment 5 Miroslav Šulc gentoo-dev 2020-09-19 11:32:26 UTC
please test with 2.4.2-r1 and report back
Comment 6 Miroslav Šulc gentoo-dev 2020-09-26 12:34:07 UTC
no reports, so closing.
Comment 7 Nikita Zlobin 2020-09-28 19:45:37 UTC
Oh, sorry for waiting too late. Slightly was too busy.
I already tried version 2.4.2-r1 with same result. It's rather caused by gtk3. The only solution for me was to modify ebuild for 2.3.3 to build with gtk2.

I reported to upstream just after trying 2.4.2:

Of course, it's only guess that gtk3 is problem - based on fact that 2.3.3 is ok with gtk2.
Comment 8 Miroslav Šulc gentoo-dev 2020-09-29 03:24:01 UTC
thank you for testing it. could you please try with wxGTK-3.1.1? you can find an ebuild in bug #577030.
Comment 9 Nikita Zlobin 2020-09-30 09:56:37 UTC
Will not wxGTK-3.1.3 be enough?
I'm not even sure, that bug #736192 was necessary, since audacity specifies only slot requirement, while wxGTK-3.1.3 is least wxGTK-3.1_gtk3 available.

Yet, I think already tried aud-2.4.2 against wxGTK-3.1.3. Probably after it failed to build against 3.0-gtk3 due to requirement in sources.
Comment 10 Miroslav Šulc gentoo-dev 2020-09-30 12:33:33 UTC
yes, sorry, i meant wxGTK-3.1*
Comment 11 Adrien D 2020-10-04 19:36:16 UTC
Same problem for me with audacity.
I found this bug.
I try to import in my overlay the x11-libs/wxGTK-3.1.3
After emergig it : same problem.
Try to reemerge Audacity : same problem
Comment 12 Adrien D 2020-10-04 20:26:30 UTC
No problem on KDE, but on GNOME i have the issue...
Comment 13 Nikita Zlobin 2020-10-05 08:16:47 UTC
I got working both versions 2.3.3 and 2.4.2 with wxGTK:3.0 (despite official requirements from release notes). No issue.

When I tried 2.3.3 with wxGTK:3.0, one time I got Envelop button (in 3x2 grid at toolbar) all black until hovered, but now it's not.

As for WM, I mostly use xfwm4 with picom, now tried i3 (both with and without picom) - no difference. Btw, it seems resize is not only one way to refresh it for gtk3 version. When project is loaded, layout is drawen, but setting cursor, selection and track resize are not reflected.
Comment 14 Sergey 'L29Ah' Alirzaev 2020-10-06 15:18:12 UTC
I observe the problem on media-sound/audacity-2.4.2-r1 with wxGTK-3.0.4. The window manager is xmonad, if it matters.
Comment 15 Sergey 'L29Ah' Alirzaev 2020-10-06 16:24:28 UTC
It works fine if it's built against gtk2. Maybe an USE flag should be added?

diff --git a/media-sound/audacity/audacity-2.4.2-r1.ebuild b/media-sound/audacity/audacity-2.4.2-r1.ebuild
index 4c5130a8044..69a9d0addfc 100644
--- a/media-sound/audacity/audacity-2.4.2-r1.ebuild
+++ b/media-sound/audacity/audacity-2.4.2-r1.ebuild
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 inherit cmake flag-o-matic wxwidgets xdg
Comment 16 Miroslav Šulc gentoo-dev 2020-10-06 16:53:33 UTC
well, i could switch it just to gtk2 as according to your investigation it is the only version that works reliably, am i right?