Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 707638

Summary: sci-astronomy/predict-2.2.3-r2 : fails to build with -fno-common or gcc-10
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Sci Astronomy Herd <sci-astronomy>
Status: RESOLVED WORKSFORME    
Severity: normal CC: sam
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 705764    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
sci-astronomy:predict-2.2.3-r2:20200131-103817.log

Description Toralf Förster gentoo-dev 2020-01-31 17:43:38 UTC
/usr/include/bits/string_fortified.h:106:10: warning: ‘__builtin_strncpy’ specified bound 256 equals destination size [-Wstringop-truncation]
  106 |   return __builtin___strncpy_chk (__dest, __src, __len, __bos (__dest));
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=native -fno-common -Wall  -Wl,-O1 -Wl,--as-needed -o gsat main.o support.o interface.o callbacks.o comms.o plugins.o db.o prefs.o -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype   -ldl -lm 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: callbacks.o:(.bss+0x8368): multiple definition of `drawmap'; main.o:(.bss+0x8368): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: callbacks.o:(.bss+0x8360): multiple definition of `sourcemap'; main.o:(.bss+0x8360): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop-libressl-20200125-232521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.14.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Fri, 31 Jan 2020 09:32:20 +0000

emerge -qpvO sci-astronomy/predict
[ebuild  N    ] sci-astronomy/predict-2.2.3-r2  USE="gtk nls -doc -xforms -xplanet"
Comment 1 Toralf Förster gentoo-dev 2020-01-31 17:43:41 UTC
Created attachment 609840 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-31 17:43:44 UTC
Created attachment 609842 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-31 17:43:47 UTC
Created attachment 609844 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-31 17:43:50 UTC
Created attachment 609846 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-31 17:43:53 UTC
Created attachment 609848 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-31 17:43:56 UTC
Created attachment 609850 [details]
sci-astronomy:predict-2.2.3-r2:20200131-103817.log
Comment 7 Sam James archtester gentoo-dev Security 2020-11-09 18:26:47 UTC
I actually can't reproduce this, yay?
Comment 8 Toralf Förster gentoo-dev 2020-11-09 19:46:24 UTC
reproduced here at 17.1_desktop-20201031-121706 - shall I attach the files ?
Comment 9 Toralf Förster gentoo-dev 2020-11-09 19:46:47 UTC
(In reply to Toralf Förster from comment #8)
> reproduced here at 17.1_desktop-20201031-121706

Ick, I meant 17.1_desktop-20201031-121706