Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 704496

Summary: sys-fs/fuse-3.9.0 - util/meson.build:19:2: ERROR: Dependency "udev" not found, tried pkgconfig and cmake
Product: Gentoo Linux Reporter: Alexander Hof <gentoobugs>
Component: Current packagesAssignee: Aaron Bauman <bman>
Status: RESOLVED FIXED    
Severity: normal CC: base-system, gentoobugs
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info
emerge -pqv
build log

Description Alexander Hof 2020-01-01 20:19:04 UTC
Issues present since 3.8.0.
Relevant part of the build log:
Run-time dependency udev found: NO (tried pkgconfig and cmake)

util/meson.build:19:2: ERROR: Dependency "udev" not found, tried pkgconfig and cmake

Reproducible: Always
Comment 1 Alexander Hof 2020-01-01 20:20:04 UTC
Created attachment 602228 [details]
emerge --info
Comment 2 Alexander Hof 2020-01-01 20:22:05 UTC
Created attachment 602230 [details]
emerge -pqv
Comment 3 Alexander Hof 2020-01-01 20:23:23 UTC
Created attachment 602232 [details]
build log
Comment 4 Larry the Git Cow gentoo-dev 2020-01-01 22:08:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5b53e4ad77b34e5d223db2ae0abc244caa956933

commit 5b53e4ad77b34e5d223db2ae0abc244caa956933
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2020-01-01 22:04:10 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-01-01 22:08:10 +0000

    sys-fs/fuse: use udevrulesdir option to avoid udev dependency
    
    Closes: https://bugs.gentoo.org/704496
    Package-Manager: Portage-2.3.84_p2, Repoman-2.3.20_p24
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 sys-fs/fuse/fuse-3.8.0.ebuild | 3 ++-
 sys-fs/fuse/fuse-3.9.0.ebuild | 3 ++-
 2 files changed, 4 insertions(+), 2 deletions(-)