Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 702230

Summary: dev-vcs/git-deps: problematic py2→py3 dependency
Product: Gentoo Linux Reporter: Michał Górny <mgorny>
Component: Current packagesAssignee: Nicolas Bock <nicolasbock>
Status: CONFIRMED ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-12-07 07:01:48 UTC
dev-python/pygit2 just dropped Python 2 support entirely.  Since git-deps is Python 2-only, its presence is going to prevent users from upgrading and prevent us from removing the old version once the new one is stable.

If the package supports py3, please add it.  If it doesn't, I will last rite it on the judgement day.

Also, this package hasn't seen a single keyworded ebuild since 2016.  If you think it's useful, please add something people can actually install on their production systems.
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-02-01 06:04:47 UTC
Ping.
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-02-16 07:01:34 UTC
Final ping.