Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 70095

Summary: dhcpStart: ioctl SIOCGIFHWADDR: No such device_ ; "netmount" was not started.
Product: [OLD] Docs-user Reporter: Tomas Mikula <tommik>
Component: Gentoo Linux FAQAssignee: Docs Team <docs-team>
Status: VERIFIED INVALID    
Severity: major    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Tomas Mikula 2004-11-04 14:39:13 UTC
When I boot gentoo from the livecd (2004.2), the network is detected correctly and network connection is available. But, when I boot from hdd, dhcpcd fails. This is an extract from log made by metalog:

Nov  4 22:09:23 [dhcpcd] dhcpStart: ioctl SIOCGIFHWADDR: No such device_
Nov  4 22:09:24 [rc-scripts] ERROR:  Problem starting needed services.
Nov  4 22:09:24 [rc-scripts] "netmount" was not started.


In result of "ifconfig" does not appear the "eth0" section, but there is a "lo" section. If I run "ifconfig" when booted from livecd, both "eth0" and "lo" section appear.

"/etc/conf.d/net" contains:

iface_eth0="dhcp"
dhcpcd_eth0="-HD"

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 SpanKY gentoo-dev 2004-11-04 17:06:03 UTC
looks like you didnt setup all the drivers for your network card
Comment 2 Tomas Mikula 2005-07-21 12:34:46 UTC
I am sorry, that I forgot to come back and mark as CLOSED
Comment 3 Jan Kundrát (RETIRED) gentoo-dev 2005-07-21 13:30:53 UTC
No need for apologies, you don't have to CLOSE.