Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 699854 (CVE-2019-12526, CVE-2019-18678, CVE-2019-18679)

Summary: <net-proxy/squid-4.9: multiple vulnerabilities (CVE-2019-{12526,18678,18679})
Product: Gentoo Security Reporter: GLSAMaker/CVETool Bot <glsamaker>
Component: VulnerabilitiesAssignee: Gentoo Security <security>
Status: IN_PROGRESS ---    
Severity: normal CC: zlogene
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: B2 [glsa cve]
Package list:
Runtime testing required: ---

Description GLSAMaker/CVETool Bot gentoo-dev 2019-11-11 17:39:54 UTC
CVE-2019-12526 (https://nvd.nist.gov/vuln/detail/CVE-2019-12526):
  Due to incorrect buffer management Squid is vulnerable to a heap overflow
  and possible remote code execution attack when processing URN.

CVE-2019-18678 (https://nvd.nist.gov/vuln/detail/CVE-2019-18678):
  Due to incorrect message parsing Squid is vulnerable to an HTTP request
  splitting issue.

CVE-2019-18679 (https://nvd.nist.gov/vuln/detail/CVE-2019-18679):
  Due to incorrect data management Squid is vulnerable to a information
  disclosure when processing HTTP Digest Authentication.
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-11-11 17:41:49 UTC
New GLSA request filed.