Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 699590

Summary: app-eselect/eselect-pinentry-0.7 - selection shows obsolete pinentry-qt4, omits pinentry-fltk
Product: Gentoo Linux Reporter: Anthony Parsons <ant+gentoo.bugs>
Component: Current packagesAssignee: Mikle Kolyada <zlogene>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Anthony Parsons 2019-11-08 00:51:33 UTC
pinentry-qt4 is long obsolete, but confusingly shows up if Qt5 is installed, and there ought to be an entry for pinentry-fltk (since >=app-crypt/pinentry-1.1.0-r2).
Comment 1 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2021-01-25 16:14:49 UTC
pinentry-qt4 was the symlink from pinentry-qt (which was built upon the USE=qt5 selected in pinentry, I've pointhed pinentry-qt to the pinentry-qt5 symlink (leaving a room for qt6), as for fltk, it is really pointless, I have disabled its support.