Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 698756

Summary: app-eselect/eselect-blas-0.2,virtual/{lapack,blas}-3.8,sci-libs/lapack-3.8: stablereq
Product: Gentoo Linux Reporter: Marco Genasci <fedeliallalinea>
Component: StabilizationAssignee: Gentoo Science Related Packages <sci>
Status: RESOLVED FIXED    
Severity: major CC: bd.mail, frp.bissey, luisav.ferreira, martin.zwicknagl, mgorny, ngg, O01eg, paul, redblade7, smopucilowski, tb
Priority: Normal Keywords: STABLEREQ
Version: unspecifiedFlags: nattka: sanity-check+
Hardware: All   
OS: Linux   
URL: https://wiki.gentoo.org/wiki/Blas-lapack-switch
See Also: https://bugs.gentoo.org/show_bug.cgi?id=696256
https://bugs.gentoo.org/show_bug.cgi?id=700196
Whiteboard:
Package list:
app-eselect/eselect-blas-0.2 virtual/lapack-3.8 virtual/blas-3.8 sci-libs/lapack-3.8.0
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 638384, 700196, 714384    

Description Marco Genasci 2019-10-28 15:27:38 UTC
When install sci-libs/lapack-reference a error (that not stop installation phases) occurs when eselect lapack add command is runned in src_install function

make[2]: Leaving directory '/var/tmp/portage/sci-libs/lapack-reference-3.2.1-r4/work/lapack-3.2.1'
make[1]: Leaving directory '/var/tmp/portage/sci-libs/lapack-reference-3.2.1-r4/work/lapack-3.2.1'
!!! Error: invalid lapack libdir!
exiting
>>> Completed installing sci-libs/lapack-reference-3.2.1-r4 into /var/tmp/portage/sci-libs/lapack-reference-3.2.1-r4/image/

 * Final size of build directory: 84612 KiB (82.6 MiB)
 * Final size of installed tree:  14008 KiB (13.6 MiB)

This prevent the creation of /etc/env.d/lapack/{lib,lib64}.

The =app-eselect/eselect-lapack-0.1 not cause the problem.

It's seems same problem also appears with app-eselect/eselect-blas-0.2.

Reference:
https://forums.gentoo.org/viewtopic-p-8382584.html#8382584

Reproducible: Always
Comment 1 François Bissey 2019-10-28 20:09:51 UTC
That version of eselect should have gone stable with the latest versions of blas/lapack. I don't think they are compatible with earlier ones.
I have dealt with the issue with someone using sabayon earlier this year.
Comment 2 Benda Xu gentoo-dev 2019-10-29 09:32:58 UTC
Hi Marco, do you have virtual/blas-3.8 and virtual/lapack-3.8 installed?
Comment 3 Marco Genasci 2019-10-29 10:02:39 UTC
(In reply to Benda Xu from comment #2)
> Hi Marco, do you have virtual/blas-3.8 and virtual/lapack-3.8 installed?

No, I'm in a stable system the I have virtual/lapack-3.1 and virtual/blas-1.0
Comment 4 Martin Zwicknagl 2019-10-29 17:43:13 UTC
Hello all,

I have exactly the same problem as Marco Genasci. I am on stable with lapack-reference-3.2.1-r4.

make[1]: Leaving directory '/var/tmp/portage/sci-libs/lapack-reference-3.2.1-r4/work/lapack-3.2.1'
!!! Error: invalid lapack libdir!
exiting

Therefore I can not install sci-libs/arpack-3.1.5

When I mask eselect-lapack-0.2 and install eselect-lapack-0.1 everything emerges fine.
Comment 5 Benda Xu gentoo-dev 2019-10-30 14:50:21 UTC
Hi Arch-testers.  It turns out that app-eselect/lapack-0.2 and app-eselect/eselect-blas-0.2, virtual/lapack-3.8, virtual/blas-3.8, sci-libs/lapack-3.8 should be stabilized at once.

Why they were not expressed in dependencies?  We wanted to avoid dependency circles.  Either old-eselect-lapack + new-lapack or new-eselect-lapack + old-lapack will break.  So let's just stabilize them in synchronization to lower this upgrade impact.

Thanks!
Comment 6 Stabilization helper bot gentoo-dev 2019-10-30 15:00:53 UTC
An automated check of this bug failed - the following atom is unknown:

sci-libs/lapack-3.8

Please verify the atom list.
Comment 7 Stabilization helper bot gentoo-dev 2019-10-30 16:03:05 UTC
An automated check of this bug failed - repoman reported dependency errors (89 lines truncated): 

> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm(default/linux/arm/17.0) ['>=app-eselect/eselect-lapack-0.2']
> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['>=app-eselect/eselect-lapack-0.2']
> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0) ['>=app-eselect/eselect-lapack-0.2']
Comment 8 Benda Xu gentoo-dev 2019-10-31 03:01:30 UTC
(In reply to Stabilization helper bot from comment #7)
> An automated check of this bug failed - repoman reported dependency errors
> (89 lines truncated): 
> 
> > dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm(default/linux/arm/17.0) ['>=app-eselect/eselect-lapack-0.2']
> > dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['>=app-eselect/eselect-lapack-0.2']
> > dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0) ['>=app-eselect/eselect-lapack-0.2']

This is false positive in our case because app-eselect/lapack-0.2 is to be stabilized together with sci-libs/lapack-3.8.0.
Comment 9 Thomas Deutschmann (RETIRED) gentoo-dev 2019-10-31 23:51:13 UTC
x86 stable
Comment 10 Stabilization helper bot gentoo-dev 2019-11-01 00:06:34 UTC
An automated check of this bug failed - repoman reported dependency errors (89 lines truncated): 

> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm(default/linux/arm/17.0) ['>=app-eselect/eselect-lapack-0.2']
> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['>=app-eselect/eselect-lapack-0.2']
> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0) ['>=app-eselect/eselect-lapack-0.2']
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-11-01 11:14:12 UTC
arm stable
Comment 12 Stabilization helper bot gentoo-dev 2019-11-01 12:04:00 UTC
An automated check of this bug failed - repoman reported dependency errors (25 lines truncated): 

> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0) ['>=app-eselect/eselect-lapack-0.2']
> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: RDEPEND: arm64(default/linux/arm64/17.0) ['>=app-eselect/eselect-lapack-0.2']
> dependency.bad sci-libs/lapack/lapack-3.8.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0/desktop) ['>=app-eselect/eselect-lapack-0.2']
Comment 13 Benda Xu gentoo-dev 2019-11-13 08:49:35 UTC
Ping Arch testers.  Would you please stabilize the listed packages?  Thank you!
Comment 14 Benda Xu gentoo-dev 2019-11-13 08:50:47 UTC
*** Bug 699726 has been marked as a duplicate of this bug. ***
Comment 15 Benda Xu gentoo-dev 2019-11-13 08:53:49 UTC
*** Bug 699816 has been marked as a duplicate of this bug. ***
Comment 16 Thomas Beutin 2019-11-13 16:33:47 UTC
*** Bug 700022 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Beutin 2019-11-15 11:24:47 UTC
Hm, this doesn't seem to work for me:


# eselect lapack list
Available LAPACK (lib32) candidates:
  (none found)
Available LAPACK (lib64) candidates:
  [1]   reference *

# eselect blas list                                                                                                                                                                                                          
Available BLAS/CBLAS (lib32) candidates:
  (none found)
Available BLAS/CBLAS (lib64) candidates:
  (none found)


Installed packages are:
app-eselect/eselect-blas-0.2,virtual/{lapack.blas}-3.8,sci-libs/lapack-3.8


Having this on my machine, i'm unable to compile media-libs/opencv-3.4.1 anymore:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_zgemm'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_sgemm'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_dgemm'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_cgemm'
Comment 18 Benda Xu gentoo-dev 2019-11-15 12:30:36 UTC
(In reply to Thomas Beutin from comment #17)
> Hm, this doesn't seem to work for me:
> 
> 
> # eselect lapack list
> Available LAPACK (lib32) candidates:
>   (none found)
> Available LAPACK (lib64) candidates:
>   [1]   reference *
> 
> # eselect blas list                                                         
> 
> Available BLAS/CBLAS (lib32) candidates:
>   (none found)
> Available BLAS/CBLAS (lib64) candidates:
>   (none found)
> 
> 
> Installed packages are:
> app-eselect/eselect-blas-0.2,virtual/{lapack.blas}-3.8,sci-libs/lapack-3.8
> 
> 
> Having this on my machine, i'm unable to compile media-libs/opencv-3.4.1
> anymore:
> /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/
> ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_zgemm'
> /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/
> ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_sgemm'
> /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/
> ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_dgemm'
> /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/
> ld: lib/libopencv_core.so.3.4.1: undefined reference to `cblas_cgemm'

Hi Thomas.  Sorry I cannot reproduce your bug with opencv-3.4.1-r6.  Please file a separate bug with full build.log, `emerge --info` and `emerge -pv opencv` attached.
Comment 19 Agostino Sarubbo gentoo-dev 2019-11-15 12:47:50 UTC
amd64 stable
Comment 20 Thomas Beutin 2019-11-15 14:31:48 UTC
(In reply to Benda Xu from comment #18)
> (In reply to Thomas Beutin from comment #17)
[...]
> Hi Thomas.  Sorry I cannot reproduce your bug with opencv-3.4.1-r6.  Please
> file a separate bug with full build.log, `emerge --info` and `emerge -pv
> opencv` attached.

it's here: bug 700176 - build.log will follow in a minute.

But shouldn't bring
# eselect blas list
at least something instead of nothing?
Comment 21 Marco Genasci 2019-11-15 15:01:23 UTC
Also sci-libs/gsl-2.5.1-r1 need to be stabilized

# emerge -uUDt @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] dev-python/numpy-1.16.1::gentoo  USE="lapack -doc -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7" 
[ebuild     U  ]  virtual/lapack-3.8::gentoo [3.1::gentoo] USE="-eselect-ldso%" 0 KiB
[ebuild     U ~] kde-misc/latte-dock-0.9.4::gentoo [0.9.2::gentoo] USE="-debug" 696 KiB
[nomerge       ] virtual/lapack-3.8::gentoo [3.1::gentoo] USE="-eselect-ldso%" 
[ebuild  N     ]  sci-libs/lapack-3.8.0::gentoo  USE="-doc -eselect-ldso -lapacke" 7,253 KiB
[nomerge       ] sci-libs/gsl-2.5:0/23::gentoo  USE="deprecated -cblas-external -static-libs" 
[ebuild  N     ]  app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[blocks B      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-3.8.0)
Comment 22 hagar-dunor 2019-11-15 16:31:36 UTC
It's a bit messy it seems

gentoo-plasma ~ # emerge -p sci-libs/cblas-reference

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-cblas-0.1
[ebuild  N     ] sci-libs/lapack-3.8.0  USE="-doc -eselect-ldso -lapacke"
[ebuild  N     ] virtual/blas-3.8  USE="-eselect-ldso"
[ebuild  N     ] sci-libs/cblas-reference-20030223-r6
[blocks B      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-3.8.0)
[blocks B      ] sci-libs/cblas-reference ("sci-libs/cblas-reference" is blocking sci-libs/lapack-3.8.0)
Comment 23 Thomas Beutin 2019-11-15 16:38:48 UTC
(In reply to hagar-dunor from comment #22)
> It's a bit messy it seems
> 
> gentoo-plasma ~ # emerge -p sci-libs/cblas-reference
[...]

if i got this right, then sci-libs/lapack-3.8.x replaces the splitted reference ebuilds:

$ eix sci-libs/lapack$
[I] sci-libs/lapack
     Available versions:  (~)3.8.0{tbz2} {doc eselect-ldso lapacke}
     Installed versions:  3.8.0{tbz2}(14:59:04 14/11/19)(eselect-ldso lapacke -doc)
     Homepage:            http://www.netlib.org/lapack/
     Description:         BLAS,CBLAS,LAPACK,LAPACKE reference implementations
Comment 24 ngg 2019-11-15 17:29:49 UTC
Stabilizing virtual/blas-3.8 broke existing cblas installations.
I had sci-libs/cblas-reference, sci-libs/blas-reference, sci-libs/lapack-reference installed previously, now virtual/blas-3.8 requires sci-libs/lapack but that conflicts with sci-libs/cblas-reference which is still required by virtual/cblas-1.0.
Keywording virtual/cblas-3.8 solved this for me locally.
Comment 25 Red 2019-11-15 17:43:25 UTC
(In reply to ngg from comment #24)
> Stabilizing virtual/blas-3.8 broke existing cblas installations.
> I had sci-libs/cblas-reference, sci-libs/blas-reference,
> sci-libs/lapack-reference installed previously, now virtual/blas-3.8
> requires sci-libs/lapack but that conflicts with sci-libs/cblas-reference
> which is still required by virtual/cblas-1.0.
> Keywording virtual/cblas-3.8 solved this for me locally.

Having this same problem but keywording virtual/cblas-3.8 did nothing.
Comment 26 Red 2019-11-15 18:01:55 UTC
(In reply to Red from comment #25)
> (In reply to ngg from comment #24)
> > Stabilizing virtual/blas-3.8 broke existing cblas installations.
> > I had sci-libs/cblas-reference, sci-libs/blas-reference,
> > sci-libs/lapack-reference installed previously, now virtual/blas-3.8
> > requires sci-libs/lapack but that conflicts with sci-libs/cblas-reference
> > which is still required by virtual/cblas-1.0.
> > Keywording virtual/cblas-3.8 solved this for me locally.
> 
> Having this same problem but keywording virtual/cblas-3.8 did nothing.

In order to have emerge -DNua @world complete properly after this, I had to uninstall kde-apps/kde-apps-meta, kde-apps/kdeedu-meta, kde-apps/step, and sci-libs/gsl, which can no longer be installed because of the block.
Comment 27 ngg 2019-11-15 18:13:16 UTC
(In reply to Red from comment #26)
> (In reply to Red from comment #25)
> > (In reply to ngg from comment #24)
> > > Stabilizing virtual/blas-3.8 broke existing cblas installations.
> > > I had sci-libs/cblas-reference, sci-libs/blas-reference,
> > > sci-libs/lapack-reference installed previously, now virtual/blas-3.8
> > > requires sci-libs/lapack but that conflicts with sci-libs/cblas-reference
> > > which is still required by virtual/cblas-1.0.
> > > Keywording virtual/cblas-3.8 solved this for me locally.
> > 
> > Having this same problem but keywording virtual/cblas-3.8 did nothing.
> 
> In order to have emerge -DNua @world complete properly after this, I had to
> uninstall kde-apps/kde-apps-meta, kde-apps/kdeedu-meta, kde-apps/step, and
> sci-libs/gsl, which can no longer be installed because of the block.

sci-libs/gsl can be used if cblas-external use-flag is set.

But I have some problem regarding /usr/lib64/libcblas.so.0 which was previously existing but now it's not (creating libcblas.so.0 -> libcblas.so.3 symlink manually works)
Comment 28 Andreas K. Hüttel archtester gentoo-dev 2019-11-15 18:30:54 UTC
(In reply to Marco Genasci from comment #21)
> Also sci-libs/gsl-2.5.1-r1 need to be stabilized
> 
^ this

Earlier gsl needs app-eselect/eselect-cblas, which blocks lapack-3.8
Comment 29 Marco Genasci 2019-11-15 19:17:43 UTC
(In reply to Andreas K. Hüttel from comment #28)
> (In reply to Marco Genasci from comment #21)
> > Also sci-libs/gsl-2.5.1-r1 need to be stabilized
> > 
> ^ this
> 
> Earlier gsl needs app-eselect/eselect-cblas, which blocks lapack-3.8

Exactly, so my question is: would not be to stabilize this version?
Comment 30 Red 2019-11-15 20:25:41 UTC
(In reply to ngg from comment #27)
> (In reply to Red from comment #26)
> > (In reply to Red from comment #25)
> > > (In reply to ngg from comment #24)
> > > > Stabilizing virtual/blas-3.8 broke existing cblas installations.
> > > > I had sci-libs/cblas-reference, sci-libs/blas-reference,
> > > > sci-libs/lapack-reference installed previously, now virtual/blas-3.8
> > > > requires sci-libs/lapack but that conflicts with sci-libs/cblas-reference
> > > > which is still required by virtual/cblas-1.0.
> > > > Keywording virtual/cblas-3.8 solved this for me locally.
> > > 
> > > Having this same problem but keywording virtual/cblas-3.8 did nothing.
> > 
> > In order to have emerge -DNua @world complete properly after this, I had to
> > uninstall kde-apps/kde-apps-meta, kde-apps/kdeedu-meta, kde-apps/step, and
> > sci-libs/gsl, which can no longer be installed because of the block.
> 
> sci-libs/gsl can be used if cblas-external use-flag is set.
> 
> But I have some problem regarding /usr/lib64/libcblas.so.0 which was
> previously existing but now it's not (creating libcblas.so.0 ->
> libcblas.so.3 symlink manually works)

Adding USE=cblas-external to make.conf and adding to package.accept_keywords:

=virtual/cblas-3.8 ~amd64
=sci-libs/gsl-2.5-r1 ~amd64

makes everything work properly again. Thank you!
Comment 31 Faraclas 2019-11-15 22:07:49 UTC
> Adding USE=cblas-external to make.conf and adding to package.accept_keywords:
> 
> =virtual/cblas-3.8 ~amd64
> =sci-libs/gsl-2.5-r1 ~amd64
> 
> makes everything work properly again. Thank you!

I can confirm that this worked for me as well with the following message:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below).
 * 
 * Detected file collision(s):
 * 
 * 	/usr/include/cblas.h
 * 	/usr/lib64/pkgconfig/cblas.pc
 * 	/usr/lib64/pkgconfig/blas.pc
 * 	/usr/lib64/pkgconfig/lapack.pc
 * 	/usr/lib64/liblapack.so
 * 	/usr/lib64/libcblas.so
 * 	/usr/lib64/libblas.so
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * None of the installed packages claim the file(s).
 * 
 * Package 'sci-libs/lapack-3.8.0' merged despite file collisions. If
 * necessary, refer to your elog messages for the whole content of the
 * above message.

I am not sure if this matters or not.
Comment 32 Benda Xu gentoo-dev 2019-11-16 01:51:02 UTC
(In reply to Red from comment #30)
> 
> Adding USE=cblas-external to make.conf and adding to package.accept_keywords:
> 
> =virtual/cblas-3.8 ~amd64
> =sci-libs/gsl-2.5-r1 ~amd64
> 
> makes everything work properly again. Thank you!

Red has given the solution to this bug.  Please refer to bug 700196 for stabilization of virtual/cblas-3.8 and sci-libs/gsl-2.5-r1.
Comment 33 Tomek L 2019-11-16 12:43:50 UTC
I can't install scipy because of package collision 

[ebuild  N     ]  sci-libs/scipy-1.1.0::gentoo  USE="-doc -sparse -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 0 KiB
[ebuild  N     ]   virtual/cblas-1.0::gentoo  0 KiB
[ebuild  N     ]    sci-libs/cblas-reference-20030223-r6::gentoo  0 KiB
[ebuild  N     ]     virtual/blas-3.8::gentoo  USE="-eselect-ldso" 0 KiB
[ebuild  N     ]   virtual/lapack-3.8::gentoo  USE="-eselect-ldso" 0 KiB
[ebuild  N     ]    sci-libs/lapack-3.8.0::gentoo  USE="-doc -eselect-ldso -lapacke" 7,253 KiB
[nomerge       ] sci-libs/cblas-reference-20030223-r6::gentoo
[ebuild  N     ]  app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[blocks B      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-3.8.0)
[blocks B      ] sci-libs/cblas-reference ("sci-libs/cblas-reference" is blocking sci-libs/lapack-3.8.0)

Total: 7 packages (7 new), Size of downloads: 7,253 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sci-libs/cblas-reference-20030223-r6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sci-libs/cblas-reference required by (virtual/cblas-1.0:0/0::gentoo, ebuild scheduled for merge)

  (sci-libs/lapack-3.8.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sci-libs/lapack-3.8.0[eselect-ldso?] (>=sci-libs/lapack-3.8.0) required by (virtual/lapack-3.8:0/0::gentoo, ebuild scheduled for merge)
    >=sci-libs/lapack-3.8[eselect-ldso?] (>=sci-libs/lapack-3.8) required by (virtual/blas-3.8:0/0::gentoo, ebuild scheduled for merge)
Comment 34 Benda Xu gentoo-dev 2019-11-16 15:32:35 UTC
(In reply to Tomek L from comment #33)
> I can't install scipy because of package collision 

Hi Tomek, please refer to https://bugs.gentoo.org/698756#c30 and bug 700196.
Comment 35 Richard Ostrow 2019-11-16 19:59:15 UTC
(In reply to Benda Xu from comment #34)
> (In reply to Tomek L from comment #33)
> > I can't install scipy because of package collision 
> 
> Hi Tomek, please refer to https://bugs.gentoo.org/698756#c30 and bug 700196.

Same problem, unmasking the following does not solve:

=virtual/cblas-3.8 ~amd64
=sci-libs/gsl-2.5-r1 ~amd64
Comment 36 Richard Ostrow 2019-11-16 20:03:54 UTC
Clarification, I get the following when attempting to update:

# emerge -pv virtual/cblas

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-eselect/eselect-blas-0.2::gentoo [0.1::gentoo] 0 KiB
[ebuild  N     ] sci-libs/lapack-3.8.0::gentoo  USE="eselect-ldso -doc -lapacke" 7,253 KiB
[uninstall     ] app-eselect/eselect-cblas-0.1::gentoo 
[blocks b      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-3.8.0)
[uninstall     ] sci-libs/cblas-reference-20030223-r6::gentoo 
[blocks b      ] sci-libs/cblas-reference ("sci-libs/cblas-reference" is blocking sci-libs/lapack-3.8.0)
[ebuild     U ~] virtual/cblas-3.8::gentoo [1.0::gentoo] USE="-eselect-ldso%" 0 KiB
[blocks B      ] sci-libs/lapack-reference ("sci-libs/lapack-reference" is blocking sci-libs/lapack-3.8.0)
[blocks B      ] sci-libs/blas-reference ("sci-libs/blas-reference" is blocking sci-libs/lapack-3.8.0)

Total: 3 packages (2 upgrades, 1 new, 2 uninstalls), Size of downloads: 7,253 KiB
Conflict: 4 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sci-libs/lapack-reference-3.2.1-r4:0/0::gentoo, installed) pulled in by
    >=sci-libs/lapack-reference-3.1 required by (virtual/lapack-3.1:0/0::gentoo, installed)

  (sci-libs/lapack-3.8.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sci-libs/lapack-3.8.0[eselect-ldso?] (>=sci-libs/lapack-3.8.0) required by (virtual/cblas-3.8:0/0::gentoo, ebuild scheduled for merge)

  (sci-libs/blas-reference-20070226-r4:0/0::gentoo, installed) pulled in by
    sci-libs/blas-reference required by (virtual/blas-1.0:0/0::gentoo, installed)
Comment 37 Richard Ostrow 2019-11-16 20:07:12 UTC
Sorry to pollute this bug... running an "emerge -avuDN @world" resolved the blockers
Comment 38 Agostino Sarubbo gentoo-dev 2019-11-20 11:27:59 UTC
ppc stable
Comment 39 Agostino Sarubbo gentoo-dev 2019-11-20 11:35:33 UTC
ia64 stable
Comment 40 Aaron Bauman (RETIRED) gentoo-dev 2019-11-24 04:24:50 UTC
arm64 stable
Comment 41 onkobu 2019-11-29 17:51:10 UTC
(In reply to Richard Ostrow from comment #36)
> Clarification, I get the following when attempting to update:
> 
> # emerge -pv virtual/cblas
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild     U  ] app-eselect/eselect-blas-0.2::gentoo [0.1::gentoo] 0 KiB
> [ebuild  N     ] sci-libs/lapack-3.8.0::gentoo  USE="eselect-ldso -doc
> -lapacke" 7,253 KiB
> [uninstall     ] app-eselect/eselect-cblas-0.1::gentoo 
> [blocks b      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is
> blocking sci-libs/lapack-3.8.0)
> [uninstall     ] sci-libs/cblas-reference-20030223-r6::gentoo 
> [blocks b      ] sci-libs/cblas-reference ("sci-libs/cblas-reference" is
> blocking sci-libs/lapack-3.8.0)
> [ebuild     U ~] virtual/cblas-3.8::gentoo [1.0::gentoo]
> USE="-eselect-ldso%" 0 KiB
> [blocks B      ] sci-libs/lapack-reference ("sci-libs/lapack-reference" is
> blocking sci-libs/lapack-3.8.0)
> [blocks B      ] sci-libs/blas-reference ("sci-libs/blas-reference" is
> blocking sci-libs/lapack-3.8.0)
> 
> Total: 3 packages (2 upgrades, 1 new, 2 uninstalls), Size of downloads:
> 7,253 KiB
> Conflict: 4 blocks (2 unsatisfied)
> 
>  * Error: The above package list contains packages which cannot be
>  * installed at the same time on the same system.
> 
>   (sci-libs/lapack-reference-3.2.1-r4:0/0::gentoo, installed) pulled in by
>     >=sci-libs/lapack-reference-3.1 required by
> (virtual/lapack-3.1:0/0::gentoo, installed)
> 
>   (sci-libs/lapack-3.8.0:0/0::gentoo, ebuild scheduled for merge) pulled in
> by
>     >=sci-libs/lapack-3.8.0[eselect-ldso?] (>=sci-libs/lapack-3.8.0)
> required by (virtual/cblas-3.8:0/0::gentoo, ebuild scheduled for merge)
> 
>   (sci-libs/blas-reference-20070226-r4:0/0::gentoo, installed) pulled in by
>     sci-libs/blas-reference required by (virtual/blas-1.0:0/0::gentoo,
> installed)

Looks the same for me but suggestion to solve with emerge -avuDN @world didn't work out. Still blocked (amd64) with no means of resolving it other than masking lapack-3.8.0 (and postponing update).
Comment 42 Benda Xu gentoo-dev 2019-11-30 07:52:17 UTC
(In reply to onkobu from comment #41)
> 
> Looks the same for me but suggestion to solve with emerge -avuDN @world
> didn't work out. Still blocked (amd64) with no means of resolving it other
> than masking lapack-3.8.0 (and postponing update).

Please paste your exact portage block message.

And / or, try remove cblas-reference, blas-reference and lapack-reference manually first.
Comment 43 Benda Xu gentoo-dev 2019-11-30 07:52:36 UTC
(In reply to onkobu from comment #41)
> 
> Looks the same for me but suggestion to solve with emerge -avuDN @world
> didn't work out. Still blocked (amd64) with no means of resolving it other
> than masking lapack-3.8.0 (and postponing update).

Please paste your exact portage block message.

And / or, try to remove cblas-reference, blas-reference and lapack-reference manually first.
Comment 44 Sergei Trofimovich (RETIRED) gentoo-dev 2019-12-01 14:13:12 UTC
ppc64 stable
Comment 45 onkobu 2019-12-02 20:22:00 UTC
(In reply to Benda Xu from comment #43)
> (In reply to onkobu from comment #41)
> > 
> > Looks the same for me but suggestion to solve with emerge -avuDN @world
> > didn't work out. Still blocked (amd64) with no means of resolving it other
> > than masking lapack-3.8.0 (and postponing update).
> 
> Please paste your exact portage block message.
> 
> And / or, try to remove cblas-reference, blas-reference and lapack-reference
> manually first.

It is caused by numpy with USE lapack. I added this for gnuradio. Will remove this bit by bit.
Comment 46 Benda Xu gentoo-dev 2019-12-03 01:27:19 UTC
(In reply to onkobu from comment #45)
> (In reply to Benda Xu from comment #43)
> > 
> > Please paste your exact portage block message.
> > 
> > And / or, try to remove cblas-reference, blas-reference and lapack-reference
> > manually first.
> 
> It is caused by numpy with USE lapack. I added this for gnuradio. Will
> remove this bit by bit.

dev-python/numpy[lapack] depends on virtual/lapack, and can be provided version 3.8.  If you remove cblas-reference, blas-reference and lapack-reference manually first, and install sci-libs/lapack, dependents will continue to work.

Please read https://wiki.gentoo.org/wiki/Blas-lapack-switch for details.
Comment 47 Bill 2019-12-03 18:03:45 UTC
I can not emerge numpy.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[ebuild  N     ] sci-libs/lapack-3.8.0::gentoo  USE="-doc -eselect-ldso -lapacke" 0 KiB
[ebuild  N     ] virtual/lapack-3.8::gentoo  USE="-eselect-ldso" 0 KiB
[ebuild  N     ] virtual/blas-3.8::gentoo  USE="-eselect-ldso" 0 KiB
[ebuild  N     ] sci-libs/cblas-reference-20030223-r6::gentoo  0 KiB
[ebuild  N     ] virtual/cblas-1.0::gentoo  0 KiB
[ebuild   R    ] dev-python/numpy-1.14.5::gentoo  USE="lapack -doc -test" PYTHON_TARGETS="python2_7 -python3_5 -python3_6 (-python3_7)" 0 KiB
[blocks B      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-3.8.0)
[blocks B      ] sci-libs/cblas-reference ("sci-libs/cblas-reference" is blocking sci-libs/lapack-3.8.0)

Total: 7 packages (6 new, 1 reinstall), Size of downloads: 0 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sci-libs/cblas-reference-20030223-r6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sci-libs/cblas-reference required by (virtual/cblas-1.0:0/0::gentoo, ebuild scheduled for merge)

  (sci-libs/lapack-3.8.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sci-libs/lapack-3.8[eselect-ldso?] (>=sci-libs/lapack-3.8) required by (virtual/blas-3.8:0/0::gentoo, ebuild scheduled for merge)
    >=sci-libs/lapack-3.8.0[eselect-ldso?] (>=sci-libs/lapack-3.8.0) required by (virtual/lapack-3.8:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

After following instructions here:

https://wiki.gentoo.org/wiki/Blas-lapack-switch

AsusTux /etc/portage # eselect blas list
Available BLAS/CBLAS (lib) candidates:
  [1]   reference *
AsusTux /etc/portage # eselect lapack list
Available LAPACK (lib) candidates:
  [1]   reference *

AsusTux /etc/portage # emerge -pv numpy

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[ebuild  N     ] sci-libs/cblas-reference-20030223-r6::gentoo  0 KiB
[ebuild  N     ] virtual/cblas-1.0::gentoo  0 KiB
[ebuild   R    ] dev-python/numpy-1.14.5::gentoo  USE="lapack -doc -test" PYTHON_TARGETS="python2_7 -python3_5 -python3_6 (-python3_7)" 0 KiB
[blocks B      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-3.8.0)
[blocks B      ] sci-libs/cblas-reference ("sci-libs/cblas-reference" is blocking sci-libs/lapack-3.8.0)

Total: 4 packages (3 new, 1 reinstall), Size of downloads: 0 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sci-libs/lapack-3.8.0:0/0::gentoo, installed) pulled in by
    >=sci-libs/lapack-3.8[eselect-ldso?] (>=sci-libs/lapack-3.8[eselect-ldso]) required by (virtual/blas-3.8:0/0::gentoo, installed)
    >=sci-libs/lapack-3.8.0[eselect-ldso?] (>=sci-libs/lapack-3.8.0[eselect-ldso]) required by (virtual/lapack-3.8:0/0::gentoo, installed)

  (sci-libs/cblas-reference-20030223-r6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sci-libs/cblas-reference required by (virtual/cblas-1.0:0/0::gentoo, ebuild scheduled for merge)
Comment 48 François Bissey 2019-12-03 18:46:31 UTC
virtual/cblas-1.0 is causing your problem. You need 3.8. It is correctly only stable on amd64, which arch are you on?
Comment 49 Bill 2019-12-03 19:03:38 UTC
(In reply to François Bissey from comment #48)
> virtual/cblas-1.0 is causing your problem. You need 3.8. It is correctly
> only stable on amd64, which arch are you on?

I am on x86.  I will try to unmask it.  Thanks.
Comment 50 Bill 2019-12-03 19:49:19 UTC
(In reply to Bill from comment #49)
> (In reply to François Bissey from comment #48)
> > virtual/cblas-1.0 is causing your problem. You need 3.8. It is correctly
> > only stable on amd64, which arch are you on?
> 
> I am on x86.  I will try to unmask it.  Thanks.

Ok it builds, hopfully works.  Thanks.
Comment 51 Red 2019-12-14 22:12:50 UTC
(In reply to Benda Xu from comment #32)
> (In reply to Red from comment #30)
> > 
> > Adding USE=cblas-external to make.conf and adding to package.accept_keywords:
> > 
> > =virtual/cblas-3.8 ~amd64
> > =sci-libs/gsl-2.5-r1 ~amd64
> > 
> > makes everything work properly again. Thank you!
> 
> Red has given the solution to this bug.  Please refer to bug 700196 for
> stabilization of virtual/cblas-3.8 and sci-libs/gsl-2.5-r1.

Glad I was able to help!
Comment 52 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-12-24 20:03:31 UTC
alpha stable
Comment 53 Benda Xu gentoo-dev 2019-12-25 08:03:51 UTC
Thank you so much to all who have contributed to solving this long standing bug!  Happy Christmas holiday!
Comment 54 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-05-17 19:51:47 UTC
Someone missed hppa.
Comment 55 Agostino Sarubbo gentoo-dev 2020-05-20 06:25:43 UTC
sparc stable
Comment 56 Rolf Eike Beer archtester 2020-06-01 20:06:41 UTC
hppa stable. Last arch, closing.