Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 692810

Summary: games-engines/frotz-2.43-r1 : /.../ld: src/frotz_curses.a(ux_input.o): undefined reference to symbol erasechar
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Games <games>
Status: RESOLVED DUPLICATE    
Severity: normal CC: esigra, redblade7
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 457530    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
games-engines:frotz-2.43-r1:20190823-224702.log
temp.tbz2

Description Toralf Förster gentoo-dev 2019-08-24 08:19:01 UTC
cc -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o frotz src/frotz_common.a src/frotz_curses.a  -lcurses \
	
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: src/frotz_curses.a(ux_input.o): undefined reference to symbol 'erasechar'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [Makefile:165: frotz-curses] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_developer-20190820-161702

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
  [3]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.37.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.13.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO games-engines/frotz
[ebuild  N    ] games-engines/frotz-2.43-r1  USE="alsa oss"
Comment 1 Toralf Förster gentoo-dev 2019-08-24 08:19:04 UTC
Created attachment 587914 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-08-24 08:19:07 UTC
Created attachment 587916 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-08-24 08:19:10 UTC
Created attachment 587918 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-08-24 08:19:12 UTC
Created attachment 587920 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-08-24 08:19:15 UTC
Created attachment 587922 [details]
games-engines:frotz-2.43-r1:20190823-224702.log
Comment 6 Toralf Förster gentoo-dev 2019-08-24 08:19:18 UTC
Created attachment 587924 [details]
temp.tbz2
Comment 7 Red 2019-08-28 11:47:03 UTC
Is this a duplicate of #677778?

I had the same problems, and as outlined in this forum post:

http://www.pclinuxos.com/forum/index.php?topic=141686.0

the workaround is:

1. Create a file /etc/portage/env/frotz-workaround.conf containing:

>LIB="-lcurses -ltinfo"

2. Edit /etc/portage/package.env:

>games-engines/frotz frotz-workaround.conf
Comment 8 James Le Cuirot gentoo-dev 2019-08-28 20:49:27 UTC
(In reply to Red from comment #7)
> Is this a duplicate of #677778?

I think so, probably differs slightly due to a parallel build.

*** This bug has been marked as a duplicate of bug 677778 ***