Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 692614

Summary: app-text/hunspell[ncurses]: Hunspell has been compiled without Ncurses user interface.
Product: Gentoo Linux Reporter: Petr Zima <zima>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal CC: esigra, polynomial-c
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://github.com/hunspell/hunspell/pull/642
Whiteboard: Waiting for upstream approval
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 457530    
Attachments: Patch fixing both problems

Description Petr Zima 2019-08-20 13:37:04 UTC
Created attachment 587618 [details, diff]
Patch fixing both problems

Compiling app-text/hunspell[ncurses] fails to find libncurses[w] during configure and silently disables the ncurses UI leading to an error where running:

hunspell file

The root cause is the split libtinfo[w] in sys-libs/ncurses[tinfo]. Adding -ltinfo[w] to the check for ncurses[w] in configure fixes the problem.

After that fix it compiles, but the ncurses UI segfaults due to conflict between libncursesw and libtinfo (without w!), which is linked independently due to readline. This is a similiar issue as in #682386 and #669096. Modifying the configure to look for tinfow first also during the readline check fixes this second problem.
Comment 1 Larry the Git Cow gentoo-dev 2019-09-02 10:55:53 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4b94328cd41359aa9a120a34b758e468f39849b8

commit 4b94328cd41359aa9a120a34b758e468f39849b8
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2019-09-02 10:54:25 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2019-09-02 10:55:47 +0000

    app-text/hunspell: Revbump fix build against sys-libs/ncurses[tinfo]
    
    Thanks-to: zimous <zimous@matfyz.cz>
    Bug: https://bugs.gentoo.org/692614
    Package-Manager: Portage-2.3.75, Repoman-2.3.17
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 app-text/hunspell/files/hunspell-1.7.0-tinfo.patch | 61 +++++++++++++++
 app-text/hunspell/hunspell-1.7.0-r1.ebuild         | 88 ++++++++++++++++++++++
 2 files changed, 149 insertions(+)
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2021-01-09 16:31:06 UTC
Upastream appears dead and this has been fixed in Gentoo for over a year. Closing.