Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 688066

Summary: net-analyzer/jffnms - dev-lang/php USE wddx removed in future versions
Product: Gentoo Linux Reporter: Brian Evans <grknight>
Component: Current packagesAssignee: Netmon Herd <netmon>
Status: CONFIRMED ---    
Severity: normal CC: treecleaner
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Brian Evans Gentoo Infrastructure gentoo-dev 2019-06-14 14:44:54 UTC
Beginning in PHP 7.4, the wddx extension will be moved to the PECL library and the USE flag will be removed.

If this package is to continue, the pecl-wddx package would have to be introduced and the RDEPEND changed to:
|| ( (>=dev-lang/php-7.4[apache2,cli,gd,mysql?,postgres?,session,snmp,sockets] dev-php/pecl-wddx) <dev-lang/php-7.4[apache2,cli,gd,mysql?,postgres?,session,snmp,sockets,wddx]

wddx is not very popular.  I do not wish to maintain this outdated extension.  Please contact the PHP team if more discussion is necessary.
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2019-06-14 15:08:38 UTC
Sorry.. the RDEPEND for PHP should be:

|| ( ( >=dev-lang/php-7.4[apache2,cli,gd,mysql?,postgres?,session,snmp,sockets] dev-php/pecl-wddx ) <dev-lang/php-7.4[apache2,cli,gd,mysql?,postgres?,session,snmp,sockets,wddx] )
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2020-06-18 14:42:16 UTC
No one seems to care and this will be broken in about 12 months from now.

Please fix or consider cleaning.