Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 687104

Summary: kde-plasma/ksysguard - Cannot view Detailed Memory Information as root since kde-plasma/libksysguard switch to webengine
Product: Gentoo Linux Reporter: Red <redblade7>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Severity: normal CC: redblade7
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Red 2019-06-01 01:06:26 UTC

When libksysguard used Webkit as the backend for the Detailed Memory Information, it would only show me information on my own processes. In order to view the Detailed Memory Information for root processes, I would have to run ksysguard with sudo.

After the switch to Webengine, selecting Detailed Memory Information while running ksysguard as sudo, crashes with the following error:

[31732:31732:0531/] Running as root without --no-sandbox is not supported. See

(note: the numbers at the beginning are always different)

If you visit that link, people seem to be talking about problems with Google Chrome, not Plasma or KDE apps.

I tried running "sudo ksysguard --no-sandbox" but it exits with the error:

Unknown option 'no-sandbox'.

I'm completely confused about what's actually happening here. I don't even have Google Chrome or Chromium even installed.
Comment 1 Arfrever Frehtes Taifersar Arahesis 2019-06-01 03:26:15 UTC


You may file a bug in in order for a more automatic solution to be implemented...
Comment 2 Red 2019-06-01 03:52:39 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #1)
> Try:
> sudo env QTWEBENGINE_DISABLE_SANDBOX=1 ksysguard

Yep that worked. Thank you!
Comment 3 Arfrever Frehtes Taifersar Arahesis 2019-06-01 04:53:33 UTC
This is upstream problem, not related to packaging in Gentoo.