Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 686086

Summary: sci-libs/ogdi-3.2.0 : /.../ecs_util.h:132:10: fatal error: projects.h: No such file or directory
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: RESOLVED FIXED    
Severity: normal CC: asturm, rose
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 685436    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
sci-libs:ogdi-3.2.0:20190516-045616.log
temp.tbz2
ogdi-3.2.0-proj.patch

Description Toralf Förster gentoo-dev 2019-05-16 07:39:59 UTC
In file included from /var/tmp/portage/sci-libs/ogdi-3.2.0/work/ogdi-3.2.0/ogdi/include/ecs.h:353,
                 from ../ecs_dyna.c:35:
/var/tmp/portage/sci-libs/ogdi-3.2.0/work/ogdi-3.2.0/ogdi/include/ecs_util.h:132:10: fatal error: projects.h: No such file or directory
  132 | #include "projects.h"
      |          ^~~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-desktop_20190510-215723

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems)
  [3]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.34.1 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.12.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO sci-libs/ogdi
[ebuild  N    ] sci-libs/ogdi-3.2.0  USE="-static-libs"
Comment 1 Toralf Förster gentoo-dev 2019-05-16 07:40:01 UTC
Created attachment 576874 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-05-16 07:40:04 UTC
Created attachment 576876 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-05-16 07:40:07 UTC
Created attachment 576878 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-05-16 07:40:11 UTC
Created attachment 576880 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-05-16 07:40:14 UTC
Created attachment 576882 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-05-16 07:40:17 UTC
Created attachment 576884 [details]
sci-libs:ogdi-3.2.0:20190516-045616.log
Comment 7 Toralf Förster gentoo-dev 2019-05-16 07:40:21 UTC
Created attachment 576886 [details]
temp.tbz2
Comment 8 Charlie Gehlin 2019-05-21 12:26:24 UTC
Created attachment 577450 [details, diff]
ogdi-3.2.0-proj.patch

ogdi-3.2.0-proj.patch to place in files-directory. Compiles from my overlay, no guarantees that I've made it right...
Comment 9 Andreas Sturmlechner gentoo-dev 2019-05-24 19:22:54 UTC
*** Bug 685524 has been marked as a duplicate of this bug. ***
Comment 10 Andreas Sturmlechner gentoo-dev 2019-05-25 13:51:37 UTC
(In reply to Charlie Gehlin from comment #8)
> Created attachment 577450 [details, diff] [details, diff]
> ogdi-3.2.0-proj.patch
> 
> ogdi-3.2.0-proj.patch to place in files-directory. Compiles from my overlay,
> no guarantees that I've made it right...

Could you please submit it upstream?
Comment 11 Charlie Gehlin 2019-05-26 11:13:32 UTC
(In reply to Andreas Sturmlechner from comment #10)
> (In reply to Charlie Gehlin from comment #8)
> > Created attachment 577450 [details, diff] [details, diff] [details, diff]
> > ogdi-3.2.0-proj.patch
> > 
> > ogdi-3.2.0-proj.patch to place in files-directory. Compiles from my overlay,
> > no guarantees that I've made it right...
> 
> Could you please submit it upstream?

Well, upstream HAS fixed it, it's us that need to bump ogdi up to 4.1.0 :)
My only requirement, is apparently gdal, just built fine against 4.1.0.
Comment 12 Andreas Sturmlechner gentoo-dev 2019-12-28 22:51:05 UTC
(In reply to Charlie Gehlin from comment #11)
> Well, upstream HAS fixed it, it's us that need to bump ogdi up to 4.1.0 :)
> My only requirement, is apparently gdal, just built fine against 4.1.0.
That was not clear to me as the patch did not come with appropriate header.

Hm, unfortunately the patch does not apply...
Comment 13 Larry the Git Cow gentoo-dev 2019-12-29 00:20:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0452eff68c3a95f0e22a604ced402b9bacafc3e6

commit 0452eff68c3a95f0e22a604ced402b9bacafc3e6
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-12-28 23:49:16 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-12-29 00:20:03 +0000

    sci-libs/ogdi: Restrict to <PROJ-6, EAPI-7 bump
    
    Closes: https://bugs.gentoo.org/686086
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 sci-libs/ogdi/ogdi-3.2.0-r1.ebuild | 78 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 78 insertions(+)