Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 685954

Summary: net-analyzer/rrdtool-1.6.0 breaks graphs that use zero-width lines
Product: Gentoo Linux Reporter: Kerin Millar <kfm>
Component: StabilizationAssignee: Netmon Herd <netmon>
Status: RESOLVED FIXED    
Severity: normal CC: mgorny, ruby, sam
Priority: Normal Keywords: CC-ARCHES, STABLEREQ
Version: unspecifiedFlags: nattka: sanity-check+
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
=dev-ruby/rrdtool-bindings-1.7.2 =net-analyzer/rrdtool-1.7.2-r100
Runtime testing required: ---
Bug Depends on: 549516    
Bug Blocks:    
Attachments:
Description Flags
rrdtool-1.6.0-allow-line0.patch none

Description Kerin Millar 2019-05-14 14:07:30 UTC
Created attachment 576654 [details, diff]
rrdtool-1.6.0-allow-line0.patch

Sometimes, LINE0 is used as a means to include data that should be listed beneath the graph but not rendered as part of the graph itself. For example, one may wish to report a total, without unnecessarily drawing it over a STACK/AREA graph.

As a result of the following commit, rrdtool-1.6.0 breaks the rendering of such graphs:

  https://github.com/oetiker/rrdtool-1.x/commit/bf7625c

A fix for this issue landed in rrdtool-1.7.1:

  https://github.com/oetiker/rrdtool-1.x/commit/e61e397

Therefore, my request is twofold. Firstly, to bump the 1.6.0 ebuild so as to apply the attached patch. Secondly, to consider 1.7.1 for stabilisation.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2019-05-14 14:27:14 UTC
(In reply to Kerin Millar from comment #0)
> A fix for this issue landed in rrdtool-1.7.1:

Thanks for the update!

> Therefore, my request is twofold. Firstly, to bump the 1.6.0 ebuild so as to
> apply the attached patch. Secondly, to consider 1.7.1 for stabilisation.

I don't see the point of fixing both 1.6.0 and stabilising 1.7.1. You could apply the patch through (eapply|epatch)_user locally or unmask 1.7.1 locally for the same effect.
Comment 2 Kerin Millar 2019-05-14 15:03:17 UTC
(In reply to Jeroen Roovers from comment #1)
> (In reply to Kerin Millar from comment #0)
> > A fix for this issue landed in rrdtool-1.7.1:
> 
> Thanks for the update!
> 
> > Therefore, my request is twofold. Firstly, to bump the 1.6.0 ebuild so as to
> > apply the attached patch. Secondly, to consider 1.7.1 for stabilisation.
> 
> I don't see the point of fixing both 1.6.0 and stabilising 1.7.1. You could
> apply the patch through (eapply|epatch)_user locally or unmask 1.7.1 locally
> for the same effect.

Indeed, I bumped 1.6.0 in my overlay and I intend to unmask 1.7.1 soon. At the time of writing, my current workload does not permit me the amount of time I would prefer in order to adequately test my munin node for any potential regressions.

As such, and until 1.6.0 is dropped from the tree altogether, I thought that patching it might be reasonable. I have no strong feelings on the matter, however.
Comment 3 Pacho Ramos gentoo-dev 2019-06-20 15:36:39 UTC
ok to stabilize the fixed version finally?
Comment 4 Kerin Millar 2019-06-20 19:31:43 UTC
I since upgraded from 1.6.0 to 1.7.2 and have experienced no regressions with either munin or the RRDTool::OO module from CPAN. I cannot speak for any other use case, but it looks good to me.
Comment 5 Kerin Millar 2019-08-18 06:56:22 UTC
Bump. If a later version isn't going to be stabilised in the near future, I would suggest applying the (trivial) patch to 1.6.0, as was originally suggested.
Comment 6 Pacho Ramos gentoo-dev 2019-09-06 13:51:52 UTC
we can try a newer version I think
Comment 7 Pacho Ramos gentoo-dev 2019-12-13 16:30:09 UTC
Maybe we can CC arches without waiting for the last arch to keyword all :/, at least main arches will get this solved
Comment 8 Kerin Millar 2019-12-13 16:44:35 UTC
(In reply to Pacho Ramos from comment #7)
> Maybe we can CC arches without waiting for the last arch to keyword all :/,
> at least main arches will get this solved

Yes, please.
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2019-12-13 20:49:45 UTC
(In reply to Pacho Ramos from comment #7)
> Maybe we can CC arches without waiting for the last arch to keyword all :/,
> at least main arches will get this solved

That should never have stopped you.
Comment 10 Kerin Millar 2020-05-08 14:49:37 UTC
As I had privately anticipated, this issue appears to have stalled. Therefore, I am repeating my earlier request to apply the given patch. It is all that will be necessary to close this bug.
Comment 11 Sam James archtester gentoo-dev Security 2020-06-27 20:53:24 UTC
arm64 stable
Comment 12 Thomas Deutschmann gentoo-dev Security 2020-06-28 20:29:41 UTC
x86 stable
Comment 13 Sergei Trofimovich gentoo-dev 2020-07-05 09:03:10 UTC
ppc/ppc64 stable
Comment 14 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-07-08 10:59:30 UTC
amd64 done
Comment 15 Sam James archtester gentoo-dev Security 2020-07-18 00:30:59 UTC
arm stable
Comment 16 Rolf Eike Beer 2020-08-03 18:56:54 UTC
sparc stable
Comment 17 Rolf Eike Beer 2020-08-06 06:50:04 UTC
hppa stable
Comment 18 NATTkA bot gentoo-dev 2020-09-13 11:30:27 UTC Comment hidden (obsolete)
Comment 19 Kerin Millar 2021-02-24 06:06:35 UTC
Closing because the affected versions are no longer available in portage.
Comment 20 Kerin Millar 2021-02-24 06:10:05 UTC
Re-opening. Sorry, I didn't notice at first that it had segued into an arch keywording/stabilisation bug.
Comment 21 NATTkA bot gentoo-dev 2021-03-16 00:09:10 UTC Comment hidden (obsolete)
Comment 22 Sam James archtester gentoo-dev Security 2021-04-05 22:26:10 UTC
s390 done

all arches done