Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 685922

Summary: media-gfx/blender-2.79b-r1 : /.../utilities.h:84:67: error: gDebugLevel not specified in enclosing parallel
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Adrian <agrigo2001>
Status: RESOLVED FIXED    
Severity: normal CC: agrigo2001, atoth, b.buschinski, bureau, dracwyrm, gentoo, gentoo, graphics, jlhamm, proxy-maint, rei4dan, zzam
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: openmp
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 685044    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
media-gfx:blender-2.79b-r1:20190513-193959.log
temp.tbz2
Patch that got `media-gfx/blender-2.79b-r1` to compile with `elbeem` for me

Description Toralf Förster gentoo-dev 2019-05-14 07:52:31 UTC
                 from /var/tmp/portage/media-gfx/blender-2.79b-r1/work/blender-2.79b/intern/elbeem/intern/solver_main.cpp:13:
/var/tmp/portage/media-gfx/blender-2.79b-r1/work/blender-2.79b/intern/elbeem/intern/solver_main.cpp: In member function ‘void LbmFsgrSolver::mainLoop(int)’:
/var/tmp/portage/media-gfx/blender-2.79b-r1/work/blender-2.79b/intern/elbeem/intern/utilities.h:84:67: error: ‘gDebugLevel’ not specified in enclosing ‘parallel’
   84 | ne errMsg(from,mStr)                           if(gDebugLevel>0){ MSGSTREAM; msg << mStr <<"\n"; messageOutputFunc(from, DM_ERROR,   msg.str(), 0); }
      |                                                   ~~~~~~~~~~~^~


  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-no-multilib_libressl_20190510-225704

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems)
  [3]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.34.1 *
  [2]   rust-1.34.1



emerge -qpvO media-gfx/blender
[ebuild  N    ] media-gfx/blender-2.79b-r1  USE="bullet dds elbeem game-engine nls openexr openmp -collada -colorio -cuda -cycles -debug -doc -ffmpeg -fftw -headless -jack -jemalloc -jpeg2k -libav -llvm -man -ndof -openal -opencl -openimageio -opensubdiv -openvdb -osl -player -sdl -sndfile -test -tiff -valgrind" PYTHON_SINGLE_TARGET="python3_6 -python3_5" PYTHON_TARGETS="python3_6 -python3_5"
Comment 1 Toralf Förster gentoo-dev 2019-05-14 07:52:34 UTC
Created attachment 576534 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-05-14 07:52:37 UTC
Created attachment 576536 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-05-14 07:52:40 UTC
Created attachment 576538 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-05-14 07:52:43 UTC
Created attachment 576540 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-05-14 07:52:46 UTC
Created attachment 576542 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-05-14 07:52:49 UTC
Created attachment 576544 [details]
media-gfx:blender-2.79b-r1:20190513-193959.log
Comment 7 Toralf Förster gentoo-dev 2019-05-14 07:52:52 UTC
Created attachment 576546 [details]
temp.tbz2
Comment 8 Markus Oehme 2019-05-31 17:50:02 UTC
This error occurred for me with gcc-9.1.0 but not with gcc-8.3.0.
Comment 9 ammar 2019-06-06 00:04:21 UTC
I was able to circumvent this bug for the time being. The bug appears to have to do with enabling the `elbeem` USE flag. RedHat Bugzilla Bug 1674700 (https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=1674700) seems to have more information. It directs me to a section of GNU's article on porting to gcc9 (https://gcc.gnu.org/gcc-9/porting_to.html#ompdatasharing). The specific error seems to have to do with OpenMP: it now requires additional declarations in #pragma blocks, but I am not well versed enough in C to understand what this means.

Nonetheless, I am fluent enough in C to track down the error to elbeem's solver_main.cpp file. Compiling the file manually, we find the offending #pragma blocks to be on lines 381, 1126, and 1164. With some effort, I created a patch file. I was able to compile `media-gfx/blender-2.79b-r1` with the `elbeem` USE flag, though I do not know whether or not I inadvertently created more errors.
Comment 10 ammar 2019-06-06 00:06:48 UTC
Created attachment 578966 [details, diff]
Patch that got `media-gfx/blender-2.79b-r1` to compile with `elbeem` for me

I was able to circumvent this bug for the time being. The bug appears to have to do with enabling the `elbeem` USE flag. RedHat Bugzilla Bug 1674700 (https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=1674700) seems to have more information. It directs me to a section of GNU's article on porting to gcc9 (https://gcc.gnu.org/gcc-9/porting_to.html#ompdatasharing). The specific error seems to have to do with OpenMP: it now requires additional declarations in #pragma blocks, but I am not well versed enough in C to understand what this means.

Nonetheless, I am fluent enough in C to track down the error to elbeem's solver_main.cpp file. Compiling the file manually, we find the offending #pragma blocks to be on lines 381, 1126, and 1164. With some effort, I created a patch file. I was able to compile `media-gfx/blender-2.79b-r1` with the `elbeem` USE flag, though I do not know whether or not I inadvertently created more errors.
Comment 11 Attila Tóth 2019-06-11 09:03:24 UTC
Attac(In reply to ammar from comment #10)
> Created attachment 578966 [details, diff] [details, diff]
> Patch that got `media-gfx/blender-2.79b-r1` to compile with `elbeem` for me
> 
> I was able to circumvent this bug for the time being. The bug appears to
> have to do with enabling the `elbeem` USE flag. RedHat Bugzilla Bug 1674700
> (https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=1674700) seems
> to have more information. It directs me to a section of GNU's article on
> porting to gcc9 (https://gcc.gnu.org/gcc-9/porting_to.html#ompdatasharing).
> The specific error seems to have to do with OpenMP: it now requires
> additional declarations in #pragma blocks, but I am not well versed enough
> in C to understand what this means.
> 
> Nonetheless, I am fluent enough in C to track down the error to elbeem's
> solver_main.cpp file. Compiling the file manually, we find the offending
> #pragma blocks to be on lines 381, 1126, and 1164. With some effort, I
> created a patch file. I was able to compile `media-gfx/blender-2.79b-r1`
> with the `elbeem` USE flag, though I do not know whether or not I
> inadvertently created more errors.

Patch works for me, thanks!
Comment 12 David Seifert gentoo-dev 2019-06-23 18:33:43 UTC
*** Bug 685194 has been marked as a duplicate of this bug. ***
Comment 13 Michael 'veremitz' Everitt 2019-06-30 13:50:31 UTC
Fixed upstream in https://developer.blender.org/rBd780409156e838e366f4da5126e6aeab44174d62 ?

Bump please?
Comment 14 Markus Oehme 2019-06-30 14:11:19 UTC
(In reply to Michael 'veremitz' Everitt from comment #13)
> Fixed upstream in
> https://developer.blender.org/rBd780409156e838e366f4da5126e6aeab44174d62 ?

Dropping this into /etc/portage/patches indeed fixed the problem for me.
Comment 15 Vincent de Phily 2019-11-12 11:17:07 UTC
Gcc 9.2.0 recently went stable on amd64, so I expect more people are now exposed to this bug (as I am). We've got a patch (two actually), let's commit it ?
Comment 16 Larry the Git Cow gentoo-dev 2019-11-12 12:33:23 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4f0c93f505f5c48ad580f6a926a0f226de215171

commit 4f0c93f505f5c48ad580f6a926a0f226de215171
Author:     Miroslav Šulc <fordfrog@gentoo.org>
AuthorDate: 2019-11-12 12:32:55 +0000
Commit:     Miroslav Šulc <fordfrog@gentoo.org>
CommitDate: 2019-11-12 12:33:15 +0000

    media-gfx/blender-2.79b: fix #685922
    
    Closes: https://bugs.gentoo.org/685922
    Package-Manager: Portage-2.3.79, Repoman-2.3.18
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>

 media-gfx/blender/blender-2.79b-r1.ebuild          |  2 ++
 ....79b-fix-for-gcc9-new-openmp-data-sharing.patch | 31 ++++++++++++++++++++++
 2 files changed, 33 insertions(+)