Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 685564

Summary: app-misc/gcal-3.6.3 : fseeko.c:105:4: error: #error Please port gnulib fseeko.c to your platform! Look at the code in fpurge.c, then report this to bug-gnulib.
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Shell Tools Herd Bugs <shell-tools>
Status: CONFIRMED ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 663916    
Attachments: emerge-info.txt
app-misc:gcal-3.6.3:20190508-003905.log
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
temp.tbz2
all relevant log-files

Description Toralf Förster gentoo-dev 2019-05-10 18:18:20 UTC
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..   -D_GNU_SOURCE  -O2 -pipe -march=native -c -o fseeko.o fseeko.c
fseeko.c: In function ‘rpl_fseeko’:
fseeko.c:105:4: error: #error "Please port gnulib fseeko.c to your platform! Look at the code in fpurge.c, then report this to bug-gnulib."
   #error "Please port gnulib fseeko.c to your platform! Look at the code in fpurge.c, then report this to bug-gnulib."
    ^~~~~
make[4]: *** [Makefile:2044: fseeko.o] Error 1

  -------------------------------------------------------------------

  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-no-multilib-hardened_stable-libressl_20190502-165513

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.29.1 *



emerge -qpvO app-misc/gcal
[ebuild  N    ] app-misc/gcal-3.6.3  USE="ncurses nls unicode"
Comment 1 Toralf Förster gentoo-dev 2019-05-10 18:18:23 UTC
Created attachment 575834 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-05-10 18:18:26 UTC
Created attachment 575836 [details]
app-misc:gcal-3.6.3:20190508-003905.log
Comment 3 Toralf Förster gentoo-dev 2019-05-10 18:18:29 UTC
Created attachment 575838 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-05-10 18:18:31 UTC
Created attachment 575840 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-05-10 18:18:34 UTC
Created attachment 575842 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-05-10 18:18:37 UTC
Created attachment 575844 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-05-10 18:18:40 UTC
Created attachment 575846 [details]
temp.tbz2
Comment 8 Tom 2019-05-25 13:10:10 UTC
Hello,

I'll get the same error message using gcc 8.3.0 on x86 32 bit.

info-gcal.tgz holds all relevant log-files.

CU Tom
Comment 9 Tom 2019-05-25 13:10:38 UTC
Created attachment 577782 [details]
all relevant log-files
Comment 10 Michael Hofmann 2019-06-14 23:30:39 UTC
I just got the same error: gcal 3.6.3, default/linux/amd64/17.1/no-multilib, gcc-8.3.0, glibc-2.29-r2, 

There's a post on the gcal mailing list: https://lists.gnu.org/archive/html/bug-gcal/2018-10/msg00000.html

The error seems to be fixed in gcal-4.1 - I could install gcal-4.1 without a problem.