Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 685436

Summary: sci-libs/gdal-2.4.1 with (sci-libs/ogdi-3.2.0 and proj-6.0.0) - /usr/include/ecs_util.h:132:10: fatal error: projects.h: No such file or directory
Product: Gentoo Linux Reporter: Juergen Rose <rose>
Component: Current packagesAssignee: Sci-geo Project <sci-geosciences>
Status: RESOLVED FIXED    
Severity: normal CC: devurandom, jstein
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 706190, 686086    
Bug Blocks:    
Attachments: build.log.bz2
output of `emerge --info '=sci-libs/gdal-2.4.1::gentoo'`

Description Juergen Rose 2019-05-09 06:29:24 UTC
Created attachment 575576 [details]
build.log.bz2

'MAKEOPTS=-j1 emerge -v1 gdal' fails with:
...
make[3]: Entering directory '/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/ogr/ogrsf_frmts/ogdi'
/bin/sh /var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/libtool --mode=compile --silent --tag=CXX x86_64-pc-linux-gnu-g++ -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/port -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/gcore -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/alg -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/ogr -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/ogr/ogrsf_frmts -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/gnm -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/apps -DHAVE_AVX_AT_COMPILE_TIME -DHAVE_SSSE3_AT_COMPILE_TIME -DHAVE_SSE_AT_COMPILE_TIME -march=broadwell -O2 -pipe -std=c++14 -I/usr/include/tirpc -fvisibility=hidden  -Wall -Wextra -Winit-self -Wunused-parameter -Wformat -Werror=format-security -Wno-format-nonliteral -Wlogical-op -Wshadow -Werror=vla -Wdate-time -Wnull-dereference -Wduplicated-cond -Wextra-semi -Wfloat-conversion -Wmissing-declarations -Wnon-virtual-dtor -Woverloaded-virtual -fno-operator-names -Wzero-as-null-pointer-constant -Wsuggest-override -Wimplicit-fallthrough  -I/usr -I/usr/include  -DGNM_ENABLED -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/port -I/usr/include/openjpeg-2.3 -I/usr/include -I/usr/ -I/usr//include  -DGDAL_COMPILATION -DHAVE_XERCES -I/usr/include -I/usr/include/xercesc -I/var/tmp/portage/sci-libs/gdal-2.4.1/work/gdal-2.4.1/port -I/usr/include/openjpeg-2.3 -I/usr/include -I/usr/ -I/usr//include  -DGDAL_COMPILATION -c -o ../o/ogrogdidriver.lo ogrogdidriver.cpp
In file included from /usr/include/ecs.h:353,
                 from ogrogdi.h:40,
                 from ogrogdidriver.cpp:30:
/usr/include/ecs_util.h:132:10: fatal error: projects.h: No such file or directory
  132 | #include "projects.h"
      |          ^~~~~~~~~~~~
compilation terminated.
make[3]: *** [../../../GDALmake.opt:678: ../o/ogrogdidriver.lo] Error 1



lynx ~ # emerge -pqv '=sci-libs/gdal-2.4.1::gentoo'
[ebuild   R   ] sci-libs/gdal-2.4.1  USE="armadillo aux_xml curl fits geos gif gml hdf5 java jpeg jpeg2k lzma mysql netcdf odbc ogdi pdf perl png postgres python sqlite threads -debug -doc -mdb -opencl -oracle -spatialite -webp -xls -zstd" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
Comment 1 Juergen Rose 2019-05-09 06:33:43 UTC
Created attachment 575578 [details]
output of `emerge --info '=sci-libs/gdal-2.4.1::gentoo'`
Comment 2 Juergen Rose 2019-05-10 12:15:57 UTC
"USE=-ogdi  emerge -v1 gdal" worked.
Comment 3 Aaron W. Swenson gentoo-dev 2019-05-21 10:13:30 UTC
GDAL needs a bump to 3.0.0 to use PROJ.4 >=6.0.0

https://github.com/OSGeo/gdal/releases/tag/v3.0.0
Comment 4 Dennis Schridde 2019-05-25 10:46:03 UTC
(In reply to Aaron W. Swenson from comment #3)
> GDAL needs a bump to 3.0.0 to use PROJ.4 >=6.0.0
> 
> https://github.com/OSGeo/gdal/releases/tag/v3.0.0

I filed a separate bug about this: https://bugs.gentoo.org/686732

Until this is implemented, could we please have <sci-libs/gdal-3 block >=sci-libs/proj-5?
Comment 5 Andreas Sturmlechner gentoo-dev 2019-12-28 19:08:07 UTC
This is actually a problem in sci-libs/ogdi-3.2.0 headers.
Comment 6 Andreas Sturmlechner gentoo-dev 2019-12-29 12:43:34 UTC
This should be fixed by sci-libs/ogdi-3.2.0-r1 now.
Comment 7 Dennis Schridde 2020-01-20 18:51:30 UTC
(In reply to Andreas Sturmlechner from comment #6)
> This should be fixed by sci-libs/ogdi-3.2.0-r1 now.

I think the issue is back:

sci-libs/proj:0

  (sci-libs/proj-6.2.1:0/15::gentoo, ebuild scheduled for merge) USE="-europe -static-libs -test" ABI_X86="(64)" pulled in by
    >=sci-libs/proj-6.0.0:= required by (sci-libs/libgeotiff-1.5.1-r1:0/5::gentoo, ebuild scheduled for merge) USE="-debug -doc -static-libs" ABI_X86="(64)"
    ^^              ^^^^^

  (sci-libs/proj-5.2.0:0/13::gentoo, ebuild scheduled for merge) USE="-static-libs" ABI_X86="(64)" pulled in by
    <sci-libs/proj-6.0.0:= required by (sci-libs/ogdi-3.2.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-static-libs" ABI_X86="(64)"
    ^              ^^^^^ ^