Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 684964

Summary: dev-util/apitrace-8.0 should depend on app-arch/brotli:=[${MULTILIB_USEDEP}] - ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../libbrotlidec.so when searching for -lbrotlidec
Product: Gentoo Linux Reporter: EoD <EoD>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal Keywords: PATCH
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Ebuild patch to fix multilib dependency

Description EoD 2019-05-03 07:15:21 UTC
Created attachment 574976 [details, diff]
Ebuild patch to fix multilib dependency

apitrace-8.0 pulls in app-arch/brotli without the respective mutlilib dependency:

> /usr/bin/x86_64-pc-linux-gnu-g++ -m32  -O2 -pipe -march=ivybridge -O2 -pipe -ggdb -O2 -pipe -fvisibility=hidden -std=gnu++11 -Wall -Wno-sign-compare -fno-strict-aliasing -fno-rtti -fno-exceptions -fmessage-length=0 -fno-omit-frame-pointer  -Wl,-O1 -Wl,--as-needed    -rdynamic lib/trace/CMakeFiles/trace_parser_flags_test.dir/trace_parser_flags_test.cpp.o  -o trace_parser_flags_test  -Wl,-rpath,/var/tmp/portage/dev-util/apitrace-8.0/work/apitrace-8.0-abi_x86_32.x86 libgtest.so lib/trace/libcommon.a -lpthread lib/guids/libguids.a lib/highlight/libhighlight.a lib/os/libos.a -ldl thirdparty/libbacktrace/libbacktrace.a -lbrotlidec -lbrotlienc && :
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../libbrotlidec.so when searching for -lbrotlidec
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libbrotlidec.so when searching for -lbrotlidec
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lbrotlidec
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../libbrotlienc.so when searching for -lbrotlienc
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libbrotlienc.so when searching for -lbrotlienc
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lbrotlienc
> collect2: error: ld returned 1 exit status

The attached patch fixes the issue.
Comment 1 Andreas Sturmlechner gentoo-dev 2019-05-03 07:34:55 UTC
This is going to be obsolete by bug 684830.
Comment 2 Matt Turner gentoo-dev 2019-05-09 00:02:13 UTC

*** This bug has been marked as a duplicate of bug 684830 ***
Comment 3 Larry the Git Cow gentoo-dev 2020-02-07 21:47:41 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=50a8d17875e524c22f2c7d8be63e6f5c3d81b73b

commit 50a8d17875e524c22f2c7d8be63e6f5c3d81b73b
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2020-02-07 18:13:29 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2020-02-07 21:47:25 +0000

    dev-util/apitrace: Version bump to 9.0.0
    
    A lot of changes in this version bump:
        - Python3 support
        - Python2 support dropped
        - IUSE=cli dropped. Enabled always
        - IUSE=system-snappy dropped. Enabled always
        - IUSE=egl dropped. Enabled always
        - Install CLI binaries for all ABIs
        - media-libs/waffle support enabled
    
    Closes: https://bugs.gentoo.org/684830
    Closes: https://bugs.gentoo.org/684964
    Closes: https://bugs.gentoo.org/693116
    Closes: https://bugs.gentoo.org/705320
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 dev-util/apitrace/Manifest                         |   1 +
 dev-util/apitrace/apitrace-9.0.ebuild              |  85 +++++++++++
 .../files/apitrace-9.0-brotli-unbundle.patch       | 158 +++++++++++++++++++++
 .../files/apitrace-9.0-disable-multiarch.patch     |  53 +++++++
 4 files changed, 297 insertions(+)