Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 684716

Summary: kde-apps/kmail-19.04.0 - unable to add a Yahoo account
Product: Gentoo Linux Reporter: klaus818
Component: New packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED NEEDINFO    
Severity: normal Keywords: UPSTREAM
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=406803
Whiteboard: tracking upstream
Package list:
Runtime testing required: ---
Attachments: Picture of the dialog

Description klaus818 2019-04-29 08:50:08 UTC
Created attachment 574602 [details]
Picture of the dialog

If I want to add an yahoo account to kmail I get an dialog for a google account. This doesn't work. See the picture.
Comment 1 klaus818 2019-05-02 16:07:52 UTC
Ok, thank you very much. Thunderbird works very fine for me. I tried heavy with kmail for years. But now I tell you, never ever. Nobody needs this bullshit kmail. Gentoo without pim and I am happy for the rest of my life.

I don't need a mailer, which is broken with every new release. 

Sorry, this is not the problem of gentoo. But I send a bugreport to KDE. No answer. A week later I send a bugreport to gentoo, an answer but no solution.

Fuck you kmail. And yes, I look for an usable desktop in the future.
Comment 2 Andreas Sturmlechner gentoo-dev 2019-05-02 16:23:41 UTC
Surely you will know that Gentoo has the option of using stable keyworded software for your production needs.
Comment 3 klaus818 2019-05-06 14:03:58 UTC
This is no solution. There is never a stable software if nobody uses testing. I am not an developer, I test everything and report the bugs. This is my part of gentoo. I have no problem with bugs, but I have a very big problem if nobody recognized my bugreports. First KDE. Ok, I now it. Forget it. But then I write a bugreport to gentoo, perhaps you have better connections.

And the next thing. Are you sure, that the stable tree don't have this problem? I don't have this problem, when I use my old installation and do and update. I recognized this bug, as i do a new installation. Perhaps this bug is in kmail for years. But nobody reported this bug because they do not use a new installation.

And the very last thing. Kmail was nice, but it is broken regularly. Thunderbird is very much better.
Comment 4 Andreas Sturmlechner gentoo-dev 2019-05-10 19:37:19 UTC
Test with 19.04.1.
Comment 5 klaus818 2019-05-11 04:16:39 UTC
Same problem.
Comment 6 klaus818 2019-05-11 09:59:26 UTC
Yes, I know it, this is my bugreport. First I reported it to kde, because I know, that this is not a problem from gentoo. But I hope, that you have better connections to the kde team. Because of this I report it to gentoo a second time.
Comment 7 Andreas Sturmlechner gentoo-dev 2019-06-06 21:52:01 UTC
(In reply to klaus818 from comment #6)
> But I hope, that you have better connections to the kde team.
> Because of this I report it to gentoo a second time.
Person who experiences the bug is always the best to report and engage with upstream to fix it. You can also visit #kontact (best during Euro working hours) for more help.

Please test with 19.04.2.
Comment 8 Andreas Sturmlechner gentoo-dev 2019-06-06 21:53:46 UTC
(In reply to Andreas Sturmlechner from comment #7)
> You can also visit #kontact (best during Euro working hours) for more help.
...with that said, don't show up with the same attitude as in comment #1.
Comment 9 Andreas Sturmlechner gentoo-dev 2019-07-15 06:19:36 UTC
Confirmed upstream by second report with different distro and 18.12.3.
Comment 10 klaus818 2019-07-16 13:50:23 UTC
At the moment I am unable to test it, because mariadb is totally broken. I am unable to run mariadb --config or if I start kmail, it is unable to cennect with acconadi.
Comment 11 Andreas Sturmlechner gentoo-dev 2019-07-16 13:51:39 UTC
That's probably bug 688746.
Comment 12 klaus818 2019-07-16 14:00:31 UTC
Hello Andreas, yes, I know. But I would told you only, that in the moment I am unable to report something about this bug.

But, if you need E-Mail, you can't use kmail for the rest of your life. At the moment, everything is broken, mariadb, akondi, kmail. This is the dead of kmail.
Comment 13 Andreas Sturmlechner gentoo-dev 2019-07-16 14:03:10 UTC
Please keep this bug free of trivia, otherwise I'm inclined to set it to RESOLVED/UPSTREAM.
Comment 14 Andreas Sturmlechner gentoo-dev 2020-07-01 21:57:54 UTC
If you are still able to reproduce this with 20.04.2, please try adding a mail account not using the account setup helper but via KMail -> Accounts -> Receiving -> Add [Custom Account] (If you choose 'Add Mail Account' it will start the account setup helper again.)