Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 681924

Summary: <virtual/mailx-2 do not RDEPEND on mail-client/s-nail
Product: Gentoo Linux Reporter: Sven Garbade <sfgarbade>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: UNCONFIRMED ---    
Severity: normal CC: u.scholz83
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Sven Garbade 2019-03-28 13:27:01 UTC
I recently have mail-client/s-nail installed (because mail-client/nail will be masked in the near future) and now an update fails:

%> ionice -c3 emerge --update --newuse --deep  @world                           

Calculating dependencies... done!
[ebuild     U  ] app-arch/tar-1.32 [1.31-r1]
[ebuild     U  ] net-dialup/ppp-2.4.7-r7 [2.4.7-r6]
[ebuild     U  ] media-libs/tiff-4.0.10 [4.0.9-r4] USE="-webp% -zstd%" 
[ebuild  N     ] net-mail/mailutils-3.4-r2  USE="berkdb clients gdbm ipv6 nls pam ssl tcpd threads -bidi -guile -kerberos -kyotocabinet -ldap -mysql -postgres -python -sasl -servers -static-libs -tokyocabinet" PYTHON_TARGETS="python2_7" 
[ebuild     U  ] app-editors/nano-3.2 [2.9.8]
[ebuild  N     ] virtual/mailx-1 
[ebuild     U  ] dev-cpp/gtest-1.8.1 [1.8.0-r1]
[blocks B      ] net-mail/mailutils ("net-mail/mailutils" is blocking mail-client/s-nail-14.9.13)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (net-mail/mailutils-3.4-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    net-mail/mailutils required by (virtual/mailx-1:0/0::gentoo, ebuild scheduled for merge)

  (mail-client/s-nail-14.9.13:0/0::gentoo, installed) pulled in by
    mail-client/s-nail required by @selected


It seems that loghceck is depending on virtual/mailx-1 which wants to install net-mail/mailutils:

%> equery depends virtual/mailx-1                                                   

 * These packages depend on virtual/mailx-1:
app-admin/logcheck-1.3.18-r1 (virtual/mailx)

I need the functionality of s-nail, therefore replacing s-nail with mailutils is not an option for me. Additionally, I have not observed any problems with logcheck in combination with s-nail so far. 

Any ideas to solve the problem?
Comment 1 Jeroen Roovers gentoo-dev 2019-03-28 13:52:28 UTC
You could solve this locally by unmasking =virtual/mailx-2
Comment 2 Sven Garbade 2019-03-28 14:14:20 UTC
great, thanks!
Comment 3 Uwe Scholz 2019-04-18 21:25:40 UTC
I ran into the same issue. Unmasking =virtual/mailx-2 solved it for me, too.
Comment 4 tazinblack 2019-05-03 07:49:45 UTC
Same problem here. Workaround to unmask =virtual/mailx-2 also worked for me