Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 680838

Summary: app-admin/mongo-tools-3.6.8 fails to build with dev-lang/go-1.12 and higher
Product: Gentoo Linux Reporter: Dennis Lichtenthäler <dennis>
Component: Current packagesAssignee: Ultrabug <ultrabug>
Status: RESOLVED FIXED    
Severity: normal CC: kroemmelbein, sandino, slawomir.nizio, urban82, web, zmedico
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://jira.mongodb.org/browse/TOOLS-2233
See Also: https://github.com/gentoo/gentoo/pull/11399
https://bugs.gentoo.org/show_bug.cgi?id=678924
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: interim fix

Description Dennis Lichtenthäler 2019-03-18 10:20:52 UTC
Created attachment 569588 [details, diff]
interim fix

Emerging mongo-tools-3.6.8 (currently stable) results in an error building mongoreplay:

vendor/src/github.com/google/gopacket/pcap/pcap.go:173:7: identifier "_Ctype_struct_bpf_program" may conflict with identifiers generated by cgo                                                                                              

According to https://jira.mongodb.org/browse/TOOLS-2233 this problem occurs with dev-lang/go > 1.12. I'm attaching a patch to the ebuild that fixes the merge for me.

The problem also exists in the latest version of mongo-tools for the 3.x versions available in portage (3.6.10).
Comment 1 Tomáš Mózes 2019-03-18 11:44:50 UTC
Yes, go-1.12 went stable before mongodb even reacted to the bug report :) The PR takes care of it, thanks for the report.
Comment 2 Joakim Tjernlund 2019-03-26 22:05:00 UTC
Got the same problem
Comment 3 INODE64 Sistemas 2019-03-28 07:12:21 UTC
I have it too
Comment 4 Brian Evans Gentoo Infrastructure gentoo-dev 2019-03-28 12:31:04 UTC
*** Bug 680872 has been marked as a duplicate of this bug. ***
Comment 5 Zac Medico gentoo-dev 2019-03-28 18:54:46 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cf2853bb8e525a2aaf580c47ad556ff716bf9789

commit cf2853bb8e525a2aaf580c47ad556ff716bf9789
Author:     Tomas Mozes <hydrapolic@gmail.com>
AuthorDate: 2019-03-18 06:48:40 +0100
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2019-03-28 10:39:07 -0700

    app-admin/mongo-tools: fix building with dev-lang/go-1.12
    
    Bug: https://bugs.gentoo.org/678924
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 app-admin/mongo-tools/mongo-tools-3.6.10.ebuild | 7 +++++++
 app-admin/mongo-tools/mongo-tools-3.6.8.ebuild  | 5 ++++-
 2 files changed, 11 insertions(+), 1 deletion(-)