Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 677574

Summary: sys-boot/grub:2 on install media probably needs patch to handle 64-bit frambuffer addresses in EFI mode
Product: Gentoo Linux Reporter: Morgan Wesström <gentoo-bugzilla>
Component: Current packagesAssignee: Mike Gilbert <floppym>
Status: RESOLVED FIXED    
Severity: normal CC: base-system, bkohler, releng
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: dmesg from affected machine
lspci -v from affected machine
Patch that resolves the problem.

Description Morgan Wesström 2019-02-09 18:51:17 UTC
Booting an Intel NUC8i5BEH in EFI mode from install-amd64-minimal-20190207T214502Z.iso results in black screen. Boot succeeds though because you can ssh remotely to the LiveCD environment. dmesg reveals one failure:
[    1.055159] efifb: invalid framebuffer address
An Ubuntu bug tracks this to GRUB2 and was patched only 5 days ago.
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1785033
Could this patch be applied to the GRUB2 on the install media? It would also need to be applied to the GRUB2 in Portage because the same thing happens after you install Gentoo with genkernel and GRUB2 in EFI mode onto the machine in question and try to boot it. dmesg and lspci attached.

Reproducible: Always

Steps to Reproduce:
1. Boot from latest minimal install CD in EFI mode (on some modern hardware).
2. Screen goes black.
3. Live environment is running because ssh works.
4. dmesg reports efifb: invalid framebuffer address
Actual Results:  
Screen goes black.

Expected Results:  
Screen should display output.
Comment 1 Morgan Wesström 2019-02-09 18:52:01 UTC
Created attachment 564384 [details]
dmesg from affected machine
Comment 2 Morgan Wesström 2019-02-09 18:52:26 UTC
Created attachment 564386 [details]
lspci -v from affected machine
Comment 3 Morgan Wesström 2019-02-24 23:22:56 UTC
Created attachment 566386 [details, diff]
Patch that resolves the problem.

The following patch was downloaded from http://git.savannah.gnu.org/cgit/grub.git/patch/?id=886edba8770ccbc3def0af2a7d6b346d00d0af2f and I have applied it to the system in question and verified that it solves the problem.
Comment 4 Ben Kohler gentoo-dev 2019-09-06 13:08:13 UTC
Looks like this patch is in grub-2.04-r1, so we just need to wait for this to be stabilized
Comment 5 Guido Jäkel 2020-02-24 15:18:30 UTC
This days we run into the same using  grub-2.02  on a Fujitsu Exprimo Desktop (FUJITSU ESPRIMO D738/D3601-A1, BIOS V5.0.0.13 R1.21.0 for D3601-A1x                    07/04/2019): 

* The grub menu was working, but starting kernel show not any video output.
* Because we also boot a prebuild rootfs with a running sshd , we found that only video output was not working

We confirm that switching to  grub-2.04-r1  solve the issue for us. Thank you for reporting and solving the bug!



00:02.0 VGA compatible controller: Intel Corporation Device 3e92 (prog-if 00 [VGA controller])
        Subsystem: Fujitsu Technology Solutions Device 124a
        Flags: bus master, fast devsel, latency 0, IRQ 255
        Memory at 6000000000 (64-bit, non-prefetchable) [size=16M]
        Memory at 4000000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 4000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] Process Address Space ID (PASID)
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] Page Request Interface (PRI)
        Kernel modules: i915
Comment 6 Ben Kohler gentoo-dev 2020-02-24 19:36:45 UTC
Thanks for the update