Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 674258

Summary: www-servers/resin-4.0.48-r1 : configure: error: Can t find valid OpenSSL include in /usr/include
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Java team <java>
Status: RESOLVED FIXED    
Severity: normal CC: treecleaner
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: fixed in 4.0.62
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 592438    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
temp.tbz2
www-servers:resin-4.0.48-r1:20190101-114558.log

Description Toralf Förster gentoo-dev 2019-01-01 11:49:56 UTC
checking for JNI in /opt/icedtea-bin-3.9.0/include/linux ... found
Using JVMTI for class reloading
configure: error: Can't find valid OpenSSL include in /usr/include

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/www-servers/resin-4.0.48-r1/work/resin-4.0.48/config.log

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-developer_20181229-151642

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems)
  [3]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.31.1 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.9.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO www-servers/resin
[ebuild  N    ] www-servers/resin-4.0.48-r1  USE="-admin -doc -source"
Comment 1 Toralf Förster gentoo-dev 2019-01-01 11:49:59 UTC
Created attachment 559348 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-01-01 11:50:02 UTC
Created attachment 559350 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-01-01 11:50:05 UTC
Created attachment 559352 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-01-01 11:50:08 UTC
Created attachment 559354 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-01-01 11:50:10 UTC
Created attachment 559356 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-01-01 11:50:13 UTC
Created attachment 559358 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-01-01 11:50:16 UTC
Created attachment 559360 [details]
www-servers:resin-4.0.48-r1:20190101-114558.log
Comment 8 Hans de Graaff gentoo-dev 2019-07-14 06:45:01 UTC
This looks to be fixed in 4.0.62, but that version now also depends on maven so I'm not sure we can bump this version because of that. Candidate for masking?
Comment 9 Agostino Sarubbo gentoo-dev 2021-04-16 07:06:21 UTC
Dear treecleaner@:

I'm still able to reproduce this issue right now.

Since it has not been fixed for a long time, I'd suggest to evaluate if it is the case to remove this package from the tree. Thanks
Comment 10 wolfgang 2021-05-03 14:52:36 UTC
I can also confirm on amd64
Comment 11 wolfgang 2021-05-03 14:53:46 UTC
(In reply to Hans de Graaff from comment #8)
> This looks to be fixed in 4.0.62, but that version now also depends on maven
> so I'm not sure we can bump this version because of that. Candidate for
> masking?

I think if the project provides a pom.xml, then there is a java-2-ebuild generator that may be able to help.

Do you know if the project provides a pom.xml?
Comment 12 Larry the Git Cow gentoo-dev 2021-08-24 12:39:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7a1e8a90fa8a09a84741dc8ef5f774d92ae8433c

commit 7a1e8a90fa8a09a84741dc8ef5f774d92ae8433c
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-08-24 12:38:22 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-08-24 12:38:22 +0000

    www-servers/resin: Remove last-rited package
    
    Bug: https://bugs.gentoo.org/781545
    Closes: https://bugs.gentoo.org/674258
    Closes: https://bugs.gentoo.org/771579
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 profiles/package.mask                              |   6 -
 www-servers/resin/Manifest                         |   1 -
 .../resin/files/resin-4.0.48-build.xml.patch       |  59 -------
 www-servers/resin/files/resin-4.0.48.conf          |  16 --
 www-servers/resin/files/resin-4.0.48.init          |  36 -----
 www-servers/resin/metadata.xml                     |  11 --
 www-servers/resin/resin-4.0.48-r1.ebuild           | 179 ---------------------
 7 files changed, 308 deletions(-)