Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 672676

Summary: x11-libs/xapps-1.4.2 : pygobject/meson.build:1:0: ERROR: Dependency pygobject-3.0 not found, tried pkgconfig
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: laurantino <olivier.laurantin>
Status: CONFIRMED ---    
Severity: normal CC: proxy-maint, sparky
Priority: Normal Keywords: PullRequest
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://github.com/gentoo/gentoo/pull/17613
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 704532    
Bug Blocks:    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
temp.tbz2
x11-libs:xapps-1.4.2:20181207-090831.log

Description Toralf Förster gentoo-dev 2018-12-07 09:18:06 UTC
Dependency pygobject-3.0 found: NO (tried pkgconfig)

pygobject/meson.build:1:0: ERROR:  Dependency "pygobject-3.0" not found, tried pkgconfig

A full log can be found at /var/tmp/portage/x11-libs/xapps-1.4.2/work/xapps-1.4.2-build/meson-logs/meson-log.txt
 * ERROR: x11-libs/xapps-1.4.2::gentoo failed (configure phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma_libressl-test_20181206-161222

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)





emerge -qpvO x11-libs/xapps
[ebuild  N    ] x11-libs/xapps-1.4.2  USE="-introspection -static-libs"
Comment 1 Toralf Förster gentoo-dev 2018-12-07 09:18:09 UTC
Created attachment 557242 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-12-07 09:18:12 UTC
Created attachment 557244 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-12-07 09:18:14 UTC
Created attachment 557246 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-12-07 09:18:17 UTC
Created attachment 557248 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-12-07 09:18:20 UTC
Created attachment 557250 [details]
temp.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-12-07 09:18:23 UTC
Created attachment 557252 [details]
x11-libs:xapps-1.4.2:20181207-090831.log
Comment 7 Larry the Git Cow gentoo-dev 2020-05-29 00:11:51 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d89a3324b97a597edb88c8b72b5df8c9130ed134

commit d89a3324b97a597edb88c8b72b5df8c9130ed134
Author:     Matthew Turnbull <sparky@bluefang-logic.com>
AuthorDate: 2020-05-12 04:44:31 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2020-05-29 00:10:42 +0000

    x11-libs/xapps: 1.8.4 version bump
    
    Update xapps to 1.8.4. Switch to EAPI=7 and clean
    up eclass usage and dependencies. Fix installation
    of pygobject files for multiple targets.
    
    Bug: https://bugs.gentoo.org/672676
    Bug: https://bugs.gentoo.org/718316
    Bug: https://bugs.gentoo.org/704532
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com>
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 x11-libs/xapps/Manifest           |  1 +
 x11-libs/xapps/metadata.xml       |  4 ++
 x11-libs/xapps/xapps-1.8.4.ebuild | 87 +++++++++++++++++++++++++++++++++++++++
 3 files changed, 92 insertions(+)
Comment 8 laurantino 2020-09-19 16:36:38 UTC
Correct me if I am wrong but I think x11-libs/xapps is not required by any stable package so I suggest removing xapps-1.4.2 instead of fixing it. A more recent version will be stabilized later with cinnamon I guess.
Comment 9 Matthew Turnbull 2020-09-19 20:22:13 UTC
Yeah, it looks like the only non-cinnamon in-tree consumer is net-wireless/blueberry (through dev-python/xapp).

I agree removing xapps-1.4.2 should be fine.