Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 672468

Summary: media-sound/pulseaudio-12.2 with dev-libs/libcli: module-cli.c:(.text+0x2ac): undefined reference to `pa_cli_new'
Product: Gentoo Linux Reporter: Gary E. Miller <gem>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED OBSOLETE    
Severity: normal CC: gem, joost.ruis, mgorny, polynomial-c
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/672
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: media-sound:pulseaudio-12.2:20181203-203729.log.gz
emerge --info

Description Gary E. Miller 2018-12-03 20:43:55 UTC
Fails to build.
Comment 1 Gary E. Miller 2018-12-03 20:45:18 UTC
Created attachment 557032 [details]
media-sound:pulseaudio-12.2:20181203-203729.log.gz

build log gzipped
Comment 2 Gary E. Miller 2018-12-03 20:46:37 UTC
The error part of the log:

libtool: relink: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  modules/.libs/module_cli_la-module-cli.o   -Wl,-rpath -Wl,/usr/lib64/pulseaudio -Wl,-rpath -Wl,/usr/lib64/pulse-12.2/modules -L/var/tmp/portage/media-sound/pulseaudio-12.2/image//usr/lib64/pulseaudio -L/usr/lib64/pulseaudio -lpulsecore-12.2 -lpulsecommon-12.2 -L/var/tmp/portage/media-sound/pulseaudio-12.2/image//usr/lib64 -L/usr/lib64 -lpulse -L/var/tmp/portage/media-sound/pulseaudio-12.2/image//usr/lib64/pulse-12.2/modules -L/usr/lib64/pulse-12.2/modules -lcli -lgdbm -lcap -lpthread -lrt -ldl -lm  -O2 -march=haswell -Wl,-z -Wl,nodelete -Wl,--no-undefined -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--enable-new-dtags   -pthread -Wl,-soname -Wl,module-cli.so -o .libs/module-cli.so
modules/.libs/module_cli_la-module-cli.o: In function `module_cli_LTX_pa__init':
module-cli.c:(.text+0x2ac): undefined reference to `pa_cli_new'
module-cli.c:(.text+0x2d2): undefined reference to `pa_cli_set_eof_callback'
modules/.libs/module_cli_la-module-cli.o: In function `module_cli_LTX_pa__done':
module-cli.c:(.text+0x473): undefined reference to `pa_cli_free'
collect2: error: ld returned 1 exit status
libtool:   error: error: relink 'module-cli.la' with the above command before installing it
make[4]: *** [Makefile:5082: install-modlibexecLTLIBRARIES] Error 1
make[4]: Leaving directory '/var/tmp/portage/media-sound/pulseaudio-12.2/work/pulseaudio-12.2-abi_x86_64.amd64/src'
make[3]: *** [Makefile:11468: install-am] Error 2
Comment 3 Gary E. Miller 2018-12-03 20:51:02 UTC
spidey # emerge --info '=media-sound/pulseaudio-12.2::gentoo'
Portage 2.3.51 (python 2.7.15-final-0, default/linux/amd64/17.1, gcc-8.2.0, glibc-2.27-r6, 4.19.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.1-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-1620_v3_@_3.50GHz-with-gentoo-2.6
KiB Mem:    16351188 total,  11860632 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Mon, 03 Dec 2018 19:00:01 +0000
Head commit of repository gentoo: 0aaec72a8df6a65829366fffe125c50567adac21
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p5) 2.30.0
distcc[21449] (dcc_trace_version) distcc 3.2rc1 x86_64-pc-linux-gnu; built Dec 28 2017 06:25:59 [disabled]
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.4.5-r1::gentoo, 3.5.5::gentoo, 3.6.5::gentoo
dev-util/ccache:          3.3.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.38.3::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.14.1::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.30-r4::gentoo
sys-devel/gcc:            8.2.0-r5::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://backup.rellim.com/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: --exclude ChangeLog* --delete-excluded
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=haswell"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=haswell"
DISTDIR="/mnt/backup/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps=y --backtrack=5"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs cgroup config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sfperms splitdebug unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.hoobly.com/ rsync://gentoo.gossamerhost.com/gentoo-distfiles/ ftp://mirror.datapipe.net/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1,--hash-style=gnu,--enable-new-dtags"
LINGUAS="en en_US"
MAKEOPTS="-j8 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude ChangeLog* --delete-excluded"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp/"
USE="X a52 aac aacplus aacs aalib acl adns aesicm aften aio alsa amd64 amr ao apache2 archive ares aspell avahi avresample bash-completion bcmath berkdb binfilter bluray bzip2 cacert cairo calendar caps cdda cgi cgroup cli community corefonts crypt cscope cups curl cxx daap dane dbi dbus dirac dlna dri drm dvd ecwj2k egl enca encode examples exif exit extensions extraengine faac faad ffmpeg fftw firmware flac fontconfig fontforge foomaticdb fortran fping fpm fpx gbm gcrypt gd gdbm geoip geos gif gimp git glamor glib gml gmp gmplayer gnome-keyring gnuplot gnutls gphoto2 gps gs gsm gtk gtk3 gui hardened harfbuzz hdf hdf5 hdri highlight http2 hwdb iconv icu id3tag ilbc imagemagick imap infinality inifile inotify introspection ipmi iproute2 ipv6 jack java jbig jce jemalloc jpeg jpeg2k json lcms libass libedit libextractor liblockfile libnotify libsamplerate libsecret libsoxr libtirpc lmdb lxc lzma lzo mad managesieve mbox memcached mhash mjpeg mmap mmx mmxext mng mp3 mp4 mpeg mtp multilib mysql ncurses netcdf netlink network nfs nfsv4 nfsv41 nodrm nptl nsplugin offensive ogdi ogg openal openexr opengl openmp openssl openvg opus osmesa pam pango pcap pch pcntl pcre pdf pdfimport pdo perl plotutils plugins png policykit postproc ppds printsupport pth pulseaudio python q32 q8 qt4 qt5 rar raw readline realtime rle romio rpc rpz rrl rtmp scanner schroedinger scrypt sctp seccomp server sharedmem slp smi smime smp sndfile snmp sockets spamassassin speex spell sphinx sqlite sqlite3 sse sse2 sse3 sse4_1 ssh ssl ssse3 stats subtitles svg syslog szip t1lib tcpd theora thin-splines threads threadsafe thumbnail tiff tk tokudb tools truetype twolame udev unbound unicode upcall urandom usb utils v4l2 vaapi vhosts vim-syntax vlc vorbis vorbix vpx wavpack webkit webkit2 webp widgets wikipedia winbind wmf x264 xattr xcb xface xine xinerama xml xmp xorg xpm xslt xvfb xvid xvmc xz zeroconf zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_file authz_core authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias http2 proxy proxy_fcgi" APACHE2_MPMS="worker" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" L10N="en en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_5 python3_6" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 4 Gary E. Miller 2018-12-03 20:53:22 UTC
spidey # emerge -pqv '=media-sound/pulseaudio-12.2::gentoo'
[ebuild     U ] media-sound/pulseaudio-12.2 [11.1-r1] USE="X alsa alsa-plugin asyncns caps dbus gdbm glib gtk ipv6 jack libsamplerate orc qt5 realtime ssl tcpd udev webrtc-aec zeroconf -bluetooth -doc -equalizer -gconf% -libressl -lirc -native-headset (-neon) -ofono-headset (-oss) (-selinux) -sox (-system-wide) -systemd -test (-gnome%)" ABI_X86="(64) -32 (-x32)"
Comment 5 Alexander Zatserkovniy 2018-12-06 05:54:31 UTC
Looks like the problem is the result of the library names conflict ( 
dev-libs/libcli and libcli.so in the pulseaudio ).

I got the same problem and resolve it by unmerging dev-libs/libcli .
Comment 6 Lik 2018-12-06 11:20:53 UTC
Can confirm that unmerging dev-libs/libcli resolves the issue.
Comment 7 Gary E. Miller 2018-12-06 19:33:05 UTC
(In reply to Alexander Zatserkovniy from comment #5)

> I got the same problem and resolve it by unmerging dev-libs/libcli .

Works for me too.  Thanks!
Comment 8 Chris 2018-12-06 20:49:52 UTC
Created attachment 557186 [details]
emerge --info
Comment 9 Joost Ruis 2019-01-04 17:40:19 UTC
(In reply to Alexander Zatserkovniy from comment #5)
> Looks like the problem is the result of the library names conflict ( 
> dev-libs/libcli and libcli.so in the pulseaudio ).
> 
> I got the same problem and resolve it by unmerging dev-libs/libcli .

Confirmed.
Comment 10 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-12 08:13:01 UTC
libcli is being removed.