Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 668614

Summary: www.client/firefox-62.0.3 fails to compile: undefined reference to 'mozilla::GetBootstrap(char const*)'
Product: Gentoo Linux Reporter: Ervin Peters <ervin.peters>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: ervin.peters
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.lo (bz2)

Description Ervin Peters 2018-10-14 13:47:13 UTC
Created attachment 551210 [details]
build.lo (bz2)

For some time now, firefox-62.0.3 didn't finish compile:

muli /var/tmp/portage/www-client/firefox-62.0.3/temp # grep -in ' error' build.log 
182: 0:02.87 Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[...]
10:44.93     = warning: once this method is added to the standard library, the ambiguity may cause an error or change in behavior!
30:21.02 /var/tmp/portage/www-client/firefox-62.0.3/temp/ccjH2e03.ltrans1.ltrans.o:<artificial>:function InitXPCOMGlue(): error: undefined reference to 'mozilla::GetBootstrap(char const*)'
30:21.02 collect2: error: ld returned 1 exit status
30:21.02 gmake[4]: *** [/var/tmp/portage/www-client/firefox-62.0.3/work/firefox-62.0.3/config/rules.mk:545: ../../dist/bin/firefox] Error 1
30:21.02 gmake[3]: *** [/var/tmp/portage/www-client/firefox-62.0.3/work/firefox-62.0.3/config/recurse.mk:74: browser/app/target] Error 2
30:31.43 gmake[2]: *** [/var/tmp/portage/www-client/firefox-62.0.3/work/firefox-62.0.3/config/recurse.mk:34: compile] Error 2
30:31.43 gmake[1]: *** [/var/tmp/portage/www-client/firefox-62.0.3/work/firefox-62.0.3/config/rules.mk:418: default] Error 2
30:31.43 gmake: *** [client.mk:150: build] Error 2
 * ERROR: www-client/firefox-62.0.3::gentoo failed (compile phase):
8472: *   (no error message)

emerge info:
Portage 2.3.49 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/gnome/systemd, gcc-7.3.0, glibc-2.26-r7, 4.17.19-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.17.19-gentoo-x86_64-Intel-R-_Core-TM-_i5-6600K_CPU_@_3.50GHz-with-gentoo-2.4.1
KiB Swap:   33554428 total,  33442300 free
Timestamp of repository gentoo: Sun, 14 Oct 2018 06:15:01 +0000
Head commit of repository gentoo: b92cc9ae805091edf16eb4f9215b6b5743b946d5
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p5) 2.30.0
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.30-r4::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://woodstok.ervnet.xl/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

dotnet
    location: /var/lib/layman/dotnet
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

muli
    location: /usr/local/portage
    masters: gentoo
    priority: 1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=skylake -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=skylake -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo http://www.ibiblio.org/pub/Linux/distributions/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en en_GB ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="3d 3ds 64bit X Xaw3d a52 aac ace acl acpi addns aften aim alsa amd64 amr animgif apache2 apng applet aqbanking archive asf aspell assistant audio auto-completion bash-completion bazaar bdf berkdb blender bogofilter branding builder bzip2 cairo cdda cdparanoia cdr charset chm cjk cli collada colord context contrib corefonts crypt css cups curl cvs cvsgraph cxx d darcs dbi dbus deprecated detex devhelp dia discouraged djvu dmx doc dri dri3 drm dts dv dvd dvdnav dvdr dvi dynamicplugin eds emboss emf enca encode equalizer escreen evo examples exif extensions extra extras fam fastcgi fat fax fbcon ffmpeg flac flash fontconfig fontforge fonts foomaticdb fortran fping fpx ftp fuse games gcj gd gdbm gdk-pixbuf geoip georeferencer geos gif gimp git gkrellm glade glamor gles gles1 gnome gnome-keyring gnome-online-accounts gnome-shell gpac gphoto2 gpm gps graphics graphviz grass grub gstreamer gtk gtk2-perl gtkhtml gudev gzip h224 h281 h323 hbci hdri hfs high-ints html humanities ibam icons iconv icq icu ide ieee1394 imagemagick imap infinality inkjar inotify inspector introspection iodbc ios ipv6 irc ithreads jadetex java javascript jbig joystick jpeg jpeg2k kerberos kpathsea lame lasi latex lcms ldap libnotify libsecret libssh2 libtirpc libwww live lm_sensors logrotate lqr lto lua luatex lzo mad mapnik mapserver mdb mdnsresponder-compat menuorg mercurial metric midi mikmod mime minizip mjpeg mms mng mod mozdom mp3 mp4 mpeg mpi mplayer msn mssql mtp multilib music mysql mysqli nautilus ncurses network network-cron networkmanager nfs nfsv4 nls nntp nocd nptl nsplugin ntfs ntfsprogs ntlm odk offensive ofx ogg ogm omega openexr opengl openmp openstreetmap openvg openxml oscar osdmenu pam pango pcf pch pcre pda pdf perl pgf pixmaps player plotutils plugins png pnm polar policykit posix postgres postscript ppds psf pstricks publishers pulseaudio pvr python qt5 quicktime rar raw rdp readline regex register2 reiserfs romio rtsp samba sasl scanner science screen scripts sdl seccomp sensord server sftp shorten simplexml sip sipim slp smartcard smp snmp soap sockets sound soup source sourcecaps sourceview speex spell sql sqlite sqlite3 ssl startup-notification stream subtitles subversion svg sylpheed syslog systemd szip tcpd templates tex tex4ht tga theora thesaurus threads thumbnail thunderbird tidy tiff timidity tinfo tk tools tracker transcode truetype udev udisks unicode unzip upower usb utils uxa v4l vaapi valgrind vcd vdpau vdr vhosts vorbis wav webkit winbind wineappdb wma wmf wxwidgets x264 xattr xbase xcb xcf xcomposite xetex xface xfs xft xml xmlrpc xorgmodule xpm xscreensaver xslt xterm xv xvid xvmc yaepg yahoo youtube zip zlib" ABI_X86="64" ALSA_CARDS="HDA-INTEL" APACHE2_MODULES="modules_unixd actions access_compat alias auth_basic auth_digest authn_anon authn_core authn_dbd authn_dbm authn_file authz_core authz_dbm authz_dbd authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id userdir usertrack vhost_alias asis cgi cgid" APACHE2_MPMS="worker" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse joystick wacom libinput" KERNEL="linux" L10N="de en en-GB ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="php mobility" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="aarch64 armel i386 mips64el mipsel x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

www-client/firefox-62.0-r1::gentoo was built with the following:
USE="dbus gmp-autoupdate pulseaudio screenshot startup-notification -bindist -custom-cflags -custom-optimization -debug -eme-free -hardened -hwaccel -jack (-neon) (-selinux) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite -test -wifi" ABI_X86="(64)" L10N="de en-GB ru -ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -dsb -el -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW"
CFLAGS="-march=skylake -pipe"
CXXFLAGS="-march=skylake -pipe -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns -fno-schedule-insns2"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-rpath=/usr/lib64/firefox,--enable-new-dtags"
Comment 1 Thomas Deutschmann gentoo-dev Security 2018-10-18 10:52:09 UTC

*** This bug has been marked as a duplicate of bug 666784 ***