Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 667268

Summary: dev-vcs/git-2.16.4: segfault on submodule command
Product: Gentoo Linux Reporter: Raymond Jennings <shentino>
Component: Current packagesAssignee: Robin Johnson <robbat2>
Severity: normal CC: jstein, polynomial-c
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 667942    
Bug Blocks:    
Attachments: gdb backtrace
emerge --info
emerge --info

Description Raymond Jennings 2018-09-29 07:07:47 UTC
I ran "git submodule" and it crashed.
Comment 1 Raymond Jennings 2018-09-29 07:08:11 UTC
Created attachment 548148 [details]
gdb backtrace
Comment 2 Raymond Jennings 2018-09-29 07:08:31 UTC
Created attachment 548150 [details]
emerge --info
Comment 3 Raymond Jennings 2018-09-29 07:13:35 UTC
Created attachment 548152 [details]
emerge --info
Comment 4 Jonas Stein gentoo-dev 2018-09-29 13:45:05 UTC
It is sad to read that you have problems with the software. It works for me. 
The situation seems to be a bit more complicate and requires some analysis.
We can not help you efficiently via bug tracker. The bug tracker aims rather on specific problems in .ebuilds and less on individual systems. 

I have had very good experience on the gentoo IRC [1] with questions like this. Of course there are also forums and mailing lists [2,3].
I hope you understand, that I will close the bug here therefore and wish you good luck on one of the mentioned channels [4].
Please reopen the ticket in order to provide an indication for an specific error in an ebuild or any gentoo related product.

Comment 5 Raymond Jennings 2018-09-29 15:49:35 UTC
I reported it upstream, their devs are working with me on getting a reproducible test case.
Comment 6 Jonas Stein gentoo-dev 2018-09-29 16:27:03 UTC
Here is no bugfix IN_PROGRESS. Reverting back to worksforme.

Link to the mailinglist:

Please provide a reproducible example. Upstream requested the same. 
Do not reopen unless you have additional information.
Comment 7 Raymond Jennings 2018-10-01 21:36:40 UTC
Upstream has already fixed this in version 2.18
Comment 8 Raymond Jennings 2018-10-01 22:09:23 UTC
[14:47:42] <veremitz> I'd wait until the stabilisation has run its course, before closing the original bug ..
[14:47:57] <veremitz> but you could push for the stabilisation because of the presence of said bug ..

So I'll open a stabilization request for this
Comment 9 Jonas Stein gentoo-dev 2018-10-03 10:41:23 UTC
As far I can see, upstream did not write about a "bug". They just suggested to use a more recent version and it worked for you. This can be anything. 

Git could be more robust towards broken repositories
There could be a bug in the old Git 2.16
It could be a broken compilation

However it is good to know that it is not reproducible in 2.18 for you.
Comment 10 Raymond Jennings 2018-10-05 00:02:49 UTC
Not yet but one of their follow up comments did:
Comment 11 Raymond Jennings 2018-10-05 00:03:17 UTC
(In reply to Raymond Jennings from comment #10)
> Not yet but one of their follow up comments did:

I mean not yet by the time you checked.