Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 663008

Summary: dev-libs/zziplib fails to build with with “File not recognized: is a directory” on 17.1 profile
Product: Gentoo Linux Reporter: Horea Christian <gentoo>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED WORKSFORME    
Severity: major CC: grknight
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 506276    
Attachments: build log
emerge --info

Description Horea Christian 2018-08-07 08:58:30 UTC
Created attachment 542664 [details]
build log

On an otherwise brand new install, I am getting the attached build log. For whatever it's worth, I'm using the `default/linux/amd64/17.1/desktop/gnome/systemd` profile.

zziplib block numerous other packages.
Comment 1 Horea Christian 2018-08-07 09:00:21 UTC
Created attachment 542666 [details]
emerge --info
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2018-08-07 13:48:34 UTC
Works for me.  Likely a local configuration problem with binutils via binutils-config.
Comment 3 Horea Christian 2018-08-07 23:39:28 UTC
It was apparently because I was in a chroot. I exited it, logged in normally, and it worked.

I don't know whether it's interesting for anybody to try and reproduce it, but maybe this is what happens if you try to migrate to 17.1 while still in the handbook chroot.