Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 661572

Summary: cross-i686-w64-mingw32/gcc-7.3.0-r3:7.3.0::local-crossdev produces non-functional executables
Product: Gentoo Linux Reporter: Evgeny Stambulchik <fnevgeny>
Component: Current packagesAssignee: Gentoo Crossdev team <crossdev>
Status: RESOLVED DUPLICATE    
Severity: normal CC: jstein
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 627914    

Description Evgeny Stambulchik 2018-07-19 11:43:16 UTC
$ i686-w64-mingw32-gcc hello.c
$ wine a.exe
$ 
(no output)

The problem seems related to the -pie option used by default at the linkage.

$ i686-w64-mingw32-gcc -no-pie hello.c
$ wine a.exe
Hello!

hello.c is a standard "hello, world" code:

#include <stdio.h>
#include <stdlib.h>

int main(void)
{
    printf("Hello!\n");
    exit(0);
}
Comment 1 Evgeny Stambulchik 2018-07-19 13:59:45 UTC
PS. Just checked under native OS instead of wine - the same.
Comment 2 Evgeny Stambulchik 2018-07-19 14:29:47 UTC
I guess USE flag "-pie" should be set by default for w32/w64 cross-compilers.
Comment 3 Sergei Trofimovich (RETIRED) gentoo-dev 2018-08-19 12:24:52 UTC

*** This bug has been marked as a duplicate of bug 644930 ***