Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 656142

Summary: dev-games/cegui-0.8.7 : /.../XMLParser.cpp:133:53: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Games <games>
Status: CONFIRMED ---    
Severity: normal CC: yamadharma
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge-info.txt
dev-games:cegui-0.8.7:20180520-074848.log
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
temp.tbz2

Description Toralf Förster gentoo-dev 2018-05-20 08:53:33 UTC
/var/tmp/portage/dev-games/cegui-0.8.7/work/cegui-0.8.7/cegui/src/XMLParserModules/TinyXML/XMLParser.cpp: In member function ‘void CEGUI::TinyXMLDocument::processElement(const TiXmlElement*)’:
/var/tmp/portage/dev-games/cegui-0.8.7/work/cegui-0.8.7/cegui/src/XMLParserModules/TinyXML/XMLParser.cpp:133:53: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
                 if (childNode->ToText()->Value() != '\0')
                                                     ^~~~
make[2]: *** [cegui/src/XMLParserModules/TinyXML/CMakeFiles/CEGUITinyXMLParser.dir/build.make:63: cegui/src/XMLParserModules/TinyXML/CMakeFiles/CEGUITinyXMLParser.dir/XMLParser.cpp.o] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma-systemd_20180508-183531

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.7.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-games/cegui
[ebuild  N    ] dev-games/cegui-0.8.7  USE="lua opengl pcre tinyxml truetype xml -bidi -debug -devil -doc -expat -freeimage -irrlicht -ogre -python -static-libs -xerces-c -zip" PYTHON_TARGETS="python2_7" 

!!! The following installed packages are masked:
- x11-wm/enlightenment-1.0.17::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Joonas Niilola <juippis@gmail.com> (18 May 2018)
# Unmaintained, bugs open without activity, makes users
# install ancient version of enlightenment by typing
# 'emerge enlightenment' due to obnoxious package slotting.
# Bug #656020. Removal in ~30 days

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 1 Toralf Förster gentoo-dev 2018-05-20 08:53:36 UTC
Created attachment 532248 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-05-20 08:53:40 UTC
Created attachment 532250 [details]
dev-games:cegui-0.8.7:20180520-074848.log
Comment 3 Toralf Förster gentoo-dev 2018-05-20 08:53:43 UTC
Created attachment 532252 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-05-20 08:53:45 UTC
Created attachment 532254 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-05-20 08:53:48 UTC
Created attachment 532256 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-05-20 08:53:51 UTC
Created attachment 532258 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2018-05-20 08:53:54 UTC
Created attachment 532260 [details]
temp.tbz2