Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 654610

Summary: dev-ruby/rake should install versioned symlinks
Product: Gentoo Linux Reporter: Matthias Dahl <ua_gentoo_bugzilla>
Component: Current packagesAssignee: Gentoo Ruby Team <ruby>
Status: CONFIRMED ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Matthias Dahl 2018-05-02 13:17:58 UTC
Currently, dev-ruby/rake does not install versioned links, so when doing a gem install locally which requires rake, that will fail looking for rake24/rake25 for example.

TODO:

- add support to the rake ebuild to install versioned links
- add support to the eselect ruby module to manage said links