Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 653678 (ffmpeg-4)

Summary: [TRACKER] >=media-video/ffmpeg-4.0 porting
Product: Gentoo Linux Reporter: Alexis Ballier <aballier>
Component: Current packagesAssignee: Gentoo Media-video project <media-video>
Status: RESOLVED FIXED    
Severity: normal CC: andig.mail, arnaudv6, ashl1future, axiator, bjh-gentoobt, carlphilippreh, devurandom, eugene.shalygin, gentoo, huglovefan, jbuchert+genbug, juippis, mike, nickAristocrates, o.freyermuth, paolo.pedroni, toralf, tsmksubc
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 634102, 653742, 654140, 654160, 654170, 654172, 654176, 654312, 654330, 654402, 654416, 654626, 654628, 654698, 654744, 654830, 654882, 655024, 655026, 655028, 655030, 655170, 655442, 655488, 658128, 660852, 665558, 665710, 666162, 666166, 666168, 670620, 670765, 671214, 672248, 673352, 673378, 673826, 690128    
Bug Blocks: 682392, 654208    

Description Alexis Ballier gentoo-dev 2018-04-21 09:59:39 UTC
ffmpeg-4.0 did a long overdue API/ABI cleanup, thus some packages need porting
Comment 1 Alexis Ballier gentoo-dev 2018-04-21 10:00:44 UTC
Toralf, could you please run a complete tinderbox on ffmpeg-4.0 and file bugs as blockers to this tracker ? Thanks
Comment 2 Larry the Git Cow gentoo-dev 2018-04-21 10:04:09 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f5cc5226663ebd1508427cf54da2319a10bc9a1d

commit f5cc5226663ebd1508427cf54da2319a10bc9a1d
Author:     Alexis Ballier <aballier@gentoo.org>
AuthorDate: 2018-04-21 10:03:39 +0000
Commit:     Alexis Ballier <aballier@gentoo.org>
CommitDate: 2018-04-21 10:03:48 +0000

    profiles: mask ffmpeg4
    
    Bug: https://bugs.gentoo.org/653678

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)}
Comment 3 Kelly Price 2018-04-28 18:04:05 UTC
Some others that are breaking:

media-plugins/gst-plugins-libav
media-video/mplayer
media-video/makemkv
media-sound/audacity
www-plugins/freshplayerplugin
net-misc/freerdp
app-text/unpaper
Comment 4 Larry the Git Cow gentoo-dev 2018-05-11 16:01:51 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=04dbda8f8b26fa328d7109fe48c5773086fc364e

commit 04dbda8f8b26fa328d7109fe48c5773086fc364e
Author:     Ian Stakenvicius <axs@gentoo.org>
AuthorDate: 2018-05-11 15:49:49 +0000
Commit:     Ian Stakenvicius <axs@gentoo.org>
CommitDate: 2018-05-11 16:00:58 +0000

    www-client/firefox: bump to v60
    
    Includes mozcoreconf-v6 and mozconfig-v6.60 eclasses
    
    Closes: http://bugs.gentoo.org/653678
    Closes: http://bugs.gentoo.org/655396
    Closes: http://bugs.gentoo.org/655022
    
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 eclass/mozconfig-v6.60.eclass                      | 396 +++++++++++++++++++++
 eclass/mozcoreconf-v6.eclass                       | 277 ++++++++++++++
 www-client/firefox/Manifest                        | 186 +++++-----
 .../{firefox-59.0.2.ebuild => firefox-60.0.ebuild} |  10 +-
 4 files changed, 771 insertions(+), 98 deletions(-)
Comment 5 Ian Stakenvicius (RETIRED) gentoo-dev 2018-05-11 16:09:52 UTC
SORRY, closed the wrong bug.
Comment 6 klaus818 2018-07-09 17:11:29 UTC
Nobody able to fix this? Every other distribution I tried has a working ffmpeg-4.0
Comment 7 Peer Barber Meyer 2018-08-22 22:50:49 UTC
Yo bitches, whats the hold up here? Come on pull the finger out. Do we have to get fixes for ffmpeg and gcc8. Whats the hold up d00ds?
Comment 8 Amaury Bouchra Pilet 2018-10-28 10:49:45 UTC
media-plugins/alsa-plugins-1.1.7 is now available in portage and, reportedly, working fine with media-video/ffmpeg-4.0.
Could dependency on https://bugs.gentoo.org/show_bug.cgi?id=653742 be removed?
Comment 9 Larry the Git Cow gentoo-dev 2018-11-06 16:02:27 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=deb9d06fb461dc57291498b327e2eeb667444a5f

commit deb9d06fb461dc57291498b327e2eeb667444a5f
Author:     Craig Andrews <candrews@gentoo.org>
AuthorDate: 2018-11-06 14:36:46 +0000
Commit:     Craig Andrews <candrews@gentoo.org>
CommitDate: 2018-11-06 15:58:03 +0000

    package.mask: unmask >=media-video/ffmpeg-4.0
    
    Bug: https://bugs.gentoo.org/653678
    Signed-off-by: Craig Andrews <candrews@gentoo.org>

 profiles/package.mask | 5 -----
 1 file changed, 5 deletions(-)
Comment 10 Aaron Bauman gentoo-dev Security 2019-05-21 03:55:47 UTC
Is this still doing something?
Comment 11 Israel G. Lugo 2019-05-28 20:28:13 UTC
Stable media-libs/openimageio-1.7.17 is broken by this. Please see bug 686920.