Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 652126

Summary: media-video/mplayer-1.3.0-r4 with media-video/ffmpeg-3.4.2-r1 - Nvidia VDPAU playback does not work: VO: Dropping frame with size not matching configured size (1920x1080 vs 1920x1072 vs 1920x1080
Product: Gentoo Linux Reporter: Mario Bachmann <grafgrimm77>
Component: Current packagesAssignee: media-video herd <media-video>
Status: UNCONFIRMED ---    
Severity: normal CC: mail
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Mario Bachmann 2018-04-01 09:49:51 UTC
Last combination in portage-tree that worked:
[ffmpeg-3.3.6 and mplayer-1.3.0-r4]

With faulty combination [ffmpeg-3.4.2-r1 and mplayer-1.3.0-r4] mplayer gives the following with some videos:

VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration 
Dropping frame with size not matching configured size (1920x1080 vs 1920x1072 vs 1920x1080)
Dropping frame with size not matching configured size (1920x1080 vs 1920x1072 vs 1920x1080)
Too many buffered pts

Manually created combination of svn and git version works:
svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer
git clone http://git.ffmpeg.org/ffmpeg.git ffmpeg
Comment 1 Maciej S. Szmigiero 2019-02-22 14:04:38 UTC
This is a known bug, see https://trac.mplayerhq.hu/ticket/2330 .
MPlayer trunk contains a fix that was posted here:
http://mplayerhq.hu/pipermail/mplayer-cvslog/2017-August/047169.html .

I can confirm that with this patch applied MPlayer VDPAU playback works
fine again.

BTW. This bug affects all VDAPU implementations, not just Nvidia's.