Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 651448

Summary: dev-util/coccinelle: uses STRIP_MASK
Product: Gentoo Linux Reporter: Michał Górny <mgorny>
Component: Current packagesAssignee: Tim Harder <radhermit>
Status: RESOLVED FIXED    
Severity: normal CC: esigra, ml
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 259422    

Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-03-25 10:56:57 UTC
STRIP_MASK is a Portage extension and is not supported by any other package manager. This means that your package is silently BROKEN (mis-stripped) for some of our users.

Please remove its use. If you can't strip everything, please RESTRICT=strip.
Comment 1 Larry the Git Cow gentoo-dev 2019-04-14 08:38:40 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3091cdc84e3c33321ba074221ec248dd789af3cc

commit 3091cdc84e3c33321ba074221ec248dd789af3cc
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2019-04-14 08:34:14 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2019-04-14 08:38:34 +0000

    dev-util/coccinelle: Replace STRIP_MASK with RESTRICT=strip
    
    Closes: https://bugs.gentoo.org/651448
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 dev-util/coccinelle/coccinelle-1.0.5.ebuild | 5 ++---
 dev-util/coccinelle/coccinelle-1.0.6.ebuild | 5 ++---
 2 files changed, 4 insertions(+), 6 deletions(-)