Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 65084

Summary: Vegastrike: version bump to 0.4.3
Product: Gentoo Linux Reporter: Emanuele Tamponi <emanuele>
Component: [OLD] GamesAssignee: Gentoo Games <games>
Status: VERIFIED WONTFIX    
Severity: enhancement CC: ben.vighy, beowulfwork, chipper02, ciklop1979, dante333, folken, forceflow2, gen2thomas, ja, justin, leroutier, matija, nowmor, orzel, pez, quazgar, radek, silvio.gerli, sir_tuam, szarpaj, volkerarmin, vollkorn, w31rd0, yannek
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: vegastrike-0.4.2.ebuild
vegastrike-0.4.2
ebuild for version 0.4.1 (see also patches)
patch 1 from 2 for version 0.4.1
patch 2 from 2 for version 0.4.1
Developer CVS-Script
svn ebuild for vegastrike
updated vegastrike svn ebuild
Up to date svn ebuild
Revisioned and Up to date svn ebuild
Data clean up fixed
Reflected the latest svn repository changes
Backported changes from vegastrike-0.5.0
fixed
Updated svn vegastrike ebuild

Description Emanuele Tamponi 2004-09-23 06:19:42 UTC
vegastrike 0.4.2 released: it seems a quite interesting release... an ebuild :D ?

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2004-09-25 04:28:14 UTC
yeah, I'd love an ebuild.  Feel free to attach one.
Comment 2 Elias Kunnas 2004-10-14 06:42:26 UTC
Created attachment 41801 [details]
vegastrike-0.4.2.ebuild

Well here is an ebuild. I believe it should work pretty well, though I haven't 

got past compiling (maybe because of gcc-3.4?) so it could help someone else to

figure out what's the problem..

and btw, this is what I get when it aborts:

g++ -DHAVE_CONFIG_H -I. -I. -I../..   -DHAVE_SDL=1 -DSDL_WINDOWING=1	 
-DHAVE_AL=1  -DUSE_STENCIL_BUFFER=1  -I/usr/include/python2.3 -DHAVE_PYTHON=1 
-DUSE_BOOST_131=1 -I../../src/boost129	-I../../src   -pipe  -gdwarf-2 -g3
-falign-loops=2 -falign-jumps=2 -falign-functions=2  -I/usr/include/SDL
-D_REENTRANT -pthread -pipe -c -o gl_fog.o `test -f 'gl_fog.cpp' || echo
'./'`gl_fog.cpp
In file included from gl_globals.cpp:22:
gl_globals.h:132: error: `PFNGLBINDBUFFERARBPROC' does not name a type
gl_globals.h:133: error: `PFNGLGENBUFFERSARBPROC' does not name a type
gl_globals.h:134: error: `PFNGLDELETEBUFFERSARBPROC' does not name a type
gl_globals.h:135: error: `PFNGLBUFFERDATAARBPROC' does not name a type
gl_globals.h:136: error: `PFNGLMAPBUFFERARBPROC' does not name a type
gl_globals.h:137: error: `PFNGLUNMAPBUFFERARBPROC' does not name a type
make[3]: *** [gl_globals.o] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from gl_fog.cpp:2:
gl_globals.h:132: error: `PFNGLBINDBUFFERARBPROC' does not name a type
gl_globals.h:133: error: `PFNGLGENBUFFERSARBPROC' does not name a type
gl_globals.h:134: error: `PFNGLDELETEBUFFERSARBPROC' does not name a type
gl_globals.h:135: error: `PFNGLBUFFERDATAARBPROC' does not name a type
gl_globals.h:136: error: `PFNGLMAPBUFFERARBPROC' does not name a type
gl_globals.h:137: error: `PFNGLUNMAPBUFFERARBPROC' does not name a type
make[3]: *** [gl_fog.o] Error 1
make[3]: Leaving directory
`/var/tmp/portage/vegastrike-0.4.2/work/vegastrike/src/gldrv'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/var/tmp/portage/vegastrike-0.4.2/work/vegastrike/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/vegastrike-0.4.2/work/vegastrike'
make: *** [all] Error 2

!!! ERROR: games-rpg/vegastrike-0.4.2 failed.
!!! Function src_compile, Line 111, Exitcode 2
!!! emake failed
Comment 3 Elias Kunnas 2004-10-15 12:10:32 UTC
Created attachment 41909 [details]
vegastrike-0.4.2

Now it works for me (needed to download newer glext.h which the ebuild now
notifies the user of). It has one limitation though, if you have empty
directory in cvs-src that vegastrike needs or cvs download didn't complete
succesfully it doesn't check it. But atm, I couldn't figure another way to make
it work.
Comment 4 Mauricio L. Pilla gentoo-dev 2004-11-10 07:04:29 UTC
I'm getting the following error after a lot of compiling:

make[2]: Leaving directory `/home/portage/portage/vegastrike-0.4.2/work/vegastrike'
make[1]: Leaving directory `/home/portage/portage/vegastrike-0.4.2/work/vegastrike'
/usr/portage/games-rpg/vegastrike/vegastrike-0.4.2.ebuild: line 112: cd: /home/portage/portage/vegastrike-0.4.2/work/vssetup/src/: No such file or directory
Can't open perl script "./build": No such file or directory

!!! ERROR: games-rpg/vegastrike-0.4.2 failed.
!!! Function src_compile, Line 113, Exitcode 2
!!! perl build failed
Comment 5 D. W. Srinath 2004-11-20 19:42:32 UTC
hello, could you please add gtk use flag to ebuild?

i got vegastrike to compile successfully without GTK by:
add "cd ${S}/vegastrike/src/" before "emake || die "emake failed""
delete "cd ${S}/vssetup/src; perl ./build || die "perl build failed""
delete "vegastrike/launcher/vslauncher \ vsinstall \"
delete "newgamesbin vssetup/src/bin/setup vssetup || die "newgamesbin failed""
Comment 6 Stephane Loeuillet 2004-11-21 08:05:29 UTC
i think it won't go into portage as long as it is a CVS ebuild (as long as no tarball is available)

because it would kill their CVS server (near 200Mb checkout)
Comment 7 Stefan Vitz 2004-11-28 22:47:18 UTC
this ebuild puts lots of stuff into the cvs-src that is not assignable to the game (directories: data, music, etc). Cause you only copy those files to the working directory why don't put all such thins to ONE directory?

I changed my local ebuild so that it uses the following directory structure:
cvs-src/vegastrike_0_4_2/vegastrike
cvs-src/vegastrike_0_4_2/data
...

only some characters to change, but you always know what files belong to which cvs-build. When you want prevent that later versions  e.g. vegastrike_0_4_3 download all the stuff again instead of updating use an dirname without versions, but I preffer that way.
Comment 8 FieldySnuts 2004-12-08 17:10:54 UTC
So do we have an ebuild to work with here, which might get into portage?
Comment 9 Chris Gianelloni (RETIRED) gentoo-dev 2005-01-22 16:08:00 UTC
So there's no 0.4.2 tarball?
Comment 10 Volker Hemmann 2005-02-02 19:05:35 UTC
Hi,

no and there will be probably never one.
They have a binary win-exe, some third-party debian-packages and the installer-scripts for cvs-checkout. 

Since everybody, who wants to install vs has to checkout cvs, and even the binary windows-package is 170mb, it should be ok, to harm their server ;)

Most of the stuff is artwork, soundeffects and music, downloaded once, never updated again...
Comment 11 folken 2005-02-03 03:34:20 UTC
The cvs server is from sf.net. What if we fabircate a tarball ourselves and distribute that via the gentoo mirrors? Thatway we also could guarantee that it compiles. Alas I don't know what criterias need to be met for a package to make it onto the gentoo mirrors.
Comment 12 Justin Clift 2005-02-04 23:01:22 UTC
If putting a 200MB static tarball on the Gentoo mirrors is difficult, then we can put it on a server somewhere for people to download (http though).

We've still got a few terabytes of spare bandwidth unused each month.

Regards and best wishes,

Justin Clift
Comment 13 Emanuele Tamponi 2005-02-14 05:40:33 UTC
Vegastrike 0.4.3 released, this time it seems providing a tarball :), and also providing maaany exciting features!
Do I open another bug or we can still use this one?

Excuse me if I can't test this game, but with Xinerama and my weird ATI, I haven't 3D acceleration, and I can't get MergedFB working as it should.

Thanks
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2005-02-14 13:57:32 UTC
*** Bug 81484 has been marked as a duplicate of this bug. ***
Comment 15 Volker Hemmann 2005-02-26 11:18:12 UTC
Hi,

I have used their installer and played vs for some time now. 
Despite a buggy setup binary (replacement called vsetup.dynamic can be downloaded from their forum) there were no problems and a lot of fun...
Comment 16 FieldySnuts 2005-07-22 13:57:41 UTC
Any progress? Quite a few people watching this one.
Comment 17 Gordon Pettey 2005-08-03 09:41:29 UTC
I suggest that this ebuild be renamed vegastrike-cvs before placing in portage.
Comment 18 Gordon Pettey 2005-09-02 16:28:18 UTC
Oops. What I meant to say is I'd like a vegastrike-cvs ebuild, because CVS is 
currently updated very far beyond where 0.4.3 is.
Comment 19 Mr. Bones. (RETIRED) gentoo-dev 2005-09-02 17:33:04 UTC
Generally, we don't add live cvs ebuilds since they're impossible to QA.
Comment 20 FieldySnuts 2005-09-06 11:10:54 UTC
*shrug* i guess we won't get what we want. Perhaps the bug should be closed
then. I mean, it's almost a year old now.
Comment 21 Chris Gianelloni (RETIRED) gentoo-dev 2005-09-07 12:58:57 UTC
We don't close bugs for now reason.

Has anyone made a 0.4.3 ebuild?  I've never used Vegastrike before, so if you
leave it up to me, it'll be a while... ;]
Comment 22 Matija "hook" Šuklje 2005-09-19 03:42:19 UTC
I've tried the 0.4.3 installer and I didn't get all the needed executables 
(like the setup and the launcher) 
 
...but maybe it was just a temporary fault, someone else better test it as 
well. 
 
 
p.s. wouldn't it be great if there was a section of Gentoo or a petition page 
or something with where Gentoo users could propose and vote for projects that 
aren't compatible with Gentoo's philosophy (no cvs, min. binary) and/or portage 
to change their ways? (like let's say VegaStrike and PlaneShift at the moment) 
Comment 23 Volker Hemmann 2005-09-19 07:39:15 UTC
Hi, 
 
vegastrike is a little bit tricky to build ;) 
 
there are several vssetup binaries, and none of them really does it job ... 
 
I have compiled the cvs-version several times now, which has its own problems (like 
finding the correct config file to copie around) but I really was not able to make an 
ebuild for it... maybe we should all wait for the next release ... 
Comment 24 Szabo Gabor 2006-01-24 15:28:28 UTC
> ... maybe we should all wait for the next release ... 
Well we should then wait a long time. Right now, the Vega Strike core develpoer team is porting the ogre3d engien for Vega Strike. This started at august 2005. It's not az easy tast so it'll take some time. Ogre3d is an advanded state of art renderer, that will allow better look and effects, and also cool extra features like walkable planets.
But again we'll have to wait long time for that. Meanwhile it'd be nice to add an 0.4.3 VS ebuild to gentoo. THe 0.4.1 edition is almost 3 years old.

http://vegastrike.sourceforge.net/wiki/Development:Ogre
http://vegastrike.sourceforge.net/wiki/FAQ:Feature_Requests#Walkable_planets_and_bases_.5B.5D

Comment 25 Mr. Bones. (RETIRED) gentoo-dev 2006-01-24 15:48:34 UTC
Attaching a working ebuild would speed up the process.
Comment 26 Chris Gianelloni (RETIRED) gentoo-dev 2006-03-31 13:46:00 UTC
We have removed vegastrike from the tree, as it was unmaintainable in its current form.
Comment 27 Volker Hemmann 2006-03-31 13:50:32 UTC
Hi,

without any announcement - great.

btw - there are a lot of cvs ebuilds in the tree, what makes vegastrike so special, that it is not possible to have it?

Comment 28 Justin Clift 2006-03-31 21:51:54 UTC
Thanks for announcing the intention to remove VegaStrike from the tree.

If someone can get a working ebuild for it happening (consistently of course), is it possible to have it added again?
Comment 29 Chris Gianelloni (RETIRED) gentoo-dev 2006-04-01 19:52:36 UTC
Umm... the package has been masked pending removal for more than 2 months.  There's no way you could have not noticed it any time you did an emerge sync and tried to upgrade, so it was announced.

As for it being added back, yes it is possible to have it added back once it becomes maintainable again, which means there's an upstream release that isn't braindead.

We have no intentions of adding a CVS ebuild, either, as they cause us more work than the releases.  This is true of any game, for the record.  We have no way to guarantee that a CVS ebuild will ever even compile.  Yes, there are some in the tree, but those are special cases where the maintainer is willing to accept responsibility for the package when it breaks.  We simply don't have that kind of interest in this game.
Comment 30 Thomas Kohler 2006-08-19 11:39:36 UTC
Hallo!

Unfortunatally I have no news. But to interest someone making an ebuild for version 0.4.3 I will submit some Informations for older versions:
* V 0.3.1 on x86 and amd64 -> fails on install with a compiler error
* V 0.4.1 on x86   -> successfully installed and good playing (attached ebuild)
* V 0.4.1 on amd64 -> fails on install with a compiler error (also only with original installer)
Comment 31 Thomas Kohler 2006-08-19 11:43:22 UTC
Created attachment 94620 [details]
ebuild for version 0.4.1 (see also patches)
Comment 32 Thomas Kohler 2006-08-19 11:44:59 UTC
Created attachment 94621 [details, diff]
patch 1 from 2 for version 0.4.1
Comment 33 Thomas Kohler 2006-08-19 11:47:45 UTC
Created attachment 94623 [details, diff]
patch 2 from 2 for version 0.4.1
Comment 34 Thomas Kohler 2006-08-20 08:32:44 UTC
I have installed today the V 4.0.3 with original installer.
* was successfull on x86 machine (only KDE-Links not ok and installation progress of base-part reached 110% ;o))
* with amd64 interrupted on or after decompressing the package

The files are available at:
 http://prdownloads.sourceforge.net/vegastrike/

For CVS-files there is a shell-script looks like a ebuild (see attachement). Maybe someone can convert this in a ebuild?
Comment 35 Thomas Kohler 2006-08-20 08:34:04 UTC
Created attachment 94703 [details]
Developer CVS-Script
Comment 36 Nicola 2007-06-12 21:37:52 UTC
Created attachment 121866 [details]
svn ebuild for vegastrike

Hi, i got interested in vegastrike lately and i noticed the last ebuild (cvs for 0.4.2 branch) was obsolete because they moved to svn now.

So i decided to modify it to make it work with svn and the new organization of the code.

I managed it to compile on x86 and svn revision 10971 (the latest in this moment), and it runs fine.
The game looks like much different from the 0.4.3 (measures, prices, HUD and some names of components). It didn't even import correctly all my ships.
But it doesn't matter much... it's an svn version... not a final :-D

if you encounter some problems, ebuild related, post them.

bye! :-)

p.s. I know nobody is intreted in maintaining an svn ebuild and it won't appear in portage. Maybe someone could make an ebuild that extracts binaries from the installer and installs them.
At most we could create svn snapshots that will be easily maintained. In vegastrike wiki explains very well how to checkout sources and compile them.
Comment 37 Nicola 2007-06-14 15:38:54 UTC
Created attachment 122042 [details]
updated vegastrike svn ebuild

I found that, after providing the previous ebuild, there were some issues regarding the directory into which to launch vegastrike.

this should be ok. and should be also cleaned of some useless things.
Last i did add the music use flag.

enjoy it! :-) 

p.s. i also changed the name of the package from vegastrike-svn to vegastrike
Comment 38 Piotr Szymaniak 2007-06-15 11:29:35 UTC
(In reply to comment #36)
> if you encounter some problems, ebuild related, post them.

I have a problem. Everything compiles fine, but after running `vsinstall` and then `vslauncher` (Start New Pilot) it crashes with:

lazy_bum@maszyn ~ $ vslauncher 
explore_universe.missionvegastrike explore_universe.mission/usr/bin/vegastrike: line 5: cd: /var/tmp/portage/games-action/vegastrike-9999/work: No such file or directory
/usr/bin/vegastrike: line 6: bin/vegastrike: No such file or directory

Also /usr/bin/vegastrike points somewhere to /var/tmp/portage...
Comment 39 Matija "hook" Šuklje 2007-09-22 20:54:23 UTC
Just to inform everyone watching this bug that VegaStrike 0.5.0 is approaching and with it a new engine (Ogre) and lots of other improvements. Beta of it should come soon.
Comment 40 Volker Hemmann 2007-09-22 21:15:56 UTC
em, wrong.

yes, the next release is close.

no, it won't include ogre,

As it says on their frontpage:

>the bad news is that the OGRE move isn't going to happen for the next release, the good news is that this means that the next release date is not dependent upon OGRE working.
Comment 41 Matija "hook" Šuklje 2007-09-22 21:20:50 UTC
Oops, sorry. I forgot about that post — it's been a long studious day :/
Comment 42 Volker Hemmann 2007-09-22 21:27:09 UTC
well, you could install the svn version an relax while cruising the stars ;)

it works very well for me and the ASAP autopilot is awesome.
Comment 43 Matija "hook" Šuklje 2007-09-22 21:55:39 UTC
Heh, I might do it after the exams. But honestly, I think I won't have time to play with compiling by hand and will just patiently wait for a release.

Still thanks for the tip :)

Erm, I guess we should stop spamming this bug now and wait for the release to open a new bug.
Comment 44 Nicola 2008-02-02 16:35:46 UTC
Created attachment 142507 [details]
Up to date svn ebuild

I updated the old ebuild and fixed some bugs.

Now you can launch vegastrike correctly, and i've also added the amd64 keyword because it compiles and runs on my x86_64 system.

dependency on gtk+ has changed too, since now vegastrike uses gtk+-2

enjoy this new ebuild :-)
Comment 45 Nicola 2008-02-04 11:29:34 UTC
Created attachment 142642 [details]
Revisioned and Up to date svn ebuild

I corrected some bugs in the previous ebuild:

now you can launch also the vegaserver: the dedicated server for vegastrike in netplay.

now it compiles with you system-wide CXXFLAGS.

dependencies issues fixed.


Maybe already this afternoon I will upload also a dedicated-only ebuild, for those who want a dedicated server without X11, and so on :-) (the dependencies are much less)

Enjoy this ebuild, cause vegastrike is much faster with specific CXXFLAGS :-) (but don't be too much aggressive :-) i filter -ffast-math cause I know it corrupts the screen... but I don' know about other aggressive flags!!)
Comment 46 310 2008-04-30 17:44:15 UTC
Created attachment 151441 [details]
Data clean up fixed

 * data4.x/bin contains subdirectories therefore added "-r" option
 * Subversion dirs are named ".svn" not "SVN"
Comment 47 310 2008-05-04 07:39:57 UTC
Created attachment 151767 [details]
Reflected the latest svn repository changes
Comment 48 Nicola 2008-05-04 12:46:39 UTC
Created attachment 151801 [details]
Backported changes from vegastrike-0.5.0

Starting from the most up to date ebuild (thank's to 310) I backported the changes from the ebuild I did for the 0.5.0 release in http://bugs.gentoo.org/show_bug.cgi?id=219559

it's untested: it should work as expectec since changes are just trivial.

if you run into problems.. speak out :-)
Comment 49 310 2008-05-05 14:05:11 UTC
(In reply to comment #48)
> if you run into problems.. speak out :-)

>>> Install vegastrike-9999 into /home/zlo/tmp/portage/games-simulation/vegastrike-9999/image/ category games-simulation
cp: omitting directory `vegastrike/setup'
 *
 * ERROR: games-simulation/vegastrike-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 2633:  Called die
 * The specific snippet of code:
 *       cp vegastrike/setup data/bin/ || die "cp failed";
 *  The die message:
 *   cp failed

-cp vegastrike/setup data/bin/ || die "cp failed"
+cp vegastrike/vssetup data/bin/ || die "cp failed"

maybe?
Comment 50 Nicola 2008-05-06 12:13:48 UTC
(In reply to comment #49)
> 
> -cp vegastrike/setup data/bin/ || die "cp failed"
> +cp vegastrike/vssetup data/bin/ || die "cp failed"
> 
> maybe?
> 

uh yep! but i already copy the vssetup in the previuos if block... and looking to an older ebuild that setup was exactly the vssetup! 

so i think you can safely remove that line, but i should investigate it further..

i should build the svn this afternoon of this evening and check some things and commit the changes.

what do you think about the changes to the ebuild discussed in: http://bugs.gentoo.org/show_bug.cgi?id=219559 ?

bye :-)
Comment 51 310 2008-05-06 16:21:01 UTC
(In reply to comment #50)
> (In reply to comment #49)
> > 
> > -cp vegastrike/setup data/bin/ || die "cp failed"
> > +cp vegastrike/vssetup data/bin/ || die "cp failed"
> > 
> > maybe?
> > 
> 
> uh yep! but i already copy the vssetup in the previuos if block... and looking
> to an older ebuild that setup was exactly the vssetup! 
> 
> so i think you can safely remove that line, but i should investigate it
> further..

I actually have commented out both:

#cp vegastrike/setup data/bin/ || die "cp failed"
#cp vsinstall data/bin/vsinstall || die "cp failed"

because it seems that vsinstall is already installed earlier:

dogamesbin vsinstall \
    || die "Creation of vsinstall failed"

> what do you think about the changes to the ebuild discussed in:
> http://bugs.gentoo.org/show_bug.cgi?id=219559 ?

I'm not that skilled in ebuilds yet, sorry ;-)
Comment 52 Nicola 2008-05-07 12:53:47 UTC
Created attachment 152257 [details]
fixed

Ok was a line I wanted to remove, but I forgot to.

and what abut renaming this thread? it's obvioulsy vegastrike-0.4.3 no more! :-)

maybe "Vegastrike SVN" ? :-)

and once we get to compile everything without issues, what about putting this ebuild and the 0.5.0 one on sunrise overlay? :-)

Bye :-)
Comment 53 DaggyStyle 2008-05-21 04:13:18 UTC
make[1]: Leaving directory `/var/tmp/portage/games-scifi/vegastrike-9999/work/vegastrike'
>>> Source compiled.
>>> Test phase [not enabled]: games-scifi/vegastrike-9999

>>> Install vegastrike-9999 into /var/tmp/portage/games-scifi/vegastrike-9999/image/ category games-scifi
cp: cannot create regular file `data/bin/vsinstall': No such file or directory
 *
 * ERROR: games-scifi/vegastrike-9999 failed.

dude, I dont mean to be rude but have you even tested the ebuild before releasing it?
Comment 54 Nicola 2008-05-21 13:49:51 UTC
(In reply to comment #53)
> make[1]: Leaving directory
> `/var/tmp/portage/games-scifi/vegastrike-9999/work/vegastrike'
> >>> Source compiled.
> >>> Test phase [not enabled]: games-scifi/vegastrike-9999
> 
> >>> Install vegastrike-9999 into /var/tmp/portage/games-scifi/vegastrike-9999/image/ category games-scifi
> cp: cannot create regular file `data/bin/vsinstall': No such file or directory
>  *
>  * ERROR: games-scifi/vegastrike-9999 failed.
> 
> dude, I dont mean to be rude but have you even tested the ebuild before
> releasing it?
> 

well... i didn't test it... but i clarified it in: comment #48... 
but as in gentoo way of doing things, this is not an ebuild for everybody: it's just for those who want to play with it.

if you want vegastrike just use the provided ebuild in http://bugs.gentoo.org/show_bug.cgi?id=219559 that's based upon a release.

ebuilds based on svn are know to be exposed to frequent brakings, due to the nature of svn development. 

in this case it's evident: in the previous versions of the svn the "bin" dir did exist! now they changed it... and it doesn't exist any more. so testing it or not testing it.. is not that much different... as long as they break things!
just insert in the ebuild the "mkdir bin" when it's under the data directory and propose the change.

so if you just want vegastrike use the ebuild for the 0.5.0 version. if you want unstable code (yeah! svn is potentially unstable and can fail during compilation!) just modify the ebuild following the svn changes, and propose the changes!

ah sorry one last thing: on bugzilla you don't release anything: you propose! the user/developer than decides what's good and what's not good.
So don't expect releasing quality in a bugzilla.

I tried to give you both the info to fix it and the way to interpret ebuilds...  especially on a bugzilla.

Bye! :-) 
Comment 55 Daniel 2008-07-18 08:38:52 UTC
Created attachment 160700 [details]
Updated svn vegastrike ebuild

fixes
cp: cannot create regular file `data/bin/vsinstall': No such file or directory

issue. But runs into an access violation issue...
Comment 56 Infinity 2009-09-22 16:55:42 UTC
after running into some compilation error 

line :3166 src/cmd/basecomputer.cpp

to fix it i commented all others except for line:3149 like this ::



//#if defined(_WIN32) && !defined(__CYGWIN__)
typedef int (*scancompare) ( const struct dirent **v1, const struct dirent **v2 );
//#else
//typedef int (*scancompare) ( const void *v1, const void *v2 );
//#endif

it fixed it on my gentoo linux and vegastrike works fine:)
(I don't remember where is the exact solution which actually adds an OR operator in line: 3149 ,srry guys!)
Comment 57 Jared Kidd 2009-12-19 02:27:56 UTC
Why is this bug closed? The ebuild still gives the same access violation error that many people are posting about in this bug. Can this bug be reopened?