Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 650228

Summary: x11-base/xorg-server-1.19.99.901-r1 renders XFCE session unenterable (segfault at libxcb-glx.so.0.0.0)
Product: Gentoo Linux Reporter: Sebastian Pipping <sping>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: normal CC: alexander, burcheri.massimo+bugs-gentoo, che, derk.tebokkel, devurandom, gmturner007, herrtimson, joost.ruis, kripton, polynomial-c, sergeev917, silencly07, thomas.bettler, tka, viklevin2
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Sebastian Pipping gentoo-dev 2018-03-11 16:59:58 UTC
I'm still researching the very cause of this problem so the summary in the title may still change.  The symptom was, that after upgrading a number of packages, when logging in to an XFCE 4 session, I would be dropped right back into the log-in manager with lines like

  [   24.976424] xfsettingsd[6648]: segfault at c ip 00007f6bc7ec4de0 sp 00007ffe3060c188 error 4 in libxcb-glx.so.0.0.0[7f6bc7eb8000+19000]

in dmesg output, for xfce4-session and xfce4-panel and so on as well.

I'm severity to critical because it took me multiple hours to be able to log back into my X session.
Comment 1 Sebastian Pipping gentoo-dev 2018-03-11 17:49:16 UTC
Further analysis confirms the issue for:
* XFCE 4.12 and XFCE 4.13
* Mesa 17.3.6 and 18.0.0_rc4
* libxcb 1.12-r2 and 1.13

So x11-base/xorg seems indeed to be the issue here.
Comment 2 Larry the Git Cow gentoo-dev 2018-03-11 17:57:26 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b4f2511b6e74db82bac5291a9d7fd9f031ef0c9d

commit b4f2511b6e74db82bac5291a9d7fd9f031ef0c9d
Author:     Sebastian Pipping <sping@gentoo.org>
AuthorDate: 2018-03-11 17:52:30 +0000
Commit:     Sebastian Pipping <sping@gentoo.org>
CommitDate: 2018-03-11 17:57:01 +0000

    package.mask: Protect users from broken XFCE
    
    Bug: https://bugs.gentoo.org/650228

 profiles/package.mask | 4 ++++
 1 file changed, 4 insertions(+)}
Comment 3 Jan Psota 2018-03-11 21:52:02 UTC
A have the same! (on system with newest ~amd64 packages)
But only trying to log-in after logging-out.
xdm restart allows me to log-in again.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2018-03-12 10:28:14 UTC
Considering that other desktop environments like KDE and Gnome seem to work fine, adding this mask IMHO is a drastic measure...
Comment 5 Thomas Beinicke 2018-03-12 10:45:17 UTC
I seem to have the same problem with kde.
The only reason I could login to KDE every time was to completely disable plasmashell and use "liquidshell" inside kde.

Also using intel via modesetting driver.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2018-03-12 12:08:37 UTC
Sebastian, what graphics device and driver do you use?
Comment 7 Sebastian Pipping gentoo-dev 2018-03-12 19:26:26 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #4)
> Considering that other desktop environments like KDE and Gnome seem to work
> fine, adding this mask IMHO is a drastic measure...

I dared to go for it due to damage it does to users.  It's totally up for discussion, just a start, I'd be happy to get it back safely some way.


(In reply to Lars Wendler (Polynomial-C) from comment #6)
> Sebastian, what graphics device and driver do you use?

I use x11-drivers/xf86-video-intel-2.99.917_p20180214 with this card:

# /usr/sbin/lspci -v | fgrep -A8 VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo 2nd Generation Core Processor Family Integrated Graphics Controller
        Flags: bus master, fast devsel, latency 0, IRQ 24
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2018-03-12 20:50:43 UTC
So two reports from intel users. 
I have no issues with this xorg-server version neither with latest xf86-video-ati nor with latest xf86-vide-amdgpu (both running kde).
Comment 9 Sebastian Pipping gentoo-dev 2018-03-12 22:03:35 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #8)
> So two reports from intel users. 
> I have no issues with this xorg-server version neither with latest
> xf86-video-ati nor with latest xf86-vide-amdgpu (both running kde).

Fair enough, let me try with intel downgraded to 2.99.917_p20171018 and xorg-server back at 1.19.99.901-r1.
Comment 10 Sebastian Pipping gentoo-dev 2018-03-12 23:14:04 UTC
(In reply to Sebastian Pipping from comment #9)
> Fair enough, let me try with intel downgraded to 2.99.917_p20171018 and
> xorg-server back at 1.19.99.901-r1.

Same issue with 2.99.917_p20171018 (that has been well with previous Xorg for me since October).
Comment 11 Matt Turner gentoo-dev 2018-03-13 00:11:45 UTC
REALLY NOT OK to unilaterally mask a package just because you have a bug.

Have you filed an upstream bug? Please do so.
Comment 12 Alexander Sergeyev 2018-03-13 07:09:22 UTC
I have intel graphics too, but with i3wm and with X started via startx from a virtual console. The libxcb-glx.so library is used by firefox, according to /proc/$pid/maps. So far I've got no problems, let alone crashes.

Versions and flags:
x11-base/xorg-server-1.19.99.901-r1:0 glamor udev unwind xorg -debug -dmx -doc -ipv6 -kdrive -libressl -minimal -selinux -static-libs -systemd -wayland -xcsecurity -xephyr -xnest -xvfb
x11-drivers/xf86-video-intel-2.99.917_p20180214:0 dri dri3 sna xvmc -debug -tools -udev -uxa
x11-libs/libxcb-1.12-r2:0 xkb -doc -selinux -static-libs -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32"
Comment 13 Massimo Burcheri 2018-03-13 09:01:10 UTC
All last xorg-server versions have been working with Xfce:  1.19.5  1.19.6  1.19.6-r1  1.19.99.901  1.19.99.901-r1. Yesterday  1.19.5-r1 was breaking Xfce. Going back to 1.19.99.901-r1 makes Xfce start again but still has graphic errors on some panels. It's radeon graphics.
Comment 14 Sebastian Pipping gentoo-dev 2018-03-13 19:59:20 UTC
(In reply to Matt Turner from comment #11)
> REALLY NOT OK to unilaterally mask a package just because you have a bug.

I didn't mask it for me: a local mask is way less work than opening a ticket and masking things in Git, for me.  I masked it to save others hours to unbreak their X session.  I'm happy with any way the X11 team decides to deal with the mask and the problem.
Comment 15 Massimo Burcheri 2018-03-14 07:59:04 UTC
(In reply to Sebastian Pipping from comment #14)

> I masked it to save others hours to
> unbreak their X session.

This issue is not trivial. The strategy of Sebastian and the fact that the mask had already arrived in the tree when I encountered the breakage, that all saved my working day.
Comment 16 Massimo Burcheri 2018-03-14 08:06:37 UTC
(In reply to Massimo Burcheri from comment #13)
> Going back to 1.19.99.901-r1 makes Xfce start again but still has
> graphic errors on some panels. It's radeon graphics.
Graphic errors are rather caused by fontconfig, https://bugs.gentoo.org/650248#c9.
Comment 17 hkBst 2018-03-16 10:55:46 UTC
I have no problem running x11-base/xorg-server-1.19.99.901 with xfce4 and lxdm-0.5.3-r1 on

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
	Subsystem: Hewlett-Packard Company HD Graphics 520
	Kernel driver in use: i915

, though logging out (and back in) is not something I generally do or have tried yet with this setup.

# emerge --info xorg-server
Portage 2.3.24 (python 3.5.4-final-0, default/linux/amd64/17.0/no-multilib, gcc-6.4.0, glibc-2.26-r6, 4.4.119-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.119-gentoo-x86_64-Intel-R-_Core-TM-_i5-6200U_CPU_@_2.30GHz-with-gentoo-2.4.1
KiB Mem:     8053392 total,   2124944 free
KiB Swap:   16123900 total,  16123900 free
Timestamp of repository gentoo: Fri, 16 Mar 2018 09:30:01 +0000
Head commit of repository gentoo: 716f27ab11dd7522e3ed73c56ec8ad5bd34dc573
sh bash 4.4_p19
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p19::gentoo
dev-lang/perl:            5.26.1-r2::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo, 3.6.4::gentoo
dev-util/cmake:           3.10.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.35.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo, 1.16-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo, 2.30::gentoo
sys-devel/gcc:            6.4.0::gentoo, 7.2.0-r1::gentoo, 7.3.0::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r2::gentoo
sys-kernel/linux-headers: 4.15::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bindist bzip2 cairo cjk cli consolekit crypt cxx dbus dri egl emacs flac fontconfig fortran gdbm gif gles gnutls gpm gtk iconv icu ipv6 jpeg jpeg2k lapack libressl midi modules mp3 ncurses networkmanager nls nptl nss ogg opengl openmp otr pam pcre pdf png policykit postscript pulseaudio qml readline seccomp sqlite ssl startup-notification svg tcpd tiff tk truetype udev unicode vorbis vulkan wav wayland webp xattr xcb xft xpm xscreensaver zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" L10N="en nl de fr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965" XFCE_PLUGINS="brightness clock multiload-nandhp power trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

x11-base/xorg-server-1.19.99.901::gentoo was built with the following:
USE="glamor ipv6 libressl udev wayland xorg -debug -dmx -doc -kdrive -minimal (-selinux) -static-libs -systemd -unwind -xcsecurity -xephyr -xnest -xvfb"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,lazy"
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2018-04-04 07:10:43 UTC
I've added x11-base/xorg-server-1.19.99.903_pre to poly-c overlay and would like people having issues with xorg-server-1.19.99.901 to test that version and report back if they still have issues. Don't be confused by the "_pre" in the version. I simply use it to make the version in my overlay lower than the same version on ::gentoo (once it got added there).
Comment 19 tka 2018-04-15 20:34:39 UTC
I tested xorg-server-1.19.99.904 (copied the xorg-server-1.19.99.901-r1 ebuild and removed the randr patch). I build xorg-server-1.19.99.904, restarted X, and built media-video/vlc (vlc's test suite reliable triggered the segfaults for me). No segfault, looks good.

Then, I downgraded to xorg-server-1.19.99.901-r1, restarted X, build vlc, and
> vlc[14227]: segfault at c ip 00007f1721e76db3 sp 00007f16e9ba6440 error 4 in libxcb-glx.so.0.0.0[7f1721e69000+20000]

So to confirm the result, back to xorg-server-1.19.99.904. Rebuilt vlc and no segfault. So the problem seems to be fixed in 1.19.99.904.
Comment 20 Matt Turner gentoo-dev 2018-04-15 23:05:24 UTC
Thanks!

I've pushed 1.19.99.904 into the tree. It's still masked until sping gives the go ahead.

Please test and confirm it works.
Comment 21 Larry the Git Cow gentoo-dev 2018-04-15 23:07:15 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1eaaa168373da2f6258680765585f191ca5f953e

commit 1eaaa168373da2f6258680765585f191ca5f953e
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2018-04-15 22:59:58 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2018-04-15 23:00:12 +0000

    x11-base/xorg-server: Version bump to 1.19.99.904
    
    Bug: https://bugs.gentoo.org/650228

 x11-base/xorg-server/Manifest                      |   1 +
 .../xorg-server/xorg-server-1.19.99.904.ebuild     | 220 +++++++++++++++++++++
 2 files changed, 221 insertions(+)}
Comment 22 Matt Turner gentoo-dev 2018-05-10 18:16:19 UTC
Please try 1.20.0. When you added the package.mask you took the responsibility of testing fixes.
Comment 23 Derk W te Bokkel 2018-05-11 12:59:34 UTC
I'm not sure but bug 653744 may also be a manifestation of this bug..
perhaps xfwm4 (gtk2) is the culprit xfwm4(gtk3) git based build appears to work.
Just extra info for consideration
Comment 24 manwe 2018-05-11 16:20:02 UTC
I've just tested xorg-server 1.12.0 and it breaks xfwm4 with --composite=on (I'm not using whole xfce, just xfwm). With --composite=off it works fine, but with =on whole screen turns white. There are windows below, I can see mouse cursor changing while hovering over them. Intel HD 4600, everything up to date from ~amd64 tree.
Comment 25 Sebastian Pipping gentoo-dev 2018-05-13 17:09:04 UTC
(In reply to Matt Turner from comment #22)
> Please try 1.20.0.

No crashes with 1.20.0 with XFCE for me.


(In reply to manwe from comment #24)
> I've just tested xorg-server 1.12.0 and it breaks xfwm4 with --composite=on

I have xfce-base/xfwm4[xcomposite] around and just enabled "Composite" mode in Xfce WM Composite Editor for the first time.  See shadows now, seems to work for me.  Is that the same thing that's broken for you?
Comment 26 David Heidelberg (okias) 2018-05-13 20:02:34 UTC
GUYS, so 1.20.0 is masked for everyone due to some unspecified crash with Xfce for "some" users? No debug info, no upstream report (xfce or xorg)?

as @mattst88 says, it's no reason to mask it (not saying it's bugless)..

Please unmask, it's Gentoo, not Debian stable...
Comment 27 Greg Turner 2018-05-13 22:09:10 UTC
The particular reason for this mask's creation might have been overly conservative, but have you guys seen this?:

https://lists.x.org/archives/xorg-devel/2018-May/056913.html

I can't even remember the last time there was a major xorg-server release... can you?  Pretty sure it's been a good while.  I know we're running ~amd64 and sometimes stuff is just going to happen but... this particular update seems like the type of thing very, very likely to catch a good number of desktop users unaware and really mess their day up.

Has there been some serious assessment as to how much trouble this particular update is likely to cause across the Gentooverse?  Xorg really ought to be treated with kid gloves like portage, pid-1 and toolchain packages, shouldn't it, so we don't make everybody miserable even if they technically could/should have known better?
Comment 28 Greg Turner 2018-05-13 22:28:13 UTC
(In reply to Greg Turner from comment #27)
> The particular reason for this mask's creation might have been overly
> conservative, but have you guys seen this?:
> 
> https://lists.x.org/archives/xorg-devel/2018-May/056913.html

OK, I should have kept reading.. the above was just the user doing --enable-dri1 across the affected drivers which looks like the default in xorg-2.eclass.  

Anyhow my point wasn't really about that particular thing; just a general note of caution: I see no urgent need to rush into unmasking the release until there's a sense that most things work for most users...  Those eager to jump onto the latest can always unmask it in /etc/portage.

By the way I hope none of this sounds like I'm assuming the X herd hasn't done their job or something... frankly I have no idea what their process looks like but I'm sure they do plenty of work behind the scenes that I've benefited from in blissful ignorance :)
Comment 29 Mike Lothian 2018-05-23 12:29:24 UTC
Has anyone reported this upstream?

I had a lot of issues with the pre-release of Xserver 1.20, including one that was really a Mesa bug, but they've been fixed now
Comment 30 Alex Bennee 2018-06-06 08:20:40 UTC
I'll add that on my SynQuacer I was hardly able to log in due to triggering nouveau bugs. Since unmasking the latest xorg for my system it's a lot more stable.
Comment 31 Alex Bennee 2018-06-06 08:23:41 UTC
(In reply to Alex Bennee from comment #30)
> I'll add that on my SynQuacer I was hardly able to log in due to triggering
> nouveau bugs. Since unmasking the latest xorg for my system it's a lot more
> stable.

Sorry I should add it's 1.20 now:

[IP-] [  ] x11-base/xorg-drivers-1.20:0
[IP-] [  ] x11-base/xorg-proto-2018.4:0
[IP-] [  ] x11-base/xorg-server-1.20.0:0/1.20.0
[IP-] [  ] x11-base/xorg-x11-7.4-r3:0
Comment 32 Matt Turner gentoo-dev 2018-06-08 05:08:38 UTC
Marking as resolved, due to some unknown combination of fixes...
Comment 33 hkBst 2018-06-16 15:19:14 UTC
Posting from LXDE as XFCE with the new xorg-server-1.20 is showing me the white screen manwe also mentioned and is unusable.

$ emerge --info xfwm4
Portage 2.3.40 (python 3.5.5-final-0, default/linux/amd64/17.0/no-multilib, gcc-6.4.0, glibc-2.27-r4, 4.4.119-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.119-gentoo-x86_64-Intel-R-_Core-TM-_i5-6200U_CPU_@_2.30GHz-with-gentoo-2.6
KiB Mem:     8053392 total,   4479348 free
KiB Swap:   16123900 total,  16123900 free
Timestamp of repository gentoo: Sat, 16 Jun 2018 14:30:01 +0000
Head commit of repository gentoo: f1b8e15de61579c83b8247339cb45f55d71320cb
sh bash 4.4_p23
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p23::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.14-r2::gentoo, 3.5.5-r1::gentoo, 3.6.5-r1::gentoo
dev-util/cmake:           3.11.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6::gentoo
sys-apps/openrc:          0.36::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo, 2.30-r3::gentoo
sys-devel/gcc:            6.4.0::gentoo, 7.2.0-r1::gentoo, 7.3.0-r3::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.16-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bindist bzip2 cairo cjk cli consolekit crypt cxx dbus dri egl emacs flac fontconfig fortran gdbm gif gles gnutls gpm gtk iconv icu ipv6 jpeg jpeg2k lapack libressl libtirpc midi modules mp3 ncurses networkmanager nls nptl nss ogg opengl openmp otr pam pcre pdf png policykit postscript pulseaudio qml readline seccomp sqlite ssl startup-notification svg tcpd tiff tk truetype udev unicode vorbis vulkan wav wayland webp xattr xcb xft xpm xscreensaver zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" L10N="en nl de fr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965" XFCE_PLUGINS="brightness clock multiload-nandhp power trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

xfce-base/xfwm4-4.13.0-r1::gentoo was built with the following:
USE="opengl startup-notification xcomposite -xpresent"
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="-march=native -O2 -pipe"
Comment 34 hkBst 2018-06-16 15:37:20 UTC
Recompiling xfwm4 did not help. Recompiling without xcomposite runs into a compiler error:

display.c: In function ‘myDisplayGetScreenFromOutput’:
display.c:612:19: error: ‘ScreenInfo {aka struct _ScreenInfo}’ has no member named ‘output’
         if (screen->output == output)
                   ^~
make[3]: *** [Makefile:726: xfwm4-display.o] Error 1
make[3]: *** Waiting for unfinished jobs....
icons.c: In function ‘inline_icon_at_size’:
icons.c:77:5: warning: ‘gdk_pixbuf_new_from_inline’ is deprecated [-Wdeprecated-declarations]
     base = gdk_pixbuf_new_from_inline (-1, data, FALSE, NULL);
     ^~~~
In file included from /usr/include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf.h:34:0,
                 from /usr/include/gtk-2.0/gdk/gdkpixbuf.h:37,
                 from /usr/include/gtk-2.0/gdk/gdkcairo.h:28,
                 from /usr/include/gtk-2.0/gdk/gdk.h:33,
                 from icons.c:31:
/usr/include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-core.h:362:12: note: declared here
 GdkPixbuf* gdk_pixbuf_new_from_inline (gint          data_length,
            ^~~~~~~~~~~~~~~~~~~~~~~~~~

Sticking to LXDE for now, but let me know if there is anything else I can try!
Comment 35 tt_1 2018-06-16 15:43:26 UTC
You def should open a new bug for the compile failure, and also consider to speak with upstream too in case they are unaware of it.
Comment 36 hkBst 2018-06-22 07:36:15 UTC
Please reopen...
Comment 37 Matt Turner gentoo-dev 2018-06-22 15:07:53 UTC
(In reply to hkBst from comment #36)
> Please reopen...

Please open a new bug, since I think this is a different bug from the one originally reported. The original reporter confirmed his was fixed.
Comment 38 hkBst 2018-06-23 09:19:33 UTC
Very well: bug 658810.