Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 648350

Summary: dev-perl/libintl-perl faisl to compile when installing Prefix
Product: Gentoo/Alt Reporter: Marius Stoica <Letto2>
Component: Prefix SupportAssignee: Gentoo Prefix <prefix>
Status: UNCONFIRMED ---    
Severity: normal CC: kentnl, Letto2
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=586184
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info
emerge log

Description Marius Stoica 2018-02-21 09:15:23 UTC
When running ./bootstrap-prefix.sh, the script stops when compiling dev-perl/libintl-perl-1.280.0. The same thing happens with all the versions of libintl-perl that I tried. 


Reproducible: Always
Comment 1 Marius Stoica 2018-02-21 09:17:15 UTC
Created attachment 520370 [details]
emerge --info
Comment 2 Marius Stoica 2018-02-21 09:19:32 UTC
Created attachment 520372 [details]
emerge log
Comment 3 Fabian Groffen gentoo-dev 2018-05-29 11:48:22 UTC
Seems like it shouldn't use -lintl for your platform.  Somehow it thinks it needs it though.

What is the host OS here?
Comment 4 Marius Stoica 2018-05-29 12:27:07 UTC
I tried installed this prefix on Mageia 5, updated to the latest version of all packages on the date that I reported this bug.
Comment 5 Kent Fredric (IRC: kent\n) gentoo-dev 2019-07-15 10:15:28 UTC
This section here in configure:

---
Warning: NAME must be a package name
Warning (mostly harmless): No library found for -liconv
Writing MYMETA.yml and MYMETA.json
---

Would have emitted the line:

---
Warning (mostly harmless): No library found for -lintl
---

If -lintl was not available.

That it detected it in configure, and then failed to find it at compile, smells spicy.