Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 646236

Summary: gnome-base/gconf-3.2.6-r4 - configure: error: XML::Parser perl module is required for intltool
Product: Gentoo Linux Reporter: Frank Daniel <fdan52>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Frank Daniel 2018-01-31 19:18:29 UTC
I am currently (re)installing Gentoo and have a problem with emerging the @world.

I am following the current AMDx64 manual and the new(?) default/linux/amd64/17.0/desktop/gnome/systemd (stable) profile.
All went well until using the command "emerge --ask  --deep --update --newuse @world".  Where I was confronted the message "XML::Parser... configure: error: XML::Parser perl module is required for intltool".

 ERROR: gnome-base/gconf-3.2.6-r4::gentoo failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *               ebuild.sh, line  124:  Called src_configure
 *             environment, line 4077:  Called multilib-minimal_src_configure
 *             environment, line 2452:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *             environment, line 2666:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2382:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2380:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *             environment, line  359:  Called multilib-minimal_abi_src_configure
 *             environment, line 2446:  Called multilib_src_configure
 *             environment, line 2878:  Called gnome2_src_configure '--disable-static' '--enable-gsettings-backend' '--with-gtk=3.0' '--disable-orbit' '--enable-introspection' '--with-openldap' '--enable-defaults-service'
 *             environment, line 1921:  Called econf '--enable-debug=yes' '--disable-gtk-doc' '--disable-maintainer-mode' '--docdir=/usr/share/doc/gconf-3.2.6-r4' '--disable-static' '--enable-gsettings-backend' '--with-gtk=3.0' '--disable-orbit' '--enable-introspection' '--with-openldap' '--enable-defaults-service'
 *        phase-helpers.sh, line  666:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *              die "$@"


I have Attach the requested files.
Comment 1 nobody 2018-01-31 23:55:30 UTC
You've win the worst bug report made this month :)

Your title should aim at your issue -> gnome-base/gconf-3.2.6-r4 missing dependency dev-perl/XML-Parser


The severity is trivial, because fixing the XML::Parser trouble will fix your issue.
just "emerge -1 XML-Parser", if you had an update of perl, the issue is that the new perl doesn't have it yet, something perl-cleaner will do for you.
So if you update perl and the updates that follow fail with perl, run perl-cleaner next time.

You have tried and fail to post the attachment, which won't be a big issue once you'll gave the answer if "emerge -1 XML-Parser" has fix your issue :D

I hope it help you.
You can mark it a dup of https://bugs.gentoo.org/41124 if it was your issue.
Comment 2 Jeroen Roovers gentoo-dev 2018-02-01 03:36:06 UTC
Thank you for your bug report. What little information you gave us was probably enough to advise you that it looks like you need to run perl-cleaner.

*** This bug has been marked as a duplicate of bug 41124 ***