Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 645572

Summary: media-libs/mesa [LTO] lto1: internal compiler error: Segmentation fault
Product: Gentoo Linux Reporter: Petross404(Petros S) <petross404>
Component: Current packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED OBSOLETE    
Severity: normal CC: huglovefan, tsmksubc
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 618550    
Attachments: media-libs:mesa-17.3.1:20180124-153245.log
emerge --info

Description Petross404(Petros S) 2018-01-24 16:29:20 UTC
Created attachment 516360 [details]
media-libs:mesa-17.3.1:20180124-153245.log

Mesa fails to build with LTO unless -flto-partition=none is passed to portage.
Comment 1 Petross404(Petros S) 2018-01-24 16:29:43 UTC
Created attachment 516362 [details]
emerge --info
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2018-01-26 12:18:05 UTC
Comment on attachment 516362 [details]
emerge --info

>KiB Mem:     8172296 total,   1631744 free
[...]
>MAKEOPTS="-j5 -l4"

That is not a lot of memory per process.
Comment 3 Matt Turner gentoo-dev 2018-01-27 03:14:49 UTC
I can reproduce the segfault with gcc-7.2.0 and gcc-7.3.0 on a system with 16GB of RAM. I don't see anything in dmesg indicating it was caused by running out of memory.

Reassigning to gcc maintainers.
Comment 4 Sergei Trofimovich gentoo-dev 2019-07-26 18:03:27 UTC
Does this keep happening for anyone on current versions of packages?
Comment 5 Petross404(Petros S) 2019-07-26 19:16:42 UTC
(In reply to Sergei Trofimovich from comment #4)
> Does this keep happening for anyone on current versions of packages?

I will test with GCC 9.1 and report ASAP.
Comment 6 Petross404(Petros S) 2019-11-06 22:17:04 UTC
media-libs/mesa-19.2.1 installed without any workaround or special gcc options.
Comment 7 Sergei Trofimovich gentoo-dev 2019-11-06 22:58:01 UTC
(In reply to Petross404(Petros S) from comment #6)
> media-libs/mesa-19.2.1 installed without any workaround or special gcc
> options.

Thank you! Let's close it as obsolete.