Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 64498

Summary: upgrading to apache-2.0.50-r1 and server cant load modules at startup
Product: Gentoo Linux Reporter: p cooper <pdcooper>
Component: New packagesAssignee: Apache Team - Bugzilla Reports <apache-bugs>
Severity: blocker    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description p cooper 2004-09-18 03:32:17 UTC
emerge -u apache and it emerges apache-2.0.50-r1
then restarting apache 
router/ # /etc/init.d/apache2 restart
 * Stopping apache2...
Syntax error on line 22 of /etc/apache2/conf/apache2.conf:
Cannot load /etc/apache2/modules/ into server: /etc/apache2/modules/mod_ac object file: No such file or directory
 * Starting apache2...   

On commenting out the line in apache2.conf   the error message is the next  uncommented module                                   

Reproducible: Always
Steps to Reproduce:
1.emerge -u apache 
2./etc/init.d/apache2 start

Actual Results:  
Syntax error on line 22 of /etc/apache2/conf/apache2.conf:
Cannot load /etc/apache2/modules/ into server:
/etc/apache2/modules/mod_ac object file: No such file or directory
 * Starting apache2... 

router modules # emerge info
Portage 2.0.50-r11 (default-x86-1.4, gcc-3.4.1, glibc-, 2.4.24)
System uname: 2.4.24 i586 AMD-K6(tm) 3D processor
Gentoo Base System version 1.5.3
distcc 2.11.1 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-march=k6-3 -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k6-3 -O3 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow aalib apache2 arts avi berkdb bitmap-fonts crypt cups dedicated
encode foomaticdb gd gdbm gif gtk gtk2 imagemagick imap java jpeg kde libg++
libwww maildir mmx motif mpeg mysql ncurses nls odbc oggvorbis pam pdflib perl
php png postgres python qt quicktime readline samba sasl sdl slang snmp spell
ssl svga tcpd truetype x86 xml2 xmms xprint xv zlib"

router modules #
Comment 1 Michael Tindal (RETIRED) gentoo-dev 2004-09-18 05:43:28 UTC
Could you post the contents of apache2.conf?
Comment 2 Elfyn McBratney (beu) (RETIRED) gentoo-dev 2004-09-18 10:39:50 UTC
I just hit this myself while re-emerging apache.  The module that causes the error is quite often random (at least here).  Using the overlay'ed apr (apr-0.9.5_pre20040917) fixed it.
Comment 3 p cooper 2004-09-18 15:02:29 UTC
outer ~ # cat /etc/apache2/conf/apache2.conf  |grep -v '^#'
ServerRoot /etc/apache2
PidFile /var/run/
ErrorLog logs/error_log
LogLevel warn
DocumentRoot /var/www/localhost/htdocs

LoadModule access_module                 modules/
LoadModule auth_module                   modules/
LoadModule auth_anon_module              modules/
LoadModule auth_dbm_module               modules/
LoadModule auth_digest_module            modules/
LoadModule include_module                modules/
LoadModule log_config_module             modules/
LoadModule env_module                    modules/
LoadModule mime_magic_module             modules/
LoadModule cern_meta_module              modules/
LoadModule expires_module                modules/
LoadModule headers_module                modules/
LoadModule usertrack_module              modules/
LoadModule unique_id_module              modules/
LoadModule setenvif_module               modules/
LoadModule proxy_module                  modules/
LoadModule proxy_connect_module          modules/
LoadModule proxy_ftp_module              modules/
LoadModule proxy_http_module             modules/
LoadModule mime_module                   modules/
LoadModule status_module                 modules/
LoadModule autoindex_module              modules/
LoadModule asis_module                   modules/
LoadModule info_module                   modules/
LoadModule cgi_module                    modules/
LoadModule cgid_module                   modules/
LoadModule vhost_alias_module            modules/
LoadModule negotiation_module            modules/
LoadModule dir_module                    modules/
LoadModule imap_module                   modules/
LoadModule actions_module                modules/
LoadModule speling_module                modules/
LoadModule userdir_module                modules/
LoadModule alias_module                  modules/
LoadModule rewrite_module                modules/

LoadModule file_cache_module             modules/
LoadModule echo_module                   modules/
LoadModule charset_lite_module           modules/
LoadModule cache_module                  modules/
LoadModule disk_cache_module             modules/
LoadModule mem_cache_module              modules/
LoadModule ext_filter_module             modules/
LoadModule case_filter_module            modules/
LoadModule case_filter_in_module         modules/
LoadModule deflate_module                modules/
LoadModule logio_module                  modules/

Include conf/modules.d/*.conf
Include conf/commonapache2.conf

Listen 80

<IfModule mod_log_config.c>
SetEnvIf Request_URI \webcam.$ webcam
CustomLog logs/access_log combined env=!webcam
CustomLog logs/access_log combined env=!VLOG

Include conf/vhosts/vhosts.conf

Timeout 300

KeepAlive On

MaxKeepAliveRequests 100

KeepAliveTimeout 15

<IfModule prefork.c>
StartServers         5
MinSpareServers      5
MaxSpareServers     10
MaxClients         150
MaxRequestsPerChild  0

<IfModule worker.c>
StartServers         2
MaxClients         150
MinSpareThreads     25
MaxSpareThreads     75
ThreadsPerChild     25
MaxRequestsPerChild  0

<IfModule perchild.c>
NumServers           5
StartThreads         5
MinSpareThreads      5
MaxSpareThreads     10
MaxThreadsPerChild  20
MaxRequestsPerChild  0

Alias /awstatsclasses "/var/www/localhost/cgi-bin/wwwroot/classes/"
Alias /awstatscss "/var/www/localhost/cgi-bin/wwwroot/css/"
Alias /awstatsicons "/var/www/localhost/cgi-bin/wwwroot/icon/"
ScriptAlias /awstats/ "/var/www/localhost/cgi-bin/wwwroot/cgi-bin/"

<Directory "/var/www/localhost/cgi-bin/wwwroot">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all

router ~ #                                                                
Comment 4 p cooper 2004-09-18 23:57:09 UTC
adding this 
 /ln -s modules/*.so . 
to /usr/lib/apache2
 has got rid of the module problem 

now I get 
router ~ # /etc/init.d/apache2 start
 * Starting apache2...
[Sun Sep 19 07:42:16 2004] [error] VirtualHost _default_:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
(98)Address already in use: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs    

router apache2 # cat /etc/apache2/conf/vhosts/vhosts.conf |grep 443
router apache2 #   

AFAIK I havent configured anything on 443                                      
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-09-19 01:27:05 UTC
it says port 443 is already in use.
so check with netstat:
netstat -anp |grep 443
Comment 6 p cooper 2004-09-19 15:27:45 UTC
I unmerged apache and then re-emerged it , which avoided the module errors.

the error message only occurs if apache2.conf contains the 
include conf/vhosts/vhosts.conf line (even if vhosts.conf contains commented lines)

router conf # cat /etc/apache2/conf/apache2.conf |grep vhosts
#If VLOG is defined in conf/vhosts/vhosts.conf, we use this entry
# vhosts directory and modify to suit your needs.
#Include conf/vhosts/vhosts.conf
#Include conf/vhosts/dynamic-vhosts.conf
#Include conf/vhosts/virtual-homepages.conf
router conf # /etc/init.d/apache2 start
 * Starting apache2...                                                                                            [ ok ]
router conf # /etc/init.d/apache2 stop
 * Stopping apache2...                                                                                            [ ok ]
router conf # nano apache2.conf
router conf # cat /etc/apache2/conf/apache2.conf |grep vhosts
#If VLOG is defined in conf/vhosts/vhosts.conf, we use this entry
# vhosts directory and modify to suit your needs.
Include conf/vhosts/vhosts.conf
#Include conf/vhosts/dynamic-vhosts.conf
#Include conf/vhosts/virtual-homepages.conf
router conf # ps -A |grep apache
router conf # /etc/init.d/apache2 start
 * Starting apache2...
[Sun Sep 19 23:22:10 2004] [error] VirtualHost _default_:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results                                                         [ ok ]
router conf #                                                      

Comment 7 Stuart Herbert (RETIRED) gentoo-dev 2004-09-20 01:02:24 UTC
Just a note to say that you should be using apache-2.0.51; all earlier versions contain known security / denial of service exploits.

Best regards,
Comment 8 p cooper 2004-09-20 02:43:04 UTC
ive unmerged what i had and emerged 2.0.51
the original problem that was raised with 2.0.50-r1 the symlinks seemd to be sorted - i this a different problem ( and a different bug)
Comment 9 p cooper 2004-09-20 14:06:12 UTC
sorted - the virtualhost definition needs a port adding ( didnt before......)
Comment 10 Michael Stewart (vericgar) (RETIRED) gentoo-dev 2005-02-01 22:29:16 UTC
Solved per reporter, closing.
Comment 11 Elfyn McBratney (beu) (RETIRED) gentoo-dev 2005-04-23 20:24:07 UTC
Comment 12 Daniel Kasak 2005-05-02 21:57:56 UTC
Not yet solved for me.

I've unmerged apache and mod_php.
I've deleted /etc/apache2.

No matter which version of apache ( version 2 ) I emerge, *NO* modules are placed in /usr/lib/apache2/modules

If I'm not missing something ( please tell me if I am ), could someone re-open this bug?