Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 644398

Summary: media-gfx/scantailor depends on deprecated Qt4
Product: Gentoo Linux Reporter: Andreas Sturmlechner <asturm>
Component: Current packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Severity: normal CC: vityokster
Priority: Normal Keywords: PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: removal on 2018-05-10
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 631788    

Description Andreas Sturmlechner gentoo-dev 2018-01-12 23:47:46 UTC
Qt4 is dead and going away. It appears someone has made progress with porting to Qt5, but none of it is upstream yet. We should track the Github issue (see URL).
Comment 1 Andreas Sturmlechner gentoo-dev 2018-01-13 00:08:11 UTC
My inquiry revealed a fork:
Comment 2 Erik Quaeghebeur 2018-03-31 23:07:43 UTC
(In reply to Andreas Sturmlechner from comment #1)
> My inquiry revealed a fork:
I have tried this version and it seems to work well.
Comment 3 Andreas Sturmlechner gentoo-dev 2018-04-10 10:04:11 UTC
(In reply to Erik Quaeghebeur from comment #2)
> (In reply to Andreas Sturmlechner from comment #1)
> > My inquiry revealed a fork:
> I have tried this version and it seems to work well.

Thanks. Of course it does not build with Qt-5.11, so I'll have to fix that first.
Comment 4 Larry the Git Cow gentoo-dev 2018-04-10 11:43:06 UTC
The bug has been referenced in the following commit(s):

commit e1ccf755ecf9f36b554198e5bc6c5316b90d1279
Author:     Andreas Sturmlechner <>
AuthorDate: 2018-04-10 10:46:05 +0000
Commit:     Andreas Sturmlechner <>
CommitDate: 2018-04-10 11:42:43 +0000

    media-gfx/scantailor-advanced: New package (scantailor fork)
    This bump is switching to scantailor-advanced, as the original
    project is nowhere near a Qt5-port, and stalled at this point.
    See also:
    Package-Manager: Portage-2.3.28, Repoman-2.3.9

 media-gfx/scantailor-advanced/Manifest             |   1 +
 .../files/scantailor-advanced-1.0.14-qt-5.11.patch | 182 +++++++++++++++++++++
 media-gfx/scantailor-advanced/metadata.xml         |  11 ++
 .../scantailor-advanced-1.0.14.ebuild              |  48 ++++++
 4 files changed, 242 insertions(+)}
Comment 5 Larry the Git Cow gentoo-dev 2018-05-10 05:34:12 UTC
The bug has been closed via the following commit(s):

commit 5abccc3ff797fea57e46963e5614d6d1d05e097b
Author:     Andreas Sturmlechner <>
AuthorDate: 2018-05-04 21:24:45 +0000
Commit:     Andreas Sturmlechner <>
CommitDate: 2018-05-10 05:33:59 +0000

    media-gfx/scantailor: Remove last-rited

 media-gfx/scantailor/Manifest                   |  1 -
 media-gfx/scantailor/metadata.xml               | 11 -----
 media-gfx/scantailor/scantailor- | 54 -------------------------
 profiles/package.mask                           |  5 ---
 4 files changed, 71 deletions(-)