Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 644056

Summary: sys-apps/acl-2.2.52-r1 - FATAL ERROR: attr/xattr.h does not exist.
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
sys-apps:acl-2.2.52-r1:20180109-192644.log
temp.tbz2

Description Toralf Förster gentoo-dev 2018-01-09 20:25:17 UTC
 * ERROR: sys-apps/acl-2.2.52-r1::gentoo failed (configure phase):
 *   econf failed
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_abi32+64_20180108-213228

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)




emerge -qpv sys-apps/acl
Comment 1 Toralf Förster gentoo-dev 2018-01-09 20:25:21 UTC
Created attachment 513980 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-01-09 20:25:24 UTC
Created attachment 513982 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-01-09 20:25:27 UTC
Created attachment 513984 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-01-09 20:25:31 UTC
Created attachment 513986 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-01-09 20:25:34 UTC
Created attachment 513988 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-01-09 20:25:37 UTC
Created attachment 513990 [details]
sys-apps:acl-2.2.52-r1:20180109-192644.log
Comment 7 Toralf Förster gentoo-dev 2018-01-09 20:25:40 UTC
Created attachment 513992 [details]
temp.tbz2
Comment 8 Mike Gilbert gentoo-dev 2018-01-09 20:32:01 UTC

*** This bug has been marked as a duplicate of bug 644048 ***
Comment 9 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-01-10 20:26:01 UTC
Fixed with 

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d09fc86f54e411052bd377e5dcc239be011be8a5

and p.masked in 

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=aca6e5c4ab50c3c96c7af8ee29fb77178849c46d

until further testing has been conducted.